Opened 5 years ago

Closed 5 years ago

#675 closed bug (Fixed)

globaldefs.h and SALINITY; correction to ana_passive.h

Reported by: kate Owned by: arango
Priority: minor Milestone: Release ROMS/TOMS 3.7
Component: Nonlinear Version: 3.7
Keywords: Cc:

Description (last modified by arango)

A colleague is trying to set up an idealized case with BULK_FLUXES, but without a forcing file. She's got all analytical options from ANA_CLOUD through ANA_WINDS, but ROMS still wants a forcing file. I believe the problem is in globaldefs.h near the line:

    ( defined SALINITY     && !defined ANA_SSFLUX)   || \

which should also have

      && !defined BULK_FLUXES

Change History (1)

comment:1 Changed 5 years ago by arango

  • Description modified (diff)
  • Resolution set to Fixed
  • Status changed from new to closed
  • Summary changed from globaldefs.h and SALINITY to globaldefs.h and SALINITY; correction to ana_passive.h

Yes, but the correct solution is to have:

    ( defined SALINITY     && !defined ANA_SSFLUX    && \
     (defined BULK_FLUXES  && !defined EMINUSP))     || \

since the freshwater flux is only computed in bulk_flux.F when EMINUSP is activated.


Also corrected a typo in ana_passive.h. We need to have instead:

# ifdef AGE_MEAN
      DO ip=1,NPT,2
        itrc=inert(ip)
        iage=inert(ip+1)
        DO k=1,N(ng)
          DO j=JstrT,JendT
            DO i=IstrT,IendT
              t(i,j,k,1,itrc)=???
              t(i,j,k,2,itrc)=t(i,j,k,1,itrc)
              t(i,j,k,1,iage)=0.0_r8
              t(i,j,k,2,iage)=t(i,j,k,1,iage)
            END DO
          END DO
        END DO
      END DO
# else
      ...
# endif

The first DO-loop need to have a step-size of 2. Otherwise, the age concentration is overwritten. Many thanks to John Wilkin for bringing this to my attention.

Note: See TracTickets for help on using tickets.