Opened 12 years ago

Closed 12 years ago

#273 closed defect (Done)

Allow or not processing of ghost points during reading/scattering

Reported by: arango Owned by: arango
Priority: major Milestone: Parallel Input/Output
Component: Parallelism Version: 3.2
Keywords: Cc:

Description

Allowed for now to process the scattering of data into ghost points in distributed-memory applications during reading. I don't like this that much but for now it is the way to go until we solve all missing exchanges in the adjoint-based algorithms during the processing of the state vector. A new cpp option NO_READ_GHOST is introduced to track these missing exchanges until we fix them.

I prefer not scatter data into ghost points in mp_scatter2d and mp_scatter3d but instead use any of the routines in mp_exchange.F. This will give us complete control of such operations.

I also corrected a bug in obs_read.F that caused the model to hang-up when the VERIFICATION option is activated. Many thanks to Gregoire Broquet for reporting this problem several weeks ago. I was finally able to reproduce the problem and track it in the debugger.

I also changed the order in which the stats are reported in routines get_ngfld*.F get_2dfld*.F, and get_3dfld*.F to facilitate the reading of such detailed information. It was easy to miss the information due to the size of input file names.

Change History (1)

comment:1 Changed 12 years ago by arango

  • Resolution set to Done
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.