Opened 12 years ago

Closed 12 years ago

#195 closed bug (Fixed)

OpenMP undeclared variables

Reported by: m.hadfield Owned by: arango
Priority: major Milestone: Release ROMS/TOMS 3.2
Component: Nonlinear Version: 3.2
Keywords: Cc:

Description (last modified by arango)

In ROMS/Modules/mod_grid.F, subroutine initialize_grid, at lines 421-447 we have

#ifdef _OPENMP
      IF (WESTERN_EDGE) THEN
        Imin=LBi
      ELSE
        Imin=Istr
      END IF
      ...
#else
      ...
#endif

The preprocessor macros WESTERN_EDGE, EASTERN_EDGE, etc (defined in globaldefs.h) involve variables, Istr, Iend, Jstr, Jend, but these are not declared. Consequently, the compiler gives error messages like

mod_grid.f90:269.14:

      IF (Iend.eq.Lm(ng)) THEN
             1
Error: Symbol 'iend' at (1) has no IMPLICIT type

Change History (1)

comment:1 Changed 12 years ago by arango

  • Description modified (diff)
  • Resolution set to Fixed
  • Status changed from new to closed

OH yes. Good catch. I forgot about these special initialization. The problem is also in mod_average.F, mod_bbl.F, mod_clima.F, mod_coupling.F, mod_diags.F, mod_forces.F, mod_mixing.F, mod_obs.F, mod_ocean.F, and mod_tides.F. Thank you.

Note: See TracTickets for help on using tickets.