ana_srflux.h problem

Report or discuss software problems and other woes

Moderators: arango, robertson

Post Reply
Message
Author
nobuhitomori
Posts: 22
Joined: Fri Jul 08, 2005 5:42 pm
Location: Kyoto University

ana_srflux.h problem

#1 Post by nobuhitomori »

Dear ROMS people,

I'm facing problem using BULK_FLUX options with SWAN coupling.
I got following error messages may be related to ana_srflux.h when I define both bulk_flux and swan_coupling options together.
Does anybody solve this problem ?

=============================================================
cd Build; /usr/local/mpich/bin/mpif90 -c -ip -O3 -pc80 -xW -I/usr/local/mct/include -free analytical.f90
fortcom: Error: analytical.f90, line 1409: The type of the actual argument differs from the type of the dummy argument. [LBJ]
& LBi, UBi, LBj, UBj, &
------------------------------------^
fortcom: Error: analytical.f90, line 1409: The type of the actual argument differs from the type of the dummy argument. [UBJ]
& LBi, UBi, LBj, UBj, &
-----------------------------------------^
fortcom: Error: analytical.f90, line 1410: The type of the actual argument differs from the type of the dummy argument. [NGHOSTPOINTS]

and etc

jcwarner
Posts: 982
Joined: Wed Dec 31, 2003 6:16 pm
Location: USGS, USA

Re: ana_srflux.h problem

#2 Post by jcwarner »

i don't think this has anything to do with the swan coupling.
Make sure you are using the most recent version.
Edit the Build/analytical.f90 file and go to lines 1409- 1410 area and see what that looks like. If all else fails please posts some of the lines in that region of the analytical.f90 code.

User avatar
m.hadfield
Posts: 523
Joined: Tue Jul 01, 2003 4:12 am
Location: NIWA

Re: ana_srflux.h problem

#3 Post by m.hadfield »

I think your problem relates to the source code changes announced here:

viewtopic.php?t=837

nobuhitomori
Posts: 22
Joined: Fri Jul 08, 2005 5:42 pm
Location: Kyoto University

Re: ana_srflux.h problem

#4 Post by nobuhitomori »

Dear jcwarner,

My ana_srflux.h located User/Functions was not the most recent version. After copying it from ROMS/Functions, I could compile
oceanM. I'm sorry for my bonehead mistake and I appreciate
for your suggestions.
jcwarner wrote:i don't think this has anything to do with the swan coupling.
Make sure you are using the most recent version.
Edit the Build/analytical.f90 file and go to lines 1409- 1410 area and see what that looks like. If all else fails please posts some of the lines in that region of the analytical.f90 code.

User avatar
arango
Site Admin
Posts: 1173
Joined: Wed Feb 26, 2003 4:41 pm
Location: DMCS, Rutgers University
Contact:

Re: ana_srflux.h problem

#5 Post by arango »

Yes, this is a bug. There are additional arguments to the mp_exchange2d call. Thank you for reporting this problem. I already correct it so you can update, see :arrow: tiket.

Post Reply