Error reading wetdry mask at psi points

Report or discuss software problems and other woes

Moderators: arango, robertson

Post Reply
Message
Author
Fay.Luxford
Posts: 3
Joined: Tue Aug 28, 2018 1:32 pm
Location: JBA Consulting

Error reading wetdry mask at psi points

#1 Post by Fay.Luxford » Fri Oct 05, 2018 8:56 am

Hi

I have installed the latest version of ROMS and I am trying to re-run an existing model. The model ran using a previous version of the code but now it fails when reading the initial conditions. Specifically it fails inside get_wetdry.f when I think it is trying to read the wetdry mask at psi points. When I look at the previous run log, I don't think it was even reading the wetdry mask from the initial conditions file previously, has a default option changed as I have not changed the control file? The initial conditions file I was provided with only contained a wetdry mask at the rho, u and v locations, so I added a mask at the psi points to see if this would correct the error. However it still persists. So I've modified get_wetdry.f to output what it is trying to find in the initial conditions file but Vname(1,idPwet) is blank with idPwet equal to 0.

Does anyone know what's going on? Or how I can fix this please? I have attached the control file I'm using, the initial conditions file which I've modified to add a wetdry mask for psi and the old and new run logs.

Any help would be much appreciated.

Cheers

Fay
Attachments
run.log
run log using the previous version of the code
(50.58 KiB) Downloaded 57 times
run.log
run log using the latest version of the code
(18.01 KiB) Downloaded 50 times
roms.in
control file
(16.26 KiB) Downloaded 50 times
ocean_ini2d_nc4.nc
Initial conditions file
(46.74 MiB) Downloaded 53 times

User avatar
wilkin
Posts: 507
Joined: Mon Apr 28, 2003 5:44 pm
Location: Rutgers University
Contact:

Re: Error reading wetdry mask at psi points

#2 Post by wilkin » Sat Oct 06, 2018 12:13 pm

Kate ... This is your branch of code - can you help? There is no revision number in the previous version log.
John Wilkin: DMCS Rutgers University
71 Dudley Rd, New Brunswick, NJ 08901-8521, USA. ph: 609-630-0559 jwilkin@rutgers.edu

User avatar
kate
Posts: 3695
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: Error reading wetdry mask at psi points

#3 Post by kate » Sat Oct 06, 2018 2:11 pm

My code is the same as Hernan's for get_wetdry.F.

Code: Select all

chinook03.rcs.alaska.edu 209% git diff trunk/roms-trunk */*/get_wetdry.F
chinook03.rcs.alaska.edu 210% 
My history of that file starts in 2014 and all versions read the psi mask (Pwet).

User avatar
wilkin
Posts: 507
Joined: Mon Apr 28, 2003 5:44 pm
Location: Rutgers University
Contact:

Re: Error reading wetdry mask at psi points

#4 Post by wilkin » Sat Oct 06, 2018 3:53 pm

I don't think the problem is in GET_WETDRY because the message to the log file that it read the V-points mask indicates it ran past reading the psi-ponts mask and went on to DEF_HIS.

So the error is in DEF_HIS or a subsequent WRT_HIS.

This a 2D horizontal configuration and I have no experience with that and wetting/drying.
John Wilkin: DMCS Rutgers University
71 Dudley Rd, New Brunswick, NJ 08901-8521, USA. ph: 609-630-0559 jwilkin@rutgers.edu

User avatar
kate
Posts: 3695
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: Error reading wetdry mask at psi points

#5 Post by kate » Sat Oct 06, 2018 6:45 pm

Oh, it's probably when the model reads an old history file before adding to it. Probably best to tell ROMS that NRREC = 0 as a fresh start on a run. You might have to extract the one record from the restart file and point to that as your initial file.

I'm afraid I was trying something with the wetting and drying that didn't actually work. I wanted to save the instantaneous wet-dry masks instead of the averages. It was all part of fussing with the offline biology code, having the model read the physical fields as "climatology" then only update the BGC tracers. Turns out if you have wetting and drying, then things go bad in the dry cells in offline mode, even if you beat it into behaving in online mode. Or should I say that I simply gave up before getting it to work.

Fay.Luxford
Posts: 3
Joined: Tue Aug 28, 2018 1:32 pm
Location: JBA Consulting

Re: Error reading wetdry mask at psi points

#6 Post by Fay.Luxford » Mon Oct 08, 2018 11:15 am

Thanks for your messages Kate and Wilkin.

Sorry for the confusion Wilkin, it ran past reading the psi-points wetdry mask because I commented out reading it in my testing: if you do this, then it fails later on with a segmentation error. I was testing to see if it could read the other masks. When it was not commented out, the model crashed reading the psi-points saying it could not find the variable in the initial conditions file, which made sense as it was looking for a variable with a blank name.

I have just tried re-running the model with the main trunk version of get_wetdry.f and with NRREC = 0. Unfortunately the model still crashes, I've attached the new run log and the errors which are printed to screen. Is there anything else I can try please?

Thanks

Fay
Attachments
Command line errors
Command line errors
run.log
new run log with NRREC=0
(16.35 KiB) Downloaded 43 times

User avatar
kate
Posts: 3695
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: Error reading wetdry mask at psi points

#7 Post by kate » Mon Oct 08, 2018 3:34 pm

So what is on line 207 of def_his.f90?

User avatar
wilkin
Posts: 507
Joined: Mon Apr 28, 2003 5:44 pm
Location: Rutgers University
Contact:

Re: Error reading wetdry mask at psi points

#8 Post by wilkin » Mon Oct 08, 2018 3:45 pm

Does you varinfo.dat have the metadata for the psi points wet/dry mask? Line 270 of def_his.f90 will be pretty close to the step defining the mask, for which it needs the Vinfo data leaded fro varinfo.dat.

Generally speaking, just switching in a subroutine (here get_wetdry.F) from another repository (myroms instead of kate) risks some inconsistency in results that might be confusing. Certainly, it's difficult for us to help you when we have an incomplete idea of what else you've changed or not updated (like varinfo).
John Wilkin: DMCS Rutgers University
71 Dudley Rd, New Brunswick, NJ 08901-8521, USA. ph: 609-630-0559 jwilkin@rutgers.edu

Fay.Luxford
Posts: 3
Joined: Tue Aug 28, 2018 1:32 pm
Location: JBA Consulting

Re: Error reading wetdry mask at psi points

#9 Post by Fay.Luxford » Thu Oct 11, 2018 1:02 pm

Thanks for the help. In the end I have decided just to compile an old version of the code which the model works with.

Cheers

Fay

Post Reply