Coastal blow-ups issues: WRF typhoon to ROMS [via COAWST]

Report or discuss software problems and other woes

Moderators: arango, robertson

Post Reply
Message
Author
lmp4
Posts: 38
Joined: Tue Aug 12, 2014 8:32 pm
Location: Imperial College London

Coastal blow-ups issues: WRF typhoon to ROMS [via COAWST]

#1 Post by lmp4 » Thu May 10, 2018 3:41 pm

I am constructing a high resolution coupled ROMS model of the South China Sea.
To be specific I am looking at a strong realistic typhoon simulation with WRF 2KM coupled to ROMS 4KM via COAWST.

However, I am finding continued issues near the coast just before the simulation ends. What’s strange is that my model is consistently blowing up when the typhoon is weakening near the end of my simulation (a few hours after landfall). Furthermore, every time a blow-up occurs I look at the affected area, try to re-grid it (maybe fill in more of the land/reduce it, etc.), re-smooth (via LP Bath smoothing) and my re-run still blowups, now in a slightly different along the coast. For example, here are the locations of some of the affected areas thus far.
Screen Shot 2018-05-10 at 13.59.22.png
All these islands and channels are proving to be very challenging! For instance, check out the bathymetry (scale for the figure below is in meters)! I think the LP BATH smooth algorithm is actually struggling to produce something sensible here (with strange square block-type pyramids) but to my understanding I think it's about the only and very best smoothing option I out there!
Screen Shot 2018-05-10 at 14.20.50.png
Now I have tried to be systematic and eliminate every possible concern by doing the following:

• Smoothed bathymetry using the LP solver to Rx01 = 0.1 (a quite extreme smoothing). This gives me quite low RX1 values. I have also performed HPGE runs as suggested on this forum (closed box with an analytical TS profile) but find there are no extreme bottom currents that form along the coastline.

• I thought perhaps the forcing required an extreme timestep so I changed the time step from 20 to 10 to 5 seconds, the latter being quite an extreme time step. I keep NDTFAST set to 28.

! Time-Stepping parameters.

NTIMES == 17280
DT == 15.0d0
NDTFAST == 28

• Changed the diffusion (TNU2), viscosity (VISC2) and wind stress momentum settings (Zos).


• Tried different vertical stretching and number of vertical levels (reduced to 20 to reduce RX1 values).

! Set vertical, terrain-following coordinates transformation equation and
! stretching function (see below for details), [1:Ngrids].

Vtransform == 2 ! transformation equation
Vstretching == 2 ! stretching function

! Vertical S-coordinates parameters (see below for details), [1:Ngrids].

THETA_S == 5.0d0 ! surface stretching parameter
THETA_B == 0.4d0 ! bottom stretching parameter
TCLINE == 250.0d0 ! critical depth (m)

• Changed to different length-scale turbulence closure parameters. Tried GEM and k-k1.

• Went through my entire .h and mixed up some settings such as changing TSMAPDATA to U3HADVECTION/C4VADVECTION.

Currently, my latest experiment is trying some more radical smoothing say….

• rx0 = 0.05 smoothing to anywhere <30m.
My thoughts are maybe this will help with the delta area.


Also, I have a few ideas what could be causing the problem:

• A lack of river source at Zhujiang River Estuary… Maybe some strange things with salinity here? A lot of the recent blowups are occurring near this delta so I think this inlet could be a potential source of problems. 
[The extreme smoothing applied to <30m may help?]

• The extreme wind stress causing continues issues near the coast partially causing havoc with zeta! I’ve noticed some strange large fluctuations along the coastline when the typhoon is near landfall. [Maybe wetting/drying would help this issue? i.e. to stop huge build ups in zeta. Otherwise, I’m little unsure how to tackle extreme forcing in a realistic model].

• Perhaps the smoothing is actually too extreme? I originally went down to rx0=0.1 from rx0=0.3 since the model was blowing up quite early for 0.3... I could try a combination with some form of targeted smoothing via the HPGE experiments (I wasn't sure what constitutes as extreme bottom currents) and LP smooth.

Lots to ponder... I was wondering if anyone else had some different insights that I'm missing?

jcwarner
Posts: 798
Joined: Wed Dec 31, 2003 6:16 pm
Location: USGS, USA

Re: Coastal blow-ups issues: WRF typhoon to ROMS [via COAWST

#2 Post by jcwarner » Thu May 10, 2018 4:46 pm

so this sounds like a roms coastline problem (not necessarily coawst). To be sure, what do the su/vstr look like? How about the surface heat fluxes?

-john

lmp4
Posts: 38
Joined: Tue Aug 12, 2014 8:32 pm
Location: Imperial College London

Re: Coastal blow-ups issues: WRF typhoon to ROMS [via COAWST

#3 Post by lmp4 » Thu May 10, 2018 5:05 pm

Here are the su/vstr fields about an hour before the simulation blows up and just when the typhoon makes landfall. I never noticed this but there seems to be somewhat the discontinuity between my outer and inner WRF domain (most notably for sustr in the affected delta). It's a small difference (0.08 N m^-2) but it's so shallow in the region maybe that's what's causing zeta and u/s fields to blow up.
Screen Shot 2018-05-10 at 17.50.41.png
Screen Shot 2018-05-10 at 17.51.58.png
I can't say I'm hugely experienced in WRF (this is my first venture into Typhoon modelling) but I think if I apply some expended damping on the boundary of the inner domain maybe I won't get such a continuity, and a smoother field might result in a more stable simulation for ROMS.

I must say I probably should have looked at this forcing to start with... but in any case thanks for the suggestion John!

User avatar
kate
Posts: 3682
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: Coastal blow-ups issues: WRF typhoon to ROMS [via COAWST

#4 Post by kate » Thu May 10, 2018 5:32 pm

Do you have wetting and drying turned on? #define WET_DRY

lmp4
Posts: 38
Joined: Tue Aug 12, 2014 8:32 pm
Location: Imperial College London

Re: Coastal blow-ups issues: WRF typhoon to ROMS [via COAWST

#5 Post by lmp4 » Thu May 10, 2018 10:19 pm

At the moment I have wetting and drying turned off. At the time I thought it might complicate things having it on and but I'll give it a go with it on!

lmp4
Posts: 38
Joined: Tue Aug 12, 2014 8:32 pm
Location: Imperial College London

Re: Coastal blow-ups issues: WRF typhoon to ROMS [via COAWST

#6 Post by lmp4 » Fri May 25, 2018 3:50 pm

So I've concluded this was 100% a problem with the inner and outer WRF domain discontinuities. As a test/fix we decided to create a 4km WRF/ROMS (single domain) coupled system (i.e. without any nesting) and ROMS runs smoothly without any issue in zeta or resulting blow-ups :D

However, I'm not sure how good of a fix this is for our long term goals since this drives up the cost of running the model significantly. Furthermore, I'm not too sure of the effect of downscaling the WRF bdy conditions from GFS (25km) to a 4km model domain! :shock:

I will look into the forums for COAWST and WRF to see if anyone else had encountered this issue.

Post Reply