Doubt about the Time variable in the CLMNAME file

Cool Findings and Plots

Moderators: arango, robertson

Post Reply
Message
Author
User avatar
leilanepassos
Posts: 6
Joined: Wed Jan 20, 2010 4:39 pm
Location: Universidade de São Paulo

Doubt about the Time variable in the CLMNAME file

#1 Post by leilanepassos » Mon Feb 27, 2017 10:45 pm

Hi,

I'm trying to use the CLMNAME files. I tried with 12 climatology files. Each month is a 30 years mean of the CCSM4 model:

CLMNAME == /scratch/user/Data/climatology/clm_M01.nc |
/scratch/user/Data/climatology/clm_M02.nc |
/scratch/user/Data/climatology/clm_M03.nc |
/scratch/user/Data/climatology/clm_M04.nc |
/scratch/user/Data/climatology/clm_M05.nc |
/scratch/user/Data/climatology/clm_M06.nc |
/scratch/user/Data/climatology/clm_M07.nc |
/scratch/user/Data/climatology/clm_M08.nc |
/scratch/user/Data/climatology/clm_M09.nc |
/scratch/user/Data/climatology/clm_M10.nc |
/scratch/user/Data/climatology/clm_M11.nc |
/scratch/user/Data/climatology/clm_M12.nc

with cycle_length=365.25 and temp_time and salt_time with values of the year 1985 (time = 724655.5, 724685, 724714.5, 724745, 724775.5, 724806, 724836.5, 724867.5, 724898, 724928.5, 724959, 724989.5). I used the dates of the months of my first year simulation (1985). Is this right?

The output file of the simulation shows that model use just the files clm_M01.nc and clm_M02.nc for all months of the year 1985. In other words, the model doesn't use the average files from March to December (03-12). And the simulation stops in the nov1985 with the error:

NETCDF_OPEN - unable to open existing NetCDF file:
^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^@^A^@^@^
call from: inquire.F




Temp_time and salt_time are wrong? What date values should I put in a time variable of the climatology file?

Thanks for help.

User avatar
kate
Posts: 3718
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: Doubt about the Time variable in the CLMNAME file

#2 Post by kate » Tue Feb 28, 2017 12:00 am

I think the cycle_length works when all the records are in one file. I haven't tried it with such large times, so I don't know what happens then. Here are the times I use in one file:

Code: Select all

	double runoff_time(runoff_time) ;
		runoff_time:long_name = "runoff_time" ;
		runoff_time:units = "days since 1900-01-01 00:00:00" ;
		runoff_time:cycle_length = 365.25 ;
 runoff_time = 15.21875, 45.65625, 76.09375, 106.53125, 136.96875, 167.40625, 
    197.84375, 228.28125, 258.71875, 289.15625, 319.59375, 350.03125 ;

User avatar
leilanepassos
Posts: 6
Joined: Wed Jan 20, 2010 4:39 pm
Location: Universidade de São Paulo

Re: Doubt about the Time variable in the CLMNAME file

#3 Post by leilanepassos » Tue Mar 07, 2017 9:05 pm

Hi Kate thanks for the answer!

My times are large because my Reference Time is "days since 0001-01-01 00:00:00". So, these numbers below match the time for 1985 (First year of my simulation).

(time = 724655.5, 724685, 724714.5, 724745, 724775.5, 724806, 724836.5,
724867.5, 724898, 724928.5, 724959, 724989.5; )

I did a test integration in which I used the CLM_files separated, but without the "cycle_length" attribute:

CLMNAME == /scratch/user/Data/climatology/clm_M01.nc |
/scratch/user/Data/climatology/clm_M02.nc |
/scratch/user/Data/climatology/clm_M03.nc |
/scratch/user/Data/climatology/clm_M04.nc |
/scratch/user/Data/climatology/clm_M05.nc |
/scratch/user/Data/climatology/clm_M06.nc |
/scratch/user/Data/climatology/clm_M07.nc |
/scratch/user/Data/climatology/clm_M08.nc |
/scratch/user/Data/climatology/clm_M09.nc |
/scratch/user/Data/climatology/clm_M10.nc |
/scratch/user/Data/climatology/clm_M11.nc |
/scratch/user/Data/climatology/clm_M12.nc

In 1985 ROMS reads the files correctly. I started the integration in 01/16/1985. Then, I have seen that the ROMS integration in a specific month needs to read the CLM_files of the next 3 months, for example, for January (1985) the model reads the files M01, M02 and M03 (I don't know why It reads the month M03). The problem is when the integration reaches the month 11/1985, ROMS stops because it doesn't find the following months. Actually, it finds the months 11/1985 and 12/1985, but it cannot find 01/1986. Obviously, I did not put this CLM_file as I am showing above. Thus:

(1) What should I do for the ROMS to understand that it should return for the first climatology month (M01)?

(2) Should I enable something so that the model is able to automatically read the "/scratch/user/Data/climatology/clm_M01.nc" again?


I already tried it with one CLM_file and cycle_length=365.25, but the simulation stops in the month 11 (1985) too. Just like when I tried with separated files and no "cycle_length".

To enable the nudging to a climatology, I have changed the ".in" file as below (just for temperature and salinity):
LtracerCLM == T T
LnudgeTCLM == T T

and put the NUDNAME file.

User avatar
kate
Posts: 3718
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: Doubt about the Time variable in the CLMNAME file

#4 Post by kate » Wed Mar 08, 2017 6:26 am

I told you what works for me: one file, times between zero and the cycle_length. It will use the same 12 records over for each cycle.

Post Reply