A confusion in the run

General scientific issues regarding ROMS

Moderators: arango, robertson

Post Reply
Message
Author
sun_92
Posts: 19
Joined: Sat Apr 07, 2018 12:59 am
Location: INDIAN INSTITUTE OF TECHNOLOGY KHARAGPUR

A confusion in the run

#1 Post by sun_92 » Fri Mar 01, 2019 6:21 am

Hey all,
I have given a test simulation with the biological module fennel on, however the model stops at one point each time. I'm getting this error.
SET_2DFLD - current model time exceeds ending value for variable: Tair
TDAYS = 360.0035
Data Tmin = 0.0000 Data Tmax = 360.0000
Data Tstr = 0.0000 Data Tend = 45.0000
TINTRP1 = 360.0000 TINTRP2 = 360.0000
FAC1 = -0.0035 FAC2 = 0.0035
I'm attaching the log file of my run

Please help me.
Attachments
log_fennel_rst_13feb.txt
(18.17 MiB) Downloaded 65 times

User avatar
kate
Posts: 3802
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: A confusion in the run

#2 Post by kate » Mon Mar 04, 2019 9:58 pm

What we need to see is the ncdump on your Tair file. Are these monthly means you are cycling through? Do you have the cycle_length attribute set?

sun_92
Posts: 19
Joined: Sat Apr 07, 2018 12:59 am
Location: INDIAN INSTITUTE OF TECHNOLOGY KHARAGPUR

Re: A confusion in the run

#3 Post by sun_92 » Tue Mar 05, 2019 6:37 am

I'm attaching the ncdump txt of the forcing file. Yes we have set cycle length to 360. I'm facing problem only when i switch on biology, the same files are running fine without fennel. Kindly help me
Attachments
frc.txt
(7.58 KiB) Downloaded 77 times

sun_92
Posts: 19
Joined: Sat Apr 07, 2018 12:59 am
Location: INDIAN INSTITUTE OF TECHNOLOGY KHARAGPUR

Re: A confusion in the run

#4 Post by sun_92 » Wed Mar 13, 2019 4:28 am

Can anyone please help me with the simulation over Indian domain using bio fennel? It stops exactly after an year in the climatological simulation. However the same files are running fine with Physical simulation. Please can you help me in this regard?

sun_92
Posts: 19
Joined: Sat Apr 07, 2018 12:59 am
Location: INDIAN INSTITUTE OF TECHNOLOGY KHARAGPUR

Re: A confusion in the run

#5 Post by sun_92 » Fri Mar 15, 2019 4:30 am

Can anyone please help me with the run. I'm attaching the screenshot of the error
Attachments
Screenshot from 2019-03-14 09-07-32.png

sun_92
Posts: 19
Joined: Sat Apr 07, 2018 12:59 am
Location: INDIAN INSTITUTE OF TECHNOLOGY KHARAGPUR

Re: A confusion in the run

#6 Post by sun_92 » Fri Mar 15, 2019 4:32 am

I tried with cycle length 360 and 365.25 both are causing errors, however, my physical run is successful with the same files. I'm stuck with this error since a long time, so kindly help me.

User avatar
kate
Posts: 3802
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: A confusion in the run

#7 Post by kate » Fri Mar 15, 2019 4:36 am

This is why people invest in learning debuggers such as totalview, ddt, gdb. It's a tough road, but sometimes it's the only way to figure out what's really going on.

Post Reply