NO3_sflux error

Discussion about coupled ecosystem models

Moderators: arango, robertson

Post Reply
Message
Author
cschultz
Posts: 13
Joined: Wed May 27, 2009 10:43 pm
Location: WHOI/MIT

NO3_sflux error

#1 Post by cschultz » Tue Nov 09, 2010 7:40 pm

Hello everyone!


I tried to run the Fennel model today but I keep getting the following error:

GET_2DFLD - unable to find requested variable: NO3_sflux
in files:
../Data/roms_blk_pair_teste1.nc
../Data/roms_blk_lwrad_teste1.nc
../Data/roms_blk_qair_teste1.nc
../Data/roms_blk_rain_teste1.nc
../Data/roms_blk_swrad_teste1.nc

GET_2DFLD - unable to find requested variable: NO3_sflux
in files:
../Data/roms_blk_pair_teste1.nc
../Data/roms_blk_lwrad_teste1.nc
../Data/roms_blk_qair_teste1.nc
../Data/roms_blk_rain_teste1.nc
../Data/roms_blk_swrad_teste1.nc
../Data/roms_blk_tair_teste1.nc

My understanding is that it represents superficial flux of nitrate, don`t know if that is correct. Do I really need nutrient fluxes or am I able to work without them? Is it just nitrate? If I have to define them, could I just create a variable set to zero at all points (will that be ok to represent an area without surface input of nutrients)?

I also have another question: can I set some biogeochemical variables to be analysed analitically and supply others in a netcdf input? Or does ana-biology define all of them as analytical?

Thank you in advance!

User avatar
nrecord
Posts: 11
Joined: Thu May 27, 2010 3:19 pm
Location: University of Maine

Re: NO3_sflux error

#2 Post by nrecord » Thu Nov 11, 2010 7:42 pm

I have a similar error:

GET_2DFLD - unable to find requested variable: NO3_sflux
in file:
./bio_toy_frc.nc


Did you ever get this worked out?

alazhar
Posts: 17
Joined: Wed Dec 03, 2008 2:06 pm
Location: PML

Re: NO3_sflux error

#3 Post by alazhar » Wed Nov 17, 2010 2:28 pm

analytically you can solve it by :

# define ANA_SPFLUX
# define ANA_BPFLUX

which then call ana_stflux and ana_btflux to give certain values (zero by default) for the tracers.

-al

Post Reply