Negative concentration values in bio_Fennel model

Discussion about coupled ecosystem models

Moderators: arango, robertson

Post Reply
Message
Author
jsole
Posts: 4
Joined: Fri Mar 23, 2007 12:34 pm
Location: Institute of Marine Sciences (CSIC)

Negative concentration values in bio_Fennel model

#1 Post by jsole » Fri Aug 20, 2010 3:51 pm

Hi everybody,
I am running a Roms setup for the Alboran Sea with bio Fennel model with the last updated source code (version 3.4, updated two weeks ago). My application using only the physics works fine and gives reasonable results. The problem comes when I turn on the bio_Fennel model. It starts without problem and all the variables are positive. After a while, the model starts to give negative values for the phytoplankton and then, after few iterations more, the model gives negative values for all the other variables. I have checked when it occurs and after 11 time steps (from the start) it gives a few (two) points (in the Gibraltar Strait) with negative values. That starts to propagate over the domain till the model crashes. I have checked the boundary values and there are all positive values for all the variables allways.
Can someone give some advice about what is going on in there?
Many thanks in advance,
Jordi

Ps. I am using the default bio_Fennel.in to setup the biological model parameters

User avatar
kate
Posts: 3678
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: Negative concentration values in bio_Fennel model

#2 Post by kate » Fri Aug 20, 2010 5:24 pm

Some of us blithely limit the bio variables to be always at least zero. You might be able to change tracer advection schemes and get better behavior. Can you figure out which process is making it go negative? Is it in the physics or in the biology?

jsole
Posts: 4
Joined: Fri Mar 23, 2007 12:34 pm
Location: Institute of Marine Sciences (CSIC)

Re: Negative concentration values in bio_Fennel model

#3 Post by jsole » Fri Aug 20, 2010 7:07 pm

Many thanks Kate for your answer,
I cannot be able to figure out what is the process that makes the biological tracer go to negative values. The negative values appear in the points near the bottom where the fluxes (in Gibraltar strait) are really high (1 sverdrup inflow to Med and 0.9 sverdrup outflow to Atlantic). I'll try to run it using a different advection scheme in the tracers and try to figure out what is the process that makes the negative values. Thanks again.
Jordi

jsole
Posts: 4
Joined: Fri Mar 23, 2007 12:34 pm
Location: Institute of Marine Sciences (CSIC)

Re: Negative concentration values in bio_Fennel model

#4 Post by jsole » Mon Aug 23, 2010 11:15 am

I have changed the advection scheme and no more negative concentrations in the biology after 10 days of simulation, so the problem is solved. Many thanks Kate for your help.
Jordi

alazhar
Posts: 17
Joined: Wed Dec 03, 2008 2:06 pm
Location: PML

Re: Negative concentration values in bio_Fennel model

#5 Post by alazhar » Tue Aug 24, 2010 10:41 am

Hi Jordi,

Which tracer advection scheme did you use before and after the negative correction?
Thanks.

-al

jsole
Posts: 4
Joined: Fri Mar 23, 2007 12:34 pm
Location: Institute of Marine Sciences (CSIC)

Re: Negative concentration values in bio_Fennel model

#6 Post by jsole » Fri Feb 25, 2011 1:09 am

Hi Al,
I have used for the tracer advection before TS_C4VADVECTION, and to avoid the negative values the TS_MPDATA.
Regards,
Jordi

Post Reply