Biotoy testcase error

Discussion about coupled ecosystem models

Moderators: arango, robertson

Post Reply
Posts: 13
Joined: Wed May 27, 2009 10:43 pm
Location: WHOI/MIT

Biotoy testcase error

#1 Post by cschultz »

Hi everyone!

I`m trying to run the biotoy testcase anda what I did was set the file to use:

! Input NetCDF file names, [1:Ngrids].

GRDNAME == /Users/cristinaschultz/ROMS/
ININAME == /Users/cristinaschultz/ROMS/
ITLNAME == /dev/null
IRPNAME == /dev/null
IADNAME == /dev/null
CLMNAME == /dev/null
BRYNAME == /dev/null
FWDNAME == /dev/null
ADSNAME == /dev/null

NFFILES == 1 ! number of forcing files

FRCNAME == /Users/cristinaschultz/ROMS/ ! forcing file 1, grid 1

with the files I downloaded at
I also defined BIO_FENNEL on bio_toy.h and undefined ECOSIM. The model compiles with no problem and also runs without any error message, but it doesn`t write any output files. On the terminal it shows:

ROMS/TOMS - Input error ............. exit_flag: 2

ERROR: Abnormal termination: NetCDF INPUT.
REASON: No error

There seems to be on the forum some debate over versions of the fasham and ecosim models and also some problems with the files names changing from fennel to fasham, but I have doublechecked the latest version of the inputs I used. Could anyone help me please?

thanks already!

User avatar
Posts: 3876
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: Biotoy testcase error

#2 Post by kate »

Could you double-check your output? There may well be another error message, perhaps above some intervening messages above that reported input error.

User avatar
Posts: 575
Joined: Mon Apr 28, 2003 5:44 pm
Location: Rutgers University

Re: Biotoy testcase error

#3 Post by wilkin »

I just ran this test case to see what's wrong and amongst the output is the clue:

Code: Select all

SET_2DFLD  - current model time exceeds ending value for variable: Pair
              TDAYS     =        366.0000
              Data Tmin =          0.0000  Data Tmax =        364.0000
The initial time in the file is set to 366 days, which is outside the 0 to 364 days of the forcing file. The initial time in is 0 and that file works OK.

So change that value of ocean_time in and this should work (I hope you know how to change the data inside a netcdf file).

I thought the forcing file distributed for this test case used the cycle_length = 365.0 attribute to cycle the time, in which this error would not have occurred (ROMS would have extracted day=1 from the forcing file to correspond to ocean_time=366).

We will make changes to these files and place corrected versions at soon.
John Wilkin: DMCS Rutgers University
71 Dudley Rd, New Brunswick, NJ 08901-8521, USA. ph: 609-630-0559

User avatar
Site Admin
Posts: 1136
Joined: Wed Feb 26, 2003 4:41 pm
Location: DMCS, Rutgers University

Re: Biotoy testcase error

#4 Post by arango »

I updated and added the BIO_TOY input NetCDF file to the svn repository. The grid, initial conditions, and forcing files are now located in Data/ROMS/Grid, Data/ROMS/Initial, and Data/ROMS/Forcing, respectively. Check the following trac :arrow: ticket for details.

Thank you for bringing this to my attention. Please update.

Posts: 13
Joined: Wed May 27, 2009 10:43 pm
Location: WHOI/MIT

Re: Biotoy testcase error

#5 Post by cschultz »

I tried changing the ocean_time on the old file and also tried running with the new file. They both worked just fine! Thank you very much!

Post Reply