ARPACK lib does not have `dsteqr_' `dpotri_' `dpotrf_'

Discussion on computers, ROMS installation and compiling

Moderators: arango, robertson

Post Reply
Posts: 30
Joined: Sun Mar 10, 2019 2:34 pm
Location: University of Tsukuba

ARPACK lib does not have `dsteqr_' `dpotri_' `dpotrf_'

#1 Post by bangdt » Wed May 22, 2019 5:56 pm

I recently compiled ARPACK with ARmake.mpif90-Linux file and set
FFLAGS = -u -Bstatic -c -frepack-arrays -O3 -ffast-math -O3 -w -fno-strict-overflow

The version used is come with trunk/LIB folder which is described that support for compile and run ROMS.

recently known problem with ARPACK and `dsteqr_' `dpotri_' `dpotrf_' is ... index.html

"Based on analyzing the GFortran 9 output of compilation of the reference LAPACK included in R, it seems that 38 LAPACK functions may be affected: dlarrc dpotrs dtrtrs dgetrs dlarzb dlatzm dlarfx ilaenv dtrtri dsygst dpotrf dlauum dpbtrf dlalsd dbdsdc dpbsv dpftrs dposv dpotri dppsv dpstrf dsbgv dspsv dsytri2 zdrscl zgesv zgetrf zgetrs zlaed0 zlahr2 zlalsd zlarfx zlatdf zlauum zpotrf zpotri ztrtri ztrtrs.

In Ubuntu 19.04, all of GFortran 7,8,9 are already with this problem (7.4.0-8ubuntu1, 8.3.0-6ubuntu1, 9-20190402-1ubuntu1). GFortran 6 is not affected and works fine. GFortran 8 is the default. In Debian Sid, GFortran 7 and GFortran 8 already have the problem (‘Debian 8.3.0-7’, ‘Debian 7.4.0-9’). In Debian Buster, GFortran 8 (‘Debian 8.3.0-6’) already has the problem. In Debian Stretch, GFortran 6 (‘Debian 6.3.0-18+deb9u1’) is ok. In Fedora 30, GFortran 9 (‘Red Hat 9.1.1-1’) already has the problem. I’ve only been looking at x86_64."

Please help me to compile the lib, I have used both gfortran version 4.8.5 and 7.4.0 to compile with all previous version in tag with no successed.

Posts: 30
Joined: Sun Mar 10, 2019 2:34 pm
Location: University of Tsukuba

Re: ARPACK lib does not have `dsteqr_' `dpotri_' `dpotrf_'

#2 Post by bangdt » Fri May 24, 2019 9:14 am

I have solved the problem by linking the right mpich version for ROMS to use. With the same config for ARmake I built lparpack and larpack.

From this I have make RomsM and run with ./build_roms.bash -j 4
the model run for about 2hours and hang with 100% cpu usage but no change in bash window. the last information is


CONGRAD - Conjugate Gradient Information:

Ndatum = 0006815

(001,050): Residual estimate, eps = 1.2568804E-01
(001,050): Reduction in gradient norm, Greduc y-space = 8.8995668E-04
(001,050): Reduction in gradient norm, Greduc v-space = 8.8995668E-04
(001,050): First guess initial data misfit, Jf = 1.9945742E+04
(001,050): State estimate data misfit, Jdata = 2.5485116E+03
(001,050): Model penalty function, Jmod = 1.4259159E+03
(001,050): Optimal penalty function, Jopt = 3.9744275E+03

(001,050): Actual Model penalty function, Jb = 1.4259315E+03
(001,050): Actual data penalty function, Jobs = 2.5484962E+03

(001,050): Actual total penalty function, Jact = 3.9744277E+03

(001,050): Lanczos vectors - cg_delta, cg_beta, zwork:

001 1.33975971E+02 0.00000000E+00 -2.81416446E+01
002 1.14570913E+03 2.67057120E+02 1.35891331E+01
003 6.04847391E+02 5.22872712E+02 -1.54029213E+01
004 3.16827061E+02 1.58734654E+02 1.39290937E+01
005 2.18735325E+02 1.27114590E+02 -1.54831672E+01
006 3.48769454E+02 1.51247882E+02 1.06852707E+01
007 2.69139968E+02 1.24501000E+02 -1.11236039E+01
008 2.07518888E+02 1.38202952E+02 1.20364975E+01
009 3.61556469E+02 1.18740529E+02 -8.08894569E+00
010 2.18270757E+02 1.67289201E+02 8.93895455E+00
011 1.23285653E+02 6.65630882E+01 -8.98274310E+00
012 1.49658962E+02 6.69143664E+01 7.65813015E+00
013 1.41358671E+02 8.19831858E+01 -6.64811008E+00
014 7.71995218E+01 3.99873166E+01 7.80072595E+00
015 1.81212542E+02 6.80767388E+01 -4.94107439E+00
016 1.07049542E+02 7.04510894E+01 5.17148381E+00
017 8.55306080E+01 4.53523545E+01 -4.53120689E+00
018 9.23443509E+01 3.96372579E+01 3.86045658E+00
019 1.21399375E+02 5.61125626E+01 -3.15235541E+00
020 1.13970521E+02 5.88198039E+01 2.82343454E+00
021 1.30310969E+02 6.05609489E+01 -2.25173780E+00
022 8.10762793E+01 5.27630824E+01 2.32049103E+00
023 9.33510944E+01 3.83552366E+01 -1.80752769E+00
024 8.71292865E+01 4.90108986E+01 1.62681583E+00
025 7.11058362E+01 3.62993455E+01 -1.46434449E+00
026 7.18388196E+01 3.67720845E+01 1.22568763E+00
027 7.51178148E+01 3.36106253E+01 -1.01768275E+00
028 7.06178805E+01 3.87974445E+01 9.08564390E-01
029 7.10768274E+01 3.32891530E+01 -7.41304580E-01
030 7.23266266E+01 3.50581568E+01 6.40200193E-01
031 6.94377058E+01 3.61992220E+01 -5.61192949E-01
032 6.38852770E+01 3.32746896E+01 4.74631084E-01
033 5.60081581E+01 2.94495162E+01 -3.95538488E-01
034 5.16082324E+01 2.47909718E+01 3.29786439E-01
035 5.59950948E+01 2.57540784E+01 -2.80107546E-01
036 5.42130249E+01 2.93366230E+01 2.45130559E-01
037 6.14204297E+01 2.76968354E+01 -1.83120547E-01
038 6.25953157E+01 2.87996739E+01 1.54793487E-01
039 5.45979323E+01 3.21509696E+01 -1.37337542E-01
040 5.48624949E+01 2.47310472E+01 1.01960306E-01
041 5.05398188E+01 2.58705087E+01 -8.49343769E-02
042 6.40274510E+01 2.64529205E+01 6.25565345E-02
043 6.05711338E+01 3.25082395E+01 -5.40962276E-02
044 4.64022855E+01 2.57177419E+01 4.83349994E-02
045 4.78175478E+01 2.30426174E+01 -3.69585454E-02
046 4.65605967E+01 2.19521412E+01 2.97694020E-02
047 4.71426917E+01 2.44441717E+01 -2.35132498E-02
048 5.49688101E+01 2.50089353E+01 1.52261384E-02
049 5.36653759E+01 2.54899538E+01 -9.76546945E-03
050 5.09420755E+01 2.66310193E+01 5.10510031E-03
051 2.46200930E+01


could anyone have an idea?

Posts: 30
Joined: Sun Mar 10, 2019 2:34 pm
Location: University of Tsukuba

Re: ARPACK lib does not have `dsteqr_' `dpotri_' `dpotrf_'

#3 Post by bangdt » Fri May 24, 2019 4:31 pm

Problem solved.
But I feel a little bit bored in lonely. :?

Posts: 30
Joined: Sun Mar 10, 2019 2:34 pm
Location: University of Tsukuba

Re: ARPACK lib does not have `dsteqr_' `dpotri_' `dpotrf_'

#4 Post by bangdt » Mon May 27, 2019 6:09 am

This is the results

Post Reply