Questions on ROMS compiling with ifort

Discussion on computers, ROMS installation and compiling

Moderators: arango, robertson

Post Reply
Message
Author
han
Posts: 13
Joined: Thu Mar 29, 2018 5:03 pm
Location: Stony Brook University

Questions on ROMS compiling with ifort

#1 Post by han » Fri Jun 01, 2018 4:04 am

Hi,

Does anyone meet with such error when compiling the Upwelling case on Linux by ifort?

ipo: warning #11015: Warning unknown option -no_compact_unwind
ipo: warning #11015: Warning unknown option -stack_size
ld: unrecognized -a option `ck_size'
make: *** [/R1/gsb/MARKOV/ROMS/Projects/Upwelling/oceanG] Error 1

I checked the cluster and found the process was using Linux-ifort.mk, and the first ipo is due to turning on the DEBUG.
But I don't understand why it can't recognize ck_size, seems like when reading -stack_size, it reads -st as a word, and can't read 'a'.

Does anyone using ifort meet with same problem?

User avatar
kate
Posts: 3796
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: Questions on ROMS compiling with ifort

#2 Post by kate » Fri Jun 01, 2018 5:06 am

Yes, someone already asked about this a week or so ago:viewtopic.php?f=19&t=4869&p=18902&hilit=ifort#p18902

han
Posts: 13
Joined: Thu Mar 29, 2018 5:03 pm
Location: Stony Brook University

Re: Questions on ROMS compiling with ifort

#3 Post by han » Fri Jun 01, 2018 12:42 pm

kate wrote:Yes, someone already asked about this a week or so ago:viewtopic.php?f=19&t=4869&p=18902&hilit=ifort#p18902
Thanks, kate.

But I met with another problem.

After I comment out the stack_size, it works well in a serial mode.

When I use MPI and submit the job to a compute node, it meets with an error
./oceanG: error while loading shared libraries: libnetcdff.so.6: cannot open shared object file: No such file or directory


I do export the library path by export LD_LIBRARY_PATH=/opt/netcdf4/lib:$LD_LIBRARY_PATH

It still doesn't work.

I attached my build.bash
Attachments
build.bash
(17.57 KiB) Downloaded 84 times

han
Posts: 13
Joined: Thu Mar 29, 2018 5:03 pm
Location: Stony Brook University

Re: Questions on ROMS compiling with ifort

#4 Post by han » Fri Jun 01, 2018 2:38 pm

I solved it by not compiling with NetCDF4.

But if I do need to compile with NetCDF4, is there any solution?

User avatar
kate
Posts: 3796
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: Questions on ROMS compiling with ifort

#5 Post by kate » Fri Jun 01, 2018 2:50 pm

Are you sure you have an up-to-date netcdf4 and netcdf-fortran?

han
Posts: 13
Joined: Thu Mar 29, 2018 5:03 pm
Location: Stony Brook University

Re: Questions on ROMS compiling with ifort

#6 Post by han » Sat Jun 02, 2018 12:05 pm

kate wrote:Are you sure you have an up-to-date netcdf4 and netcdf-fortran?
Definitely.

I installed the latest version.

chenjung
Posts: 5
Joined: Fri Dec 29, 2006 11:02 pm
Location: NSYSU

Re: Questions on ROMS compiling with ifort

#7 Post by chenjung » Fri Jul 27, 2018 9:11 am

han wrote:
kate wrote:Are you sure you have an up-to-date netcdf4 and netcdf-fortran?
Definitely.

I installed the latest version.
hi han

Could you solve this problem??

I have the same problem.

I installed netcdf-c lib 4.6.1 and netcdf-fortran lib 4.4.4.

Post Reply