Ocean Modeling Discussion

ROMS/TOMS

Search for:
It is currently Sat Aug 18, 2018 6:39 am




Post new topic Reply to topic  [ 2 posts ] 

All times are UTC

Author Message
PostPosted: Fri Mar 30, 2018 4:38 am 
Offline

Joined: Thu Mar 29, 2018 5:03 pm
Posts: 12
Location: Stony Brook University
Hi everyone,

I'm installing ROMS on a cluster. I already installed NetCDF4, NetCDF-fortran, HDF5, zilb. But when I compile ROMS, there is an error says
"Fatal Error: File 'netcdf.mod' opened at (1) is not a GFORTRAN module file".

I know I'm using gfortran on the cluster.

Also I go to the directory /opt/netcdf4/include to check the status of netcdf.mod

File: `netcdf.mod'
Size: 291243 Blocks: 576 IO Block: 4096 regular file
Device: fd00h/64768d Inode: 7209892 Links: 1
Access: (0644/-rw-r--r--) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2018-03-29 21:49:47.797721930 -0400
Modify: 2015-10-19 18:13:08.920376884 -0400
Change: 2015-10-19 18:13:08.920376884 -0400


Does anyone know what is going on?


Top
 Profile  
Reply with quote  
PostPosted: Fri Mar 30, 2018 6:18 am 
Offline
User avatar

Joined: Wed Jul 02, 2003 5:29 pm
Posts: 3487
Location: IMS/UAF, USA
The file could be from a different version of gfortran. You need one compiled with the same version of the compiler. One way to achieve that is to compile it yourself from sources - you only need to compile the netcdf-fortran.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group