Ocean Modeling Discussion

ROMS/TOMS

Search for:
It is currently Wed Jul 17, 2019 6:55 pm




Post new topic Reply to topic  [ 1 post ] 

All times are UTC

Author Message
PostPosted: Sat Dec 16, 2006 12:24 pm 
Hi,

We are trying to compile ROMS agrif v1.2 with MPI for two processors of dual core each one.

We have put (ON) MPI in cppdef.h and we also in param.h the following lines:

Quote:
#ifdef MPI
integer NP_XI, NP_ETA, NNODES
parameter (NP_XI=2, NP_ETA=2, NNODES=NP_XI*NP_ETA)
parameter (NSUB_X=1, NSUB_E=2, NPP=1)


We executed doing :
Quote:
/opt/intel/mpich/bin/mpirun -np 4 -machinefile machines.list roms roms.in


The compilation has gone well and the simulation is executed in the 4 nodes, but it is broken saying ->

Quote:
- - - - - - - - - - - - - -
MAIN: started time-steping.
DEF_HIS/AVG -- Opened existing file from record = -1 mynode = 3
WRT_GRID -- wrote grid data into file 'ROMS_FILES/roms_his.nc'. mynode = 3
WRT_HIS -- wrote history fields into time record = 1 / 1 mynode = 3
MAIN: started time-steping.
STEP time[DAYS] KINETIC_ENRG POTEN_ENRG TOTAL_ENRG NET_VOLUME trd
0 0.00000 0.000000000E+00 2.6850194E+01 2.6850194E+01 6.3283148E+15 0
1 0.00001 NaN NaN NaN NaN 0
MAIN - number of records written into history file(s): 1
number of records written into restart file(s): 0
number of records written into averages file(s): 0
MAIN: Abnormal termination: BLOWUP
- - - - - - - - - - - - - -


Must we modify something more ? Cu_max is 0,8 sec. For a single node if it goes well !!.

regards,


Top
  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group