using ANA_ICE and ANA_INITIAL

Discussion about modeling ice with ROMS

Moderators: arango, robertson

Post Reply
Message
Author
turuncu
Posts: 128
Joined: Tue Feb 01, 2005 8:21 pm
Location: Istanbul Technical University (ITU)
Contact:

using ANA_ICE and ANA_INITIAL

#1 Post by turuncu » Mon Mar 19, 2012 1:54 pm

Hi,

I try to run ice code with only ANA_ICE cpp option (no ANA_INITIAL cpp flag is used) but model try to find the ice related variables in the initial condition netcdf file and gives following error,

Code: Select all

 NLM: CHECKVARS - unable to find model variable: uice
I check the code and found that this error comes from '/ROMS/Utility/checkvars.F'. I also try to change cpp flag for ice model from "ifdef ICE_MODEL" to "ifdef ICE_MODEL && !defined ANA_ICE" but problem still continues. Do you have any idea to fix it?

Regards,

--ufuk

User avatar
kate
Posts: 3717
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: using ANA_ICE and ANA_INITIAL

#2 Post by kate » Mon Mar 19, 2012 4:40 pm

Try this syntax:

Code: Select all

# if defined ICE_MODEL || !defined ANA_ICE
You will have to make the same change to get_state.F. Clearly, this isn't a case I tried, so let me know if that isn't the full fix.

turuncu
Posts: 128
Joined: Tue Feb 01, 2005 8:21 pm
Location: Istanbul Technical University (ITU)
Contact:

Re: using ANA_ICE and ANA_INITIAL

#3 Post by turuncu » Tue Mar 20, 2012 3:41 pm

Hi,

Thanks Kate. I tried your fix but it gives error in the compile time and i changed it like,

Code: Select all

# if defined ICE_MODEL && !defined ANA_ICE
and it seems working.

Thanks again,

--ufuk

User avatar
kate
Posts: 3717
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: using ANA_ICE and ANA_INITIAL

#4 Post by kate » Tue Mar 20, 2012 4:51 pm

Yes, right you are.

Post Reply