Segmentation fault at the start

Information about ongoing ROMS/TOMS applications

Moderators: arango, robertson

Post Reply
Message
Author
lalvarez
Posts: 104
Joined: Wed Feb 03, 2010 6:59 pm
Location: Universidad Autonoma de Baja California Sur

Segmentation fault at the start

#1 Post by lalvarez » Mon Feb 16, 2015 7:59 pm

Hello All

I'm having a problem by the time i try to run ROMS, this is what i got

ggv@SNI01 ~/roms/Projects/Leo $ ./oceanO <leo.in >out00.txt

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0 0x7FACD9F6A7D7
#1 0x7FACD9F6ADDE
#2 0x7FACD96ACD3F
#3 0x414C37 in read_fltpar_
#4 0x409155 in inp_par_
#5 0x403699 in __ocean_control_mod_MOD_roms_initialize
Segmentation fault

I attach my floats file

I really appreciate your help on this

Thanks in advance
Attachments
Leofloats.in
(13.27 KiB) Downloaded 140 times

User avatar
m.hadfield
Posts: 521
Joined: Tue Jul 01, 2003 4:12 am
Location: NIWA

Re: Segmentation fault at the start

#2 Post by m.hadfield » Tue Feb 17, 2015 9:14 pm

I suggest you get into read_fltpar with a debugger or (my choice) add some WRITE statements.

It would be helpful if your compiler told you the line number at which the error occurred. Most compilers can be persuaded to do this. For Gfortran (on most platforms) you just need to set the USE_DEBUG make variable.

lalvarez
Posts: 104
Joined: Wed Feb 03, 2010 6:59 pm
Location: Universidad Autonoma de Baja California Sur

Re: Segmentation fault at the start

#3 Post by lalvarez » Wed Feb 18, 2015 4:11 pm

Hello Mike

Thanks for your comment, acrually we have solve that problem, what we are facing now iare the DT and dt, time steps. We are running on a large domain (figure atteched) and we can not fine aa adecuate pair of the to make Roms run, it blows up at the very start, here i attach the file too (out00.txt).

Thanks in advance Mike
Attachments
Figure.docx
(1.11 MiB) Downloaded 144 times
out00.txt
(38.68 KiB) Downloaded 142 times

User avatar
kate
Posts: 3798
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: Segmentation fault at the start

#4 Post by kate » Wed Feb 18, 2015 5:42 pm

I suggest you set NINFO to 1 so that diag can check for extreme values every timestep. Then you can perhaps see what is going bad before the whole grid is full of NaN. When it saves a record to the restart file like that, look at it with your favorite viewer, ncview or whatever you like. Where is it blowing up? Perhaps you should also look at your boundary and forcing files. What are you doing with the ZCLIMATOLOGY?

machaielder
Posts: 43
Joined: Wed Mar 18, 2015 3:40 pm
Location: Universidade Federal Fluminense

Re: Segmentation fault at the start

#5 Post by machaielder » Fri Aug 14, 2015 10:55 pm

Hello Every one. I am having the the following error error message (see the log file in attachment) ; my compiler is gfortran;
Program received signal SIGSEGV: Segmentation fault - invalid memory reference.
Any help please
Attachments
sofala.log
(11.41 KiB) Downloaded 141 times

User avatar
kate
Posts: 3798
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: Segmentation fault at the start

#6 Post by kate » Fri Aug 14, 2015 11:13 pm

#4 0x4C9809 in check_multifile_
#5 0x433911 in initial_
Can you show us the part of your ocean.in that refers to the boundary, climatology and forcing files? Which version of ROMS is this, exactly?

machaielder
Posts: 43
Joined: Wed Mar 18, 2015 3:40 pm
Location: Universidade Federal Fluminense

Re: Segmentation fault at the start

#7 Post by machaielder » Tue Aug 18, 2015 3:01 am

Dear Kate
thank you for replying.my ROMS version 3.7.
I send in attachment my ocean.in

Kindest Regards
Attachments
ocean.in
(116.92 KiB) Downloaded 138 times

User avatar
kate
Posts: 3798
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: Segmentation fault at the start

#8 Post by kate » Wed Aug 19, 2015 4:44 pm

Code: Select all

     NFFILES ==                           ! number of unique forcing files

     FRCNAME ==                ! forcing file 1, grid 1
I suggest you put NFFILES == 1 even if you don't have any files. Also, provide some bogus filename for the forcing file. ROMS will allocate the FRC object to have NFFILES elements in it, so I don't know what it would do with a blank there. Nothing good, obviously. Also, you want a filename for FRCNAME just for error reporting. If ROMS thinks it needs a forcing file, it will try to open it, and the error is more meaningful with "unable to open file: some_bogus_forcing.nc" than with a blank filename.

Post Reply