questions about test cases posted on USGS webpage

Sediment modeling collaborators: issues, applications, information exchange

Moderators: arango, robertson, rsignell

Post Reply
Message
Author
merrywish
Posts: 2
Joined: Fri Dec 07, 2007 10:36 pm
Location: Arcadis

questions about test cases posted on USGS webpage

#1 Post by merrywish » Tue Dec 11, 2007 11:01 pm

On this webpage, there are some results of four test cases using ROMS.
http://woodshole.er.usgs.gov/project-pa ... _Cases.htm

I am using ECOMSED to repeat the first two cases and encounter some problems. Your replies are truely appreciated!!
For the "channel flow" case:
1) Is the erosion rate 5.0e-4 right? I employed it in ECOMSED and the output of SSC is one order of magnitude larger than ROMS results. Should it be 5.0e-5?
2)the drag coefficient Cd is given as 0.0025 or computed?
3)"por_1 = 1-porosity = 0.6" on the page of results are not consistent with "Fractional bed concentration (1-porosity) = 0.90" on the page of model description. Which one is used in this case?
4) Is the eddy diffusivity used in SSC transport equation directly from the turbulence closure scheme? The eddy diffusivity from ECOMSED (Mellor&Yammda) agreed well with ROMS results, but the vertical profile of SSC shows less mixing (milder slope) than ROMS results (steep slope). Any possible explainations?

For the estuary case:
1)Is a constant erosion rate used in this case? What's the value?
2)What's the downstream salinity boundary? 35ppt?
3)Where can I get the ROMS modeled flow field and bottom shear stress?

THANKS A MILLION!

rsignell
Posts: 123
Joined: Fri Apr 25, 2003 9:22 pm
Location: USGS

#2 Post by rsignell » Wed Dec 19, 2007 11:06 pm

Merrywish,

Indeed, it appears there are some discrepancies between (1) the test cases listed on the USGS test_cases web page, (2) the paper where the test case results were reported (Warner et al, Ocean Modeling 8 (2005) 81-113), and (3) the test case configurations that come supplied with the ROMS distribution.

Until we can get these to all to agree, please use the configurations and results listed in the Ocean Modeling paper, which are self consistent.

I took a look at the "channel flow" case supplied with ROMS, which can be run by setting ROMS_APPLICATION=TEST_CHAN
in your Makefile or build script.

The only change you need to make to reproduce the results in the paper is to change the layer spacing to uniform, by specifying theta_s=0 in ocean_test_chan.in. Although it isn't explicitly stated in the paper, there are 20 uniformly spaced levels (which you can see by careful inspection of Fig. 2). With uniform spacing set, you can then increase the time step from 10s to 30 s, the time step indicated in the paper.

With regard to your other questions about parameters, you can see from sediment_test_chan.in that the erosion rate is set to 5.0e-5 as specified in the paper. The porosity in sediment_test_chan.in is set to 0.9, as specified in the paper, but this doesn't play a role in the solution, as the porosity only comes in when sediment mass flux is converted to volume flux, and we are not tracking the bed changes in this problem. The bottom drag is specified by constant roughness length Zob=0.0053 m set in ocean_test_chan.in (the paper says 0.005, but I think this is just rounding off).

Hope this is useful and gets you going. I'll try to take a look at the estuary test case also.

Thanks for the feedback!

-Rich

merrywish
Posts: 2
Joined: Fri Dec 07, 2007 10:36 pm
Location: Arcadis

It helps a lot

#3 Post by merrywish » Fri Dec 21, 2007 4:19 pm

Rich,

Thank you so very much. Your reply lits my way.

By the way, the paper you referred to is excellent.

HH

Post Reply