A problem about coupled SWAN and ROMS model

Sediment modeling collaborators: issues, applications, information exchange

Moderators: arango, robertson, rsignell

Post Reply
Message
Author
Rocky_Wang
Posts: 45
Joined: Tue Mar 01, 2016 1:38 am
Location: the Ocean University of China

A problem about coupled SWAN and ROMS model

#1 Post by Rocky_Wang » Fri Jun 16, 2017 2:45 am

Hello,
I use the COAWST model to couple SWAN and ROMS, and they exchange variables throuth MCT every 3 hours. I use the SSW_bbl for the wave-current interactions.the CPP options are as following:


#define SSW_BBL /* Sherwood et al. BBL closure */
#ifdef SSW_BBL
# define SSW_CALC_ZNOT /* Computing bottom roughness internally */
# undef SSW_LOGINT /* Logarithmic interpolation of (Ur,Vr) */
# undef SSW_CALC_UB /* Computing bottom orbital velocity internally */
# undef SSW_FORM_DRAG_COR /* Activate form drag coefficient */
# undef SSW_ZOBIO /* Biogenic bedform roughness from ripples */
# undef SSW_ZOBL /* Bedload roughness for ripples */
# undef SSW_ZORIP /* Bedform roughness from ripples */#endif


and in my log file, they exchange data normally, for example:

== SWAN grid 1 sent wave data to ROMS grid 1
** ROMS grid 1 recv data from SWAN grid 1
SWANtoROMS Min/Max DISBOT (Wm-2): 0.000000E+00 1.156542E-05
SWANtoROMS Min/Max DISSURF (Wm-2): 0.000000E+00 0.000000E+00
SWANtoROMS Min/Max DISWCAP (Wm-2): 0.000000E+00 8.076467E-05
SWANtoROMS Min/Max HSIGN (m): 0.000000E+00 6.775821E-01
SWANtoROMS Min/Max RTP (s): 0.000000E+00 3.343699E+00
SWANtoROMS Min/Max TMBOT (s): 0.000000E+00 8.335983E+00
SWANtoROMS Min/Max UBOT (ms-1): 0.000000E+00 5.487803E-02
SWANtoROMS Min/Max DIR (deg): 9.044095E-04 6.282655E+00
SWANtoROMS Min/Max WLEN (m): 1.000000E+00 1.068273E+01
** ROMS grid 1 sent data to SWAN grid 1
== SWAN grid 1 recv data from ROMS grid 1
ROMStoSWAN Min/Max DEPTH (m): 5.000000E+00 1.321269E+02
ROMStoSWAN Min/Max WLEV (m): -8.748971E-01 1.111308E+00
ROMStoSWAN Min/Max VELX (ms-1): -8.722052E-01 8.795478E-01
ROMStoSWAN Min/Max VELY (ms-1): -1.390613E+00 8.895970E-01
ROMStoSWAN Min/Max ZO (m): 5.000000E-02 5.000000E-02

But when I check the wave induced shear stress(bustrw,bvstrw), values are really small, So I made a test that turn on the CPP options

SSW_CALC_UB, as following , and I changed nothing about others. And the result is more reasonable.



#define SSW_BBL /* Sherwood et al. BBL closure */
#ifdef SSW_BBL
# define SSW_CALC_ZNOT /* Computing bottom roughness internally */
# undef SSW_LOGINT /* Logarithmic interpolation of (Ur,Vr) */
# define SSW_CALC_UB /* Computing bottom orbital velocity internally */
# undef SSW_FORM_DRAG_COR /* Activate form drag coefficient */
# undef SSW_ZOBIO /* Biogenic bedform roughness from ripples */
# undef SSW_ZOBL /* Bedload roughness for ripples */
# undef SSW_ZORIP /* Bedform roughness from ripples */#endif



So I want to know if should I turn on the SSW_CALC_UB option when I couple SWAN and ROMS.
Attachments
Jan_wavestress.jpeg

jcwarner
Posts: 812
Joined: Wed Dec 31, 2003 6:16 pm
Location: USGS, USA

Re: A problem about coupled SWAN and ROMS model

#2 Post by jcwarner » Fri Jun 16, 2017 2:57 pm

typically when you couple roms with swan, then you should use the bottom orbital velocity from swan. so we typically only use ssw_calc_znot with roms+swan.

If you added ssw_calc_ub, then Ubot is being computed in sswbbl as:

! Set bed wave orbital velocity and excursion amplitude. Use data
! from wave models (SWAN) or use Dean and Dalrymple (1991) 6th-degree
! polynomial to approximate wave number on shoaling water.
Fwave_bot(i,j)=twopi/MAX(Pwave_bot(i,j),0.05_r8)
#ifdef SSW_CALC_UB
Kdh=h(i,j)*Fwave_bot(i,j)**2/g
Kbh2=Kdh*Kdh+ &
& Kdh/(1.0_r8+Kdh*(K1+Kdh*(K2+Kdh*(K3+Kdh*(K4+ &
& Kdh*(K5+K6*Kdh))))))
Kbh=SQRT(Kbh2)
Ab(i,j)=0.5_r8*Hwave(i,j)/SINH(Kbh)+eps
Ub(i,j)=Fwave_bot(i,j)*Ab(i,j)+eps
#else
Ub(i,j)=MAX(Uwave_rms(i,j),0.0_r8)+eps
Ab(i,j)=Ub(i,j)/Fwave_bot(i,j)+eps
#endif

You might want to look at the bottom roughness values that are being sent to swan. See if there is a grain size effect. that might have some effect on the Ub.

-j

Rocky_Wang
Posts: 45
Joined: Tue Mar 01, 2016 1:38 am
Location: the Ocean University of China

Re: A problem about coupled SWAN and ROMS model

#3 Post by Rocky_Wang » Sat Jun 17, 2017 3:24 am

Thanks John,
That is to say, If I want ROMS one way coupled with swan (make the swan output hwave, tmbot wdir into a wave forcing file) , the CPP option define SSW_CALC_UB can be activated. And if I want to ROMS two way coupled with SWAN, There is no need to activate it. Right?
Yes, I want to look at the bottom roughness values that are being sent to swan, but why in my log file, the ZO that roms sent to swan is always be 0.05m? and the attachment is my log file.

ROMStoSWAN Min/Max ZO (m): 5.000000E-02 5.000000E-02
Attachments
log.txt
(2.66 MiB) Downloaded 96 times

jcwarner
Posts: 812
Joined: Wed Dec 31, 2003 6:16 pm
Location: USGS, USA

Re: A problem about coupled SWAN and ROMS model

#4 Post by jcwarner » Mon Jun 19, 2017 11:44 am

For both choices (uncoupled or coupled) you still have 2 choices: you can save Ub from swan and force roms with that or use the SSW_CALC_UB option and have the code compute Ub.

For the bottom roughness, we have a minimum value of 0.05 set in MAster/mct_roms_swan.h. you can edit that file and change it if you want.

Rocky_Wang
Posts: 45
Joined: Tue Mar 01, 2016 1:38 am
Location: the Ocean University of China

Re: A problem about coupled SWAN and ROMS model

#5 Post by Rocky_Wang » Sun Jun 25, 2017 5:10 am

Ok, I get the point.Thanks John

Post Reply