Ocean Modeling Discussion

ROMS/TOMS

Search for:
It is currently Mon Dec 10, 2018 6:33 am




Post new topic Reply to topic  [ 3 posts ] 

All times are UTC

Author Message
 Post subject: Estuary_Test
PostPosted: Wed Feb 02, 2011 12:20 am 
Hello,

I'm a beginner ROMS user and I've been trying to get the estuary_test case going, but I haven't been able to get it to jive either with the wikiROMS page for estuary_test or the Warner et al. 2005 ocean modeling paper. It seems to be working well enough except for a weird overall freshness in the ocean layer that is exacerbated at the western boundary, and seems to be causing a third turbidity maximum. Here's what an average of the last two tidal cycles (of ten total tidal cycles) looks like:

Attachment:
ETM_avg.jpg
ETM_avg.jpg [ 83.52 KiB | Viewed 2076 times ]


The header file is essentially the estuary.h provided with the ROMS code:

#undef ANA_GRID
#define UV_ADV
#define UV_LOGDRAG
#define TS_U3HADVECTION
#define SALINITY
#define SOLVE3D
#define SPLINES
#define SEDIMENT
#ifdef SEDIMENT
# define SUSPLOAD
#endif
#define AVERAGES
#define NORTHERN_WALL
#define SOUTHERN_WALL
#define EAST_FSGRADIENT
#define EAST_M2CLAMPED
#define EAST_M3GRADIENT
#define EAST_TCLAMPED
#define WEST_FSCHAPMAN
#define WEST_M2CLAMPED
#undef WEST_M2REDUCED
#undef FSOBC_REDUCED
#define WEST_M3GRADIENT
#define WEST_TRADIATION
#define WEST_TNUDGING
#define GLS_MIXING
#undef MY25_MIXING
#if defined GLS_MIXING || defined MY25_MIXING
# define KANTHA_CLAYSON
# undef CANUTO_A
# define N2S2_HORAVG
#endif
#define ANA_INITIAL
#define ANA_SEDIMENT
#define ANA_SMFLUX
#define ANA_STFLUX
#define ANA_BTFLUX
#define ANA_SSFLUX
#define ANA_BSFLUX
#define ANA_SPFLUX
#define ANA_BPFLUX
#define ANA_FSOBC
#define ANA_M2OBC
#define ANA_TOBC

As far as I can tell, ana_tobc is setting the western boundary salinity to 30. Any ideas what I'm doing wrong here?

Thanks!
-Maggie


Top
  
Reply with quote  
 Post subject: Re: Estuary_Test
PostPosted: Wed Mar 02, 2011 3:51 am 
Offline

Joined: Wed Dec 31, 2003 6:16 pm
Posts: 739
Location: USGS, USA
Maggie-
i did an svn update on the rutgers code and ran estuary_test. It ran for 10 days.
here is what i did in matlab:
ncload ocean_his.nc
saltmean=salt(end-47:end,:,3,:);
figure
pcolorjw(squeeze(mean(saltmean,1)))
colorbar

i do not get the same picture of avg salt that you show. I am not sure why your salt at the western obc shows a decrease.
For the sediment, in the paper i ran the est case for 10 tidal cycles, then i restarted the model and ran it for days 10-20 with the sediment. this allowed the est circ to establish itself beofre the sed was applied. Can you try that and see if the double sed peaks go away? (i do get teh double sed peaks, but i would not use them. they are distorted by the initial conditions.) let the salt get correct first, then go with the sediment.

-john


Attachments:
est_salt.png
est_salt.png [ 8.06 KiB | Viewed 2004 times ]
Top
 Profile  
Reply with quote  
 Post subject: Re: Estuary_Test
PostPosted: Mon Mar 14, 2011 8:06 pm 
Hi,

Thank you for checking back! I'd done something weird setting up the test case, but it is working now. Thanks for the tip about starting the sediment after the estuary circulation has been set up.

Best,
Maggie


Top
  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group