A ROMS error in relation to stiffness.F

Bug reports, work arounds and fixes

Moderators: arango, robertson

Post Reply
Posts: 60
Joined: Tue Sep 28, 2010 11:59 pm
Location: Texas A&M University

A ROMS error in relation to stiffness.F

#1 Post by d.kobashi » Wed Oct 19, 2011 6:49 am

Dear all,

I have encountered an error when I tried to run a 2-D ROMS tide model for my study area. A 3D tide model run without problems and I am now trying to run 2D version of the 3D model. I use TPXO to get open boundary conditions along each boundary.

After checking other ROMS community posts on similar issues, I did:

(1) change the following for cppdefs.h.
undef SOLVE3D and various analytical options not necessary for 3D run.


(2) change the following for my input file (.in)
DT = 3.0d0 (2D) from 100.0d0 (3D)

The compiling went well; however, when I run the model, I've got the following error (the complete log is also attached). :?

forrtl: severe (193): Run-Time Check Failure. The variable 'stiffness_mod_mp_stiffness_tile_$MY_RX0' is being used without being defined
Image PC Routine Line Source
oceanG 082DCB6D Unknown Unknown Unknown
oceanG 082DB965 Unknown Unknown Unknown
oceanG 082A13DF Unknown Unknown Unknown
oceanG 08270C67 Unknown Unknown Unknown
oceanG 082713A2 Unknown Unknown Unknown
oceanG 08113B7F stiffness_mod_mp_ 204 stiffness.f90
oceanG 08113824 stiffness_mod_mp_ 64 stiffness.f90
oceanG 08086933 initial_ 193 initial.f90
oceanG 0804B73C ocean_control_mod 113 ocean_control.f90
oceanG 0804B213 MAIN__ 95 master.f90
oceanG 0804B0C1 Unknown Unknown Unknown
libc.so.6 B7641BD6 Unknown Unknown Unknown
oceanG 0804B001 Unknown Unknown Unknown

It looks like this problem is caused by stiffness.F via initial.F and stiffness_mod is indeed called in initial.F.
I am wondering if someone could point out what went wrong.
In stiffness.F, the header says "This routine surveys the 3D grid in order to determine maximum grid stiffness ratio. This is done for diagnostic purposes and it does not affect the computations". Is stiffness something to do with smoothness of vertical slope?

My cppdefs file of both 3D and 2D model runs is also attached.
I use Intel Fortran 11.1 under Ubuntu 10.04.
Many thanks in advance.


(10.37 KiB) Downloaded 78 times
cppdefs for 3D model run
(2.76 KiB) Downloaded 75 times
cppdefs for 2D model run
(2.68 KiB) Downloaded 86 times

User avatar
Site Admin
Posts: 1108
Joined: Wed Feb 26, 2003 4:41 pm
Location: IMCS, Rutgers University

Re: A ROMS error in relation to stiffness.F

#2 Post by arango » Wed Oct 19, 2011 3:48 pm

Yes, the variables my_rx0 and my_rx1 are only used in 3D applications. Their values were unassigned in 2D applications and some strict compilers may complaint about that. This fix required changing the local buffers for MPI communications. I updated the code. Check the following :arrow: trac ticket.

The fix is only done in the current ROMS 3.6 version. You need to update. If you are using an older version of ROMS, you just need to replace stiffness.F with the corrected one. The change is backward compatible with all versions. However, previous version of ROMS in the repository are tagged and frozen.

Thank you for reporting this problem.

Posts: 60
Joined: Tue Sep 28, 2010 11:59 pm
Location: Texas A&M University

Re: A ROMS error in relation to stiffness.F

#3 Post by d.kobashi » Thu Oct 20, 2011 8:33 am

Many thanks for your prompt fix. I use ROMS 3.5. I replaced the old one with the corrected one as you suggested and then the 2d model runs like a charm. :)



Post Reply