main3d_offline.F and step3d_t.F in ROMS 3.9

Bug reports, work arounds and fixes

Moderators: arango, robertson

Post Reply
Message
Author
goodboy
Posts: 16
Joined: Tue Sep 29, 2020 12:07 am
Location: OUC

main3d_offline.F and step3d_t.F in ROMS 3.9

#1 Post by goodboy »

During my application establishment, I open the "OFFLINE_BIOLOGY" option and compile them, which gives me a wrong error and aborts during my compiling.
After checking out the main3d_offline.F file in ROMS 3.9, I found there is some code missed.
When I add this code, it can compile successfully.

Code: Select all

      USE strings_mod,         ONLY : FoundError
Besides, there is also some code missed in step3d_t.F file. After I add these codes, it can compile successfully.

Code: Select all

# if defined OFFLINE_BIOLOGY
      USE mod_biology
# endif
I don't know whether this is my reason or not. Maybe this error occurs because of my unintentional modification in the past. I'm not sure. Could anyone can check them out in ROMS 3.9?

User avatar
kate
Posts: 3939
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: main3d_offline.F and step3d_t.F in ROMS 3.9

#2 Post by kate »

If this is my code, I've given up on OFFLINE_BIOLOGY. I sort of had it working in the "main" branch, not the default "kate_svn" branch. But for me, I have wetting and drying and it wasn't doing the right thing in the dry parts, nor did it even know if it was wet or dry that day.

goodboy
Posts: 16
Joined: Tue Sep 29, 2020 12:07 am
Location: OUC

Re: main3d_offline.F and step3d_t.F in ROMS 3.9

#3 Post by goodboy »

Ok, I got it. Thank you very much!

Post Reply