INQUIRE - unable to find requested variable: tide_period

Report or discuss software problems and other woes

Moderators: arango, robertson

Post Reply
Message
Author
aakashsane
Posts: 12
Joined: Tue Sep 19, 2017 2:14 pm
Location: Brown University

INQUIRE - unable to find requested variable: tide_period

#1 Post by aakashsane » Sat Jan 05, 2019 3:09 am

Hello!

I am running the latest version of roms (downloaded fresh copy today and ported everything from older version to newer version. I also ran the test case 'upwelling' and there was no problem in running it.)

For the model I am running, I have compiled it with no issues.
But when I am running it, I am getting the following error:

INQUIRE - unable to find requested variable: tide_period
in files:
frc_NAM_wind_fields_OSOM_2006.nc
frc_bulk8_point_osom_2006.nc

I am guessing it is trying to find the variable 'tide_period' in forcing file. But the variable 'tide_period' has already
been defined in the tidal forcing file under 'TIDENAME'.
I have checked varinfo.dat file and the variable 'tide_period' exists in it.

Could someone please highlight what I am doing wrong?
Last edited by aakashsane on Sat Jan 05, 2019 4:57 am, edited 1 time in total.

aakashsane
Posts: 12
Joined: Tue Sep 19, 2017 2:14 pm
Location: Brown University

Re: INQUIRE - unable to find requested variable: tide_pe

#2 Post by aakashsane » Sat Jan 05, 2019 4:37 am

An update on this:

When I am having these settings in the ocean.in file:
___________________________________________________________________
TIDENAME == osom_grid4_mindep_smlp_mod6_tidalforcing_2006.nc

NFFILES == 2 ! number of unique forcing files

FRCNAME == frc_NAM_wind_fields_OSOM_2006.nc \ ! forcing file 1, grid 1
frc_bulk8_point_osom_2006.nc
___________________________________________________________________
I am getting the error mentioned in the previous post.

But when I do this:

___________________________________________________________________
! TIDENAME == osom_grid4_mindep_smlp_mod6_tidalforcing_2006.nc

NFFILES == 3 ! number of unique forcing files

FRCNAME == osom_grid4_mindep_smlp_mod6_tidalforcing_2006.nc \
frc_NAM_wind_fields_OSOM_2006.nc \ ! forcing file 1, grid 1
frc_bulk8_point_osom_2006.nc
___________________________________________________________________

the model is running and I am not getting errors.

Any suggestions on this?

User avatar
kate
Posts: 3700
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: INQUIRE - unable to find requested variable: tide_pe

#3 Post by kate » Sat Jan 05, 2019 5:56 pm

I would be very careful about the formatting of the list of forcing files. No tabs, no trailing comments. ROMS will skip a line starting with "!", but not skip the stuff following a mid-line "!". Just put the comments on their own lines before the rest.

Post Reply