Ocean Modeling Discussion

ROMS/TOMS

Search for:
It is currently Fri Jul 19, 2019 1:51 am




Post new topic Reply to topic  [ 3 posts ] 

All times are UTC

Author Message
 Post subject: changed LBC options
PostPosted: Fri Sep 28, 2018 2:52 am 
Hi all,

I'm not sure if this is a bug or a hardware issue. I'm doing a restart test with ROMS svn904 but the LBC options were changed automatically from Shc to Red by the script during the simulation. It only happened for ubar/vbar but the location is random. It happened once for East (ubar) and South (vbar), and once for North (both). I'm using netcdf with parallel, could this be a potential issue? How could I determine where the error is from?

This is my .in file (the same as in the restart file)
Code:
   LBC(isFsur) ==   Cha     Cha     Cha     Cha         ! free-surface
!  LBC(isUbar) ==   Fla     Fla     Fla     Fla         ! 2D U-momentum
!  LBC(isVbar) ==   Fla     Fla     Fla     Fla         ! 2D V-momentum
   LBC(isUbar) ==   Shc     Shc     Shc     Shc         ! 2D U-momentum
   LBC(isVbar) ==   Shc     Shc     Shc     Shc         ! 2D V-momentum
   LBC(isUvel) ==   RadNud  RadNud  RadNud  RadNud      ! 3D U-momentum
   LBC(isVvel) ==   RadNud  RadNud  RadNud  RadNud      ! 3D V-momentum
   LBC(isMtke) ==   Gra     Gra     Gra     Gra         ! mixing TKE


This is the output

Code:
         "EDGE:  WEST   SOUTH  EAST   NORTH  \n",
         "zeta:  Cha    Cha    Cha    Cha    \n",
         "ubar:  Shc    Shc    Shc    Red    \n",
         "vbar:  Shc    Shc    Shc    Red    \n",
         "u:     RadNud RadNud RadNud RadNud \n",
         "v:     RadNud RadNud RadNud RadNud \n",
         "temp:  RadNud RadNud RadNud RadNud \n",
         "salt:  RadNud RadNud RadNud RadNud" ;


Thank you,
Yi


Last edited by allencapa on Fri Sep 28, 2018 3:25 am, edited 2 times in total.

Top
  
Reply with quote  
 Post subject: Re: changed LBC options
PostPosted: Fri Sep 28, 2018 3:07 am 
I just tested without parallel nc and the results were ok, so it seems to be a netcdf issue, but how can I fix it?


Top
  
Reply with quote  
 Post subject: Re: changed LBC options
PostPosted: Sat Sep 29, 2018 12:37 am 
allencapa wrote:
I just tested without parallel nc and the results were ok, so it seems to be a netcdf issue, but how can I fix it?


Sorry it turns out to be a compiler problem. The serial one is compiled with ifort 14.0.4 while the parallel one is with ifort 17.0.1. I also tried intel 17.0.1 but with debug on and the model is running well. So now the question becomes: what is the recommended compiling option for intel 17.0.1?

Thanks


Top
  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group