ECMWF REGRID-input gridded data does not contain model grid

Report or discuss software problems and other woes

Moderators: arango, robertson

Post Reply
Message
Author
halftao1
Posts: 2
Joined: Mon Nov 21, 2016 5:58 pm
Location: ECNU SKLEC

ECMWF REGRID-input gridded data does not contain model grid

#1 Post by halftao1 » Sat Apr 08, 2017 2:10 pm

I used ecmwf2roms generated frc file and I'm sure it contain roms grid,but I meet this promble:

Code: Select all

 REGRID - input gridded data does not contain model grid:

          Gridded:  LonMin =   92.7429 LonMax =  145.1310
                    LatMin =  -11.7679 LatMax =   46.1067
          Model:    LonMin =   91.5336 LonMax =  147.0130
                    LatMin =   -9.0343 LatMax =   43.0000

 GET_2DFLD   - error while reading variable: Uwind   at TIME index =       1
The model grid information is right.But wind file have wrong lon and lat.I check wind file many times :cry: ,it show in Attachments.
I used cpp SPHERICAL , but I don't know whether it work.

Can someone help me?
Attachments
a.png
a.png (10.12 KiB) Viewed 1463 times

halftao1
Posts: 2
Joined: Mon Nov 21, 2016 5:58 pm
Location: ECNU SKLEC

Re: ECMWF REGRID-input gridded data does not contain model g

#2 Post by halftao1 » Sun Apr 09, 2017 6:00 am

OK,I get the reason.Because previously input path include pure number file , it return error.For test, I added another frc file.After modify get_varcoords.F,I finded the reason.
The Roms code is right.

Scarlett
Posts: 48
Joined: Tue Aug 04, 2015 4:42 pm
Location: Universidad del Mar (UMAR), Mexico
Contact:

Re: ECMWF REGRID-input gridded data does not contain model g

#3 Post by Scarlett » Thu Sep 06, 2018 6:36 pm

Hello everyone!
Like Ruiming wu I used ecmwf2roms generated forcing file.
I did my grid, and I used the grid lat and lon for create all my inputs files.

Code: Select all

ymax=20.3070;
ymin=-10.3042;
xmax=-76.7665;
xmin=-130.9754;
But when I run my model, I get:

REGRID - input gridded data does not contain model grid:

Gridded: LonMin = -140.0000 LonMax = -70.0000
LatMin = -10.0000 LatMax = 40.0000
Model: LonMin = -130.9754 LonMax = -76.7665
LatMin = -10.3043 LatMax = 20.3071

GET_2DFLD - error while reading variable: Uwind at TIME index = 1

I have checked the size of my input files and they are all around these coordinates, with the exception of forcings. Although these files I set them the same coordinates in the ecmwf2roms, the files still have the coordinates that the original files (the ECMWF files I downloaded with lat 40 to -10 and lon -140 a -70 )

Code: Select all

% Various parameters.

spherical = true;                       % Spherical switch

LonMin    = -130.9754;                     % GOM left-bottom longitude  
LonMax    = -76.7665;                      % GOM right-top   longitude
LatMin    = -10.3042;                       % GOM left-bottom latitude
LatMax    = 20.3070;                       % GOM right-top   latitude
FlipLat   = true;                       % Flip data in ERA NetCDF files
                                        % (see below information)

% StrDay    = datenum('01-Jan-2000');     % starting day to process
% EndDay    = datenum('31-Dec-2011');     % ending   day to process

StrDay    = datenum('01-Jan-2001');     % starting day to process
EndDay    = datenum('31-Dec-2001');     % ending   day to process
I have been reading about this problem and for the most part the cause is that the files do not have the latitude and longitude information, but my files have them.

I don't know if I need change the get_varcoords.F and where...
I appreciate any help to solve this problem.

Scarlett Mar.Mo.

User avatar
kate
Posts: 3678
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: ECMWF REGRID-input gridded data does not contain model g

#4 Post by kate » Thu Sep 06, 2018 6:50 pm

It looks like your model goes to 10.3 degrees south while you only gave it forcing down to 10 degrees south. Try giving it down to 11 south.

Post Reply