problem with mpirun

Report or discuss software problems and other woes

Moderators: arango, robertson

Post Reply
Message
Author
cwinant
Posts: 5
Joined: Wed Nov 18, 2015 3:53 pm
Location: SIO

problem with mpirun

#1 Post by cwinant » Tue Dec 01, 2015 5:24 pm

After moving my Roms files to a different disk, I am geeting the following message at eexecution time:

cdw@Meursault:/HOME/cdw/Roms/Projects/t24si$ mpirun -np 8 ./oceanM<tidebasinforcing.in
[proxy:0:0@Meursault] HYD_pmcd_pmip_control_cmd_cb (pm/pmiserv/pmip_cb.c:938): process reading stdin too slowly; can't keep up
[proxy:0:0@Meursault] HYDT_dmxu_poll_wait_for_event (tools/demux/demux_poll.c:76): callback returned error status
[proxy:0:0@Meursault] main (pm/pmiserv/pmip.c:206): demux engine error waiting for event
[mpiexec@Meursault] control_cb (pm/pmiserv/pmiserv_cb.c:200): assert (!closed) failed
[mpiexec@Meursault] HYDT_dmxu_poll_wait_for_event (tools/demux/demux_poll.c:76): callback returned error status
[mpiexec@Meursault] HYD_pmci_wait_for_completion (pm/pmiserv/pmiserv_pmci.c:198): error waiting for event
[mpiexec@Meursault] main (ui/mpich/mpiexec.c:336): process manager error waiting for completion

User avatar
kate
Posts: 3780
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: problem with mpirun

#2 Post by kate » Tue Dec 01, 2015 5:41 pm

Do you have a computer expert you can ask? These are system errors, not ROMS errors. Can you go back to the prior disk?

cwinant
Posts: 5
Joined: Wed Nov 18, 2015 3:53 pm
Location: SIO

Re: problem with mpirun

#3 Post by cwinant » Fri Dec 04, 2015 3:08 am

I guess these are mpi errors, although this thread claims they are user application errors.

User avatar
jivica
Posts: 133
Joined: Mon May 05, 2003 2:41 pm
Location: The University of Western Australia, Perth, Australia

Re: problem with mpirun

#4 Post by jivica » Fri Dec 04, 2015 4:53 am

not sure if you made typo but when running with MPI you do not use "<" to feed in .in file
this is wrong: mpirun -np 8 ./oceanM<tidebasinforcing.in
and should be: mpirun -np 8 ./oceanM tidebasinforcing.in > log &

Cheers
I.

cwinant
Posts: 5
Joined: Wed Nov 18, 2015 3:53 pm
Location: SIO

Re: problem with mpirun

#5 Post by cwinant » Sat Dec 05, 2015 12:59 am

That was exactly the problem I copied the syntax straight over from my serial runs.... Yhanks so much

Post Reply