Problems with time

Report or discuss software problems and other woes

Moderators: arango, robertson

Post Reply
Message
Author
cschultz
Posts: 13
Joined: Wed May 27, 2009 10:43 pm
Location: WHOI/MIT

Problems with time

#1 Post by cschultz » Fri Jun 10, 2011 2:35 pm

Dear everyone,

I will try to make the story short...We are working on a computer with limited space and time to run the jobs, so we made a script to run several years with restart every month. We "echoed" everything to see if the time steps are being caclulated right for all months, and it is (ex. it is set to save first restart after 2976 time steps - 31*96, for DT == 900.0d0). Still, the outputs don't look very good and it seems like the dates it's writing are random (they aren't, but I fail to see the logic :? ). It begins saving jan 16th, and sometimes it saves 2 values for rst in a month, and it's supposed to save only one.
We've been thinking about it for a while, and we strongly believe we are having some problem with ROMS understanding our time. I'll number them:

1. I started to do some runs in 2003, but then I got more interested in 1985. My reference is still 2000, so all my time values are negative. I didn't think it would be a problem, but could it?

2. The dates of the time steps come with stars, like this;
30217 -5164 **:**:00 3.072683E-02 2.353725E+04 2.353728E+04 1.215317E+16
30218 -5164 **:**:00 3.073118E-02 2.353725E+04 2.353728E+04 1.215317E+16
30219 -5164 **:**:00 3.073552E-02 2.353725E+04 2.353728E+04 1.215317E+16
30220 -5164 **:00:00 3.073984E-02 2.353725E+04 2.353728E+04 1.215317E+16
30221 -5164 **:**:00 3.074415E-02 2.353726E+04 2.353729E+04 1.215317E+16
30222 -5164 **:**:00 3.074841E-02 2.353726E+04 2.353729E+04 1.215316E+16
30223 -5164 **:**:00 3.075262E-02 2.353726E+04 2.353729E+04 1.215316E+16
30224 -5164 **:00:00 3.075676E-02 2.353726E+04 2.353729E+04 1.215316E+16
30225 -5164 **:**:00 3.076078E-02 2.353727E+04 2.353730E+04 1.215316E+16
what does that mean?

3. It does not run with NRREC = -1 on restarts, we had to set it to 1.
The error is:
NLM: GET_STATE - Read state initial conditions, t = 0 00:00:**
(File: cbm_rst_vazaoplus.nc, Rec=****, Index=1)

NLM: GET_STATE - error while reading variable: zeta at time record = -1
in input NetCDF file: /home/cristina/ROMS/cbm_rst_vazaoplus.nc


Long story short, maybe my time is a bit confusing to ROMS? Could that be it? How do I fix it?
Any clue would be very appreciated!

thank you very much!

Post Reply