About easygrid's SMOOTH_GRID

Report or discuss software problems and other woes

Moderators: arango, robertson

Post Reply
Message
Author
xiaozhu557
Posts: 61
Joined: Fri Sep 11, 2009 1:48 pm
Location: nmefc

About easygrid's SMOOTH_GRID

#1 Post by xiaozhu557 » Sun Dec 20, 2009 9:26 am

Now I am running ROMS for simulating the SOUTH CHINA SEA, and after I changed for my depth from our group to create a grid:
lat = 0.86; % Latitude (degrees) of the bottom-left corner of the grid.
lon = 99; % Longitude (degrees) of the bottom-left corner of the grid.

X = 3120000; % Width of domain (meters) 26.33
Y = 2800000; % Length of domain (meters)
rotangle = 0; % Angle (degrees) to rotate the grid conterclock-wise
resol = 11000; % Cell width and height (i.e. Resolution)in meters. Grid cells are forced to be (almost) square.
N = 10; % Number of vertical levels


When I smoothed the depth at first time, it is OK, and outputed in the screen:
---------------------------------------
WORKING with previously-generated GRID!
---------------------------------------
SMOOTHING Bathymetry...

Minimum r-value = 0
Maximum r-value = 0.99601
Mean r-value = 0.092054
Median r-value = 0.032014

Minimum r-value = 0
Maximum r-value = 0.92831
Mean r-value = 0.062297
Median r-value = 0.022814

Minimum r-value = 0
Maximum r-value = 0.76247
Mean r-value = 0.054567
Median r-value = 0.019597

Minimum r-value = 0
Maximum r-value = 0.62556
Mean r-value = 0.050096
Median r-value = 0.017906

Minimum r-value = 0
Maximum r-value = 0.60644
Mean r-value = 0.046937
Median r-value = 0.016938

Minimum r-value = 0
Maximum r-value = 0.54015
Mean r-value = 0.044504
Median r-value = 0.016021

Minimum r-value = 0
Maximum r-value = 0.52423
Mean r-value = 0.042552
Median r-value = 0.015158

Minimum r-value = 0
Maximum r-value = 0.51559
Mean r-value = 0.040945
Median r-value = 0.014767

Minimum r-value = 0
Maximum r-value = 0.47715
Mean r-value = 0.039557
Median r-value = 0.01423

Minimum r-value = 0
Maximum r-value = 0.46091
Mean r-value = 0.038341
Median r-value = 0.013626

Minimum r-value = 0
Maximum r-value = 0.44934
Mean r-value = 0.037264
Median r-value = 0.013131

Minimum r-value = 0
Maximum r-value = 0.35939
Mean r-value = 0.036305
Median r-value = 0.01291

Minimum r-value = 0
Maximum r-value = 0.34809
Mean r-value = 0.03544
Median r-value = 0.013018
Number of smoothing applications: 12
DONE!
SCREEN DISPLAY:
COPY-PASTE the following parameters into your ocean.in file
----------------------------------------------------------------------------------------------


Lm == 282 ! Number of I-direction INTERIOR RHO-points
Mm == 253 ! Number of J-direction INTERIOR RHO-points
N == 10 ! Number of vertical levels


Make sure the Baroclinic time-step (DT) in your ocean.in file is less than: 36.1962 seconds
----------------------------------------------------------------------------------------------

PLOTTING grid...
DONE!
***************************************************************
elapsed time: 0.040136 minute(s)
***************************************************************
EASYGRID is DONE!!! *******************************************
***************************************************************

But when I soothed it again,by setting in the easygrid.m:
create_grid = 0; % Create GRID. Turn OFF to work with a previously created grid (i.e. grid variables existing on Workspace)
plot_grid = 1; % Plot grid
smooth_grid = 1; % Smooth bathymetry using H. Arango's smth_bath.m , which applies a Shapiro filter to the bathymetry
edit_mask = 0; % Edit rho-mask using interactive plot. Use this to manually change sea-pixels into land-pixels and vice-versa
screen_output = 1; % Displays (on screen) many parameters that need to be copy-pasted in the ocean.in file
save_grid = 0; % Save GRID in a NetCDF file
save_init = 0; % Create (and save) INITIAL CONDITIONS (from grid)
% ON = 1; OFF = 0

It just outputed in the screen:
***************************************************************
** EASYGRID ***************************************************
***************************************************************
---------------------------------------
WORKING with previously-generated GRID!
---------------------------------------
SMOOTHING Bathymetry...

Minimum r-value = 0
Maximum r-value = 0.38381
Mean r-value = 0.035617
Median r-value = 0.013088

Minimum r-value = 0
Maximum r-value = 0.34173
Mean r-value = 0.034656
Median r-value = 0.012787
Number of smoothing applications: 1DONE!
SCREEN DISPLAY:
COPY-PASTE the following parameters into your ocean.in file
----------------------------------------------------------------------------------------------


Lm == 282 ! Number of I-direction INTERIOR RHO-points
Mm == 253 ! Number of J-direction INTERIOR RHO-points
N == 10 ! Number of vertical levels


Make sure the Baroclinic time-step (DT) in your ocean.in file is less than: 36.1962 seconds
----------------------------------------------------------------------------------------------

PLOTTING grid...
DONE!
***************************************************************
elapsed time: 0.0067904 minute(s)
***************************************************************
EASYGRID is DONE!!! *******************************************
***************************************************************


And my setting in the easygrid.m file is
if smooth_grid == 1;
order = 2; % Order of Shapiro filter (2,4,8)... default: 2
rlim = 0.35; % Maximum r-factor allowed (0.35)... default: 0.35
npass = 50; % Maximum number of passes.......... default: 50
end


What's more, while I run the model using this depth, it will blowing-up.

But if I use the depth from ETOPO5 to run this model, it is OK.

Who can you tell me what should I do? Why the easygrid.m just outputed that
Number of smoothing applications: 1
while I smoothing the depth at the second time?

I hope your help! Thank You!

Post Reply