Ocean Modeling Discussion

ROMS/TOMS

Search for:
It is currently Sun Oct 22, 2017 9:12 pm




Post new topic Reply to topic  [ 3 posts ] 

All times are UTC

Author Message
 Post subject: WRF-ROMS coupling
PostPosted: Sat Oct 26, 2013 4:54 pm 
Offline

Joined: Mon Apr 22, 2013 3:17 pm
Posts: 4
Location: Hormozgan Uni
Dear Users
I want to couple WRF-ROMS-SWAN models. for this purpose i try to compile COAWST codes and JOE_TC test case,but i have some errors with it:

L/home/mohammadpour/COAWST/Lib/MCT/pgi_mct/lib -lmct -lmpeu -L/home/mohammadpour/libs_pgi/lib -lnetcdf
/opt/pgi/linux86-64/9.0-2/lib/f90main.o: In function `main':
f90main.c:(.text+0x3c): undefined reference to `MAIN_'
[color=#0000FF]make[2]: [em_wrf] Error 2 (ignored)

make[2]: Leaving directory `/home/mohammadpour/COAWST/WRF/main'
( cd run ; /bin/rm -f wrf.exe ; ln -s ../main/wrf.exe . )
if [ 0 -eq 1 ] ; then \
( cd main ; make -i -r MODULE_DIRS="-I../dyn_em -I../dyn_nmm -module /home/mohammadpour/COAWST/WRF/main -I/home/mohammadpour/COAWST/WRF/external/esmf_time_f90 -I/home/mohammadpour/COAWST/WRF/main -[/color]

.......

PGF90-S-0155-Could not resolve generic procedure globalsegmap_lsize (ocean_coupler.f90: 1131)
PGF90-S-0038-Symbol, ocn_comm_world, has not been explicitly declared (ocean_coupler.f90)
0 inform, 0 warnings, 2 severes, 0 fatal for ocn2atm_coupling_tile
make: *** [Build/ocean_coupler.o] Error 2


i use fedora 17, 64 bit, with pgi compiler. does anyone know how to solve these problems?

Regards,
Mohammadreza


Top
 Profile  
Reply with quote  
 Post subject: Re: WRF-ROMS coupling
PostPosted: Mon Oct 28, 2013 2:09 am 
Offline

Joined: Wed Dec 31, 2003 6:16 pm
Posts: 666
Location: USGS, USA
the first issue of not finding wrf.exe is ok, that is not an error. The coupled code can only have one executable, and it makes a coawstM.exe. So you can diregard that fact that it cant find wrf.exe, it will not exist.

for the second issue,
"PGF90-S-0155-Could not resolve generic procedure globalsegmap_lsize (ocean_coupler.f90: 1131)
PGF90-S-0038-Symbol, ocn_comm_world, has not been explicitly declared (ocean_coupler.f90)"
did you set MPI=on and MPIf90=on in your coawst.bash? if it does not know what ocn_comm_world is, then it most likely does not think it needs mpi.

if you cant resolve it, please do this:
scrip build.log
./coawst.bash
exit
and send the build.log file to me at
jcwarner@usgs.gov

we are setting up a different location to discuss issue with model coupling, not specific to the Rutgers code.
thanks
john


Top
 Profile  
Reply with quote  
 Post subject: Re: WRF-ROMS coupling
PostPosted: Tue Oct 29, 2013 12:48 am 
Offline

Joined: Wed Mar 02, 2011 6:46 pm
Posts: 33
Location: University of Michigan
John,

Please let us know when you set up another location to discuss model coupling. I know some people at my location who would definitely be interested and I'm sure there are many other people who are interested as well.

Patrick


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group