Two-way nested simulation error

General scientific issues regarding ROMS

Moderators: arango, robertson

Post Reply
Message
Author
wavewatch
Posts: 11
Joined: Thu Nov 14, 2013 1:51 am
Location: institute of oceanology

Two-way nested simulation error

#1 Post by wavewatch » Tue Jun 16, 2020 4:23 am

Hi,
Recently I tried nesting simulation in ROMS and found Two_Way nesting reported errors. The result is the following error:

Code: Select all

TIME-STEP YYYY-MM-DD hh:mm:ss.ss  KINETIC_ENRG   POTEN_ENRG    TOTAL_ENRG    NET_VOLUME  Grid
                     C => (i,j,k)       Cu            Cv            Cw         Max Speed

         0 2000-01-02 00:00:00.00  1.314949E-03  2.184196E+04  2.184196E+04  1.005743E+17  01
                     (214,052,04)  3.291530E-02  3.888322E-02  0.000000E+00  9.450913E-01
      DEF_HIS     - creating  history      file, Grid 01: ./output/SP_s1_his_0001.nc
      WRT_HIS     - wrote history     fields (Index=1,1) in record = 0000001               01
      DEF_AVG     - creating  average      file, Grid 01: ./output/SP_s1_avg_0001.nc

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
--------------------------------------------------------------------------
A process has executed an operation involving a call to the
"fork()" system call to create a child process.  Open MPI is currently
operating in a condition that could result in memory corruption or
other system errors; your job may hang, crash, or produce silent
data corruption.  The use of fork() (or system() or other calls that
create child processes) is strongly discouraged.

The process that invoked fork was:

  Local host:          [[64185,1],0] (PID 13572)

If you are *absolutely sure* that your application will successfully
and correctly survive a call to fork(), you may disable this warning
by setting the mpi_warn_on_fork MCA parameter to 0.
--------------------------------------------------------------------------
#0  0x2B687FAD66F7
#1  0x2B687FAD6D3E
#2  0x2B688078426F
#3  0x5255BB in __nesting_mod_MOD_nesting
#4  0x46D4ED in main3d_
#5  0x403C5D in __ocean_control_mod_MOD_roms_run
#6  0x403868 in MAIN__ at master.f90:?
--------------------------------------------------------------------------
mpirun noticed that process rank 0 with PID 0 on node comput43 exited on signal 11 (Segmentation fault).
--------------------------------------------------------------------------
When I define ONE_WAY in the .h file, the mode worked, but blowing up quickly. In both cases, the boundary conditions can be found in Output/Input Files, however, no boundary values are read. In addition, the build Script file and *.in file are modified from the new version.Tip: I tried to run large domain with this version for 8 years without any errors.
For more detailed output reports, please browse to download the following file. Is there any obvious mistake?
Attachments
roms_refined.in
(135.34 KiB) Downloaded 13 times
One_way.log.txt
(78.08 KiB) Downloaded 12 times
Two_Way.log.txt
(60.51 KiB) Downloaded 12 times
build_roms.sh
(11.22 KiB) Downloaded 11 times
scs.h
(1.26 KiB) Downloaded 11 times

Post Reply