erro about MPDATA

General scientific issues regarding ROMS

Moderators: arango, robertson

Post Reply
Message
Author
fereshteh
Posts: 79
Joined: Sun Dec 30, 2012 2:58 pm
Location: inio:Iranian National Institute for Oceanography

erro about MPDATA

#1 Post by fereshteh » Tue Sep 17, 2019 6:37 am

I am running my test in parallel mode (shared-memory)
TS-MPDATA option is active in header file, so such error appeared in running step:
cannot active option:TS-MPDATA in serial with partitions or shared-memory..
Use distributed-memory (MPI) in parallel run
could you please tell me which option could be use instead of TS-MPDATA in shared-memory?
cheers
fereshte

User avatar
kate
Posts: 3681
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

Re: erro about MPDADA

#2 Post by kate » Tue Sep 17, 2019 4:22 pm

Any of the other advection schemes should work. Is there any reason you can't use MPI on that shared-memory cluster?

fereshteh
Posts: 79
Joined: Sun Dec 30, 2012 2:58 pm
Location: inio:Iranian National Institute for Oceanography

Re: erro about MPDADA

#3 Post by fereshteh » Sat Sep 21, 2019 10:11 am

many thanks for your reply. shared-memory is active cluster on my university server.
i used
#define TS_C4VADVECTION
#define TS_C4HADVECTION


Also, in older revision i used #define spline that i think reconstruct vertical diffusion and advection,simultaneously. my test does not have very high vertical resolution (20 layers for maximum depth about 1000 m).So, is it good to use following option?

SPLINES_VDIFF and SPLINES_VVISC
cheers
Fereshte

Post Reply