import pyroms error

General scientific issues regarding ROMS

Moderators: arango, robertson

Post Reply
Message
Author
hzh_1211
Posts: 17
Joined: Mon Nov 30, 2015 5:22 pm
Location: NUIST

import pyroms error

#1 Post by hzh_1211 » Fri May 18, 2018 1:59 am

Hello,
I tried to install pyroms in Ubuntu18.04LTS, the Prerequisites of pyroms list in https://github.com/ESMG/pyroms have been installed. Such as liblpsolve55.so (tutorial1 and tutorial2) and scrip.so (tutorial) can be seen in

Code: Select all

henry@ubuntu:~$ find -name liblpsolve55.so
./lp_solve_5.5/lpsolve55/bin/ux64/liblpsolve55.so
./anaconda3/lib/liblpsolve55.so
./anaconda3/lib/python3.6/site-packages/liblpsolve55.so
./anaconda3/pkgs/lpsolve-5.5.2.3-4/lib/liblpsolve55.so
henry@ubuntu:~$ find -name scrip.so
./anaconda3/lib/scrip.so
./anaconda3/lib/python3.6/site-packages/scrip.so
./anaconda3/lib/python3.6/site-packages/pyroms/scrip.so
./anaconda3/lib/python3.6/site-packages/pyroms/remapping/scrip.so
However, when I import pyroms, gives the error message:

Code: Select all

>>> import pyroms
scrip.so not found. Remapping function will not be available
I have added the three packages of pyroms into mypkpath.pth which located in /home/henry/anaconda3/lib/python3.6/site-packages and can import lpsolve55 smoothly.
How can I sove this problem?
Thanks,
Henry

User avatar
kate
Posts: 3803
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: import pyroms error

#2 Post by kate » Fri May 18, 2018 6:23 am

Does your LD_LIBRARY_PATH include any of the places with these libraries? Mine does.

hzh_1211
Posts: 17
Joined: Mon Nov 30, 2015 5:22 pm
Location: NUIST

Re: import pyroms error

#3 Post by hzh_1211 » Fri May 18, 2018 8:22 am

kate wrote:Does your LD_LIBRARY_PATH include any of the places with these libraries? Mine does.
Yes, I have set LD_LIBRARY_PATH=/home/henry/anaconda3/lib that includes scrip.so, and I also change the LD_LIBRARY_PATH to other path that include scrip.so but
the error still exists.
Furthermore, I met another problem when python make_YELLOW_grd_v1.py that matplotlib.mlab.griddata: the griddata function was deprecated in version 2.2 (https://matplotlib.org/api/mlab_api.html), however I have solved this problem through reducing the version of matplotlib lower than version2.2, but dose have other ways to solve this problem?

Thanks for your reply,
Henry

User avatar
kate
Posts: 3803
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: import pyroms error

#4 Post by kate » Fri May 18, 2018 3:44 pm

The deprecated message should be just a warning. Do they provide a suggestion for what routine to use instead?

User avatar
kate
Posts: 3803
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: import pyroms error

#5 Post by kate » Fri May 18, 2018 6:51 pm

I just got some of those warnings:
/import/u/u1/uaf/kshedstrom/.conda/envs/snowdrifts/lib/python3.5/site-packages/mpl_toolkits/basemap/__init__.py:3608: MatplotlibDeprecationWarning: The ishold function was deprecated in version 2.0.
b = ax.ishold()
/import/u/u1/uaf/kshedstrom/.conda/envs/snowdrifts/lib/python3.5/site-packages/mpl_toolkits/basemap/__init__.py:3677: MatplotlibDeprecationWarning: axes.hold is deprecated.
Note that the warnings don't refer to pyroms code but to code in another package. These things should clear up in good time and can be ignored in the mean time.

hzh_1211
Posts: 17
Joined: Mon Nov 30, 2015 5:22 pm
Location: NUIST

Re: import pyroms error

#6 Post by hzh_1211 » Sat May 19, 2018 8:21 am

kate wrote:The deprecated message should be just a warning. Do they provide a suggestion for what routine to use instead?
As you say, The deprecated message just a warning, matplotlib.mlab.griddata can work on version 2.2.
However, my first problem cannot be solved.
I re-installed the pyroms according https://houstonthereisaproblem.blogspot ... -1072.html.
My pyroms is installed into /home/henry/pyroms and all external packages are installed into /home/henry/pyroms/ext.
The scrip*.so is localed at

Code: Select all

henry@ubuntu:~$ find -name scrip*.so
./Downloads/pyroms-python3/pyroms/external/scrip/source/scrip.cpython-36m-x86_64-linux-gnu.so
./pyroms/ext/lib/scrip.cpython-36m-x86_64-linux-gnu.so
./pyroms/lib/scrip.cpython-36m-x86_64-linux-gnu.so
./pyroms/lib/python3.6/site-packages/pyroms/remapping/scrip.cpython-36m-x86_64-linux-gnu.so
./pyroms/scrip.cpython-36m-x86_64-linux-gnu.so
and then set the following environment variables

Code: Select all

export PYROMS=/home/henry/pyroms
export PYROMS_GRIDID_FILE=/home/henry/Downloads/pyroms-python3/pyroms/pyroms/gridid.txt
export PYTHONPATH=$PYROMS/lib/python3.6/site-packages:$PYTHONPATH
export PYTHONPATH=$PYROMS/ext/lib:$PYTHONPATH
export DYLD_LIBRARY_PATH=$PYROMS/lib/python3.6/site-packages/bathy_smoother:$DYLD_LIBRARY_PATH
export DYLD_LIBRARY_PATH=$PYROMS/ext/lib:$DYLD_LIBRARY_PATH
export PATH=$PYROMS/ext/lib:$PATH
export LD_LIBRARY_PATH=$PYROMS/lib:LD_LIBRARY_PATH=$PYROMS/ext/lib:$LD_LIBRARY_PATH
but still have the message that

Code: Select all

>>> import pyroms
scrip.so not found. Remapping function will not be available

I have no idea to solve this prolbem, please give me some advises!

Post Reply