ROMS-WRF coupling problem

General scientific issues regarding ROMS

Moderators: arango, robertson

Post Reply
Message
Author
hzh_1211
Posts: 14
Joined: Mon Nov 30, 2015 5:22 pm
Location: NUIST

ROMS-WRF coupling problem

#1 Post by hzh_1211 » Fri Sep 08, 2017 2:45 pm

I got a mistake when I do a coupled modelling IN WRF-ROMS.
The ROMS grid size is 274 by 224,as same as wrf grid.

Code: Select all


 MCT::m_ExchangeMaps::ExGSMapGSMap_:: MCTERROR, Grid Size mismatch 
 LocalMap Gsize =        61376  RemoteMap Gsize =        62376
 MCT::m_ExchangeMaps::ExGSMapGSMap_:: MCTERROR, Grid Size mismatch 
 LocalMap Gsize =        62376  RemoteMap Gsize =        61376
MCT::m_ExchangeMaps::ExGSMapGSMap_: Map Grid Size mismatch error, stat =3
MCT::m_ExchangeMaps::ExGSMapGSMap_: Map Grid Size mismatch error, stat =3
000.MCT(MPEU)::die.: from MCT::m_ExchangeMaps::ExGSMapGSMap_()
004.MCT(MPEU)::die.: from MCT::m_ExchangeMaps::ExGSMapGSMap_()
[cli_0]: aborting job:
application called MPI_Abort(MPI_COMM_WORLD, 2) - process 0
[cli_4]: aborting job:
application called MPI_Abort(MPI_COMM_WORLD, 2) - process 4
I down't know why the grid size mismatched.

jcwarner
Posts: 821
Joined: Wed Dec 31, 2003 6:16 pm
Location: USGS, USA

Re: ROMS-WRF coupling problem

#2 Post by jcwarner » Fri Sep 08, 2017 5:46 pm

looks odd. if they are same grid, make sure you dont define MCT_INTERP_OC2AT.
did you try any of the cases distributed with the code?
-john

hzh_1211
Posts: 14
Joined: Mon Nov 30, 2015 5:22 pm
Location: NUIST

Re: ROMS-WRF coupling problem

#3 Post by hzh_1211 » Sat Sep 09, 2017 1:20 am

jcwarner wrote:looks odd. if they are same grid, make sure you dont define MCT_INTERP_OC2AT.
did you try any of the cases distributed with the code?
-john
Thanks for your apply, I dont difine MCT_INTERP_OC2AT,and take a successful JOE_TC_coupling case,
unsuccessful case:

Code: Select all

wrf:	       		                        ROMS:
dimensions:                                    |dimensions:
        Time = UNLIMITED ; // (1 currently)    |        xi_psi = 273 ;
        DateStrLen = 19 ;                      |        xi_rho = 274 ;
        west_east = 274 ;                      |        xi_u = 273 ;
        south_north = 224 ;                    |        xi_v = 274 ;
        bottom_top = 29 ;                      |        eta_psi = 223 ;
        bottom_top_stag = 30 ;                 |        eta_rho = 224 ;
        soil_layers_stag = 4 ;                 |        eta_u = 224 ;
        west_east_stag = 275 ;                 |        eta_v = 223 ;
        south_north_stag = 225 ;               |        one = 1 ;
        DIM0009 = 5 ;                          |        two = 2 ;
        land_cat_stag = 24 ;                   |        bath = 1 ;
        soil_cat_stag = 16 ;                   |variables:
        num_ext_model_couple_dom_stag = 1 ;    |
successful case grid:

Code: Select all

netcdf wrfinput_d01 {                          |netcdf joe_tc_grd {
dimensions:                                    |dimensions:
        Time = UNLIMITED ; // (1 currently)    |        xi_psi = 198 ;
        DateStrLen = 19 ;                      |        xi_rho = 199 ;
        west_east = 199 ;                      |        xi_u = 198 ;
        south_north = 149 ;                    |        xi_v = 199 ;
        west_east_stag = 200 ;                 |        eta_psi = 148 ;
        bottom_top = 30 ;                      |        eta_rho = 149 ;
        south_north_stag = 150 ;               |        eta_u = 149 ;
        bottom_top_stag = 31 ;                 |        eta_v = 148 ;
        ext_scalar = 1 ;                       |        one = 1 ;
        DIM0009 = 5 ;                          |        two = 2 ;
        soil_layers_stag = 4 ;                 |        bath = UNLIMITED ; // (0 currently)
        land_cat_stag = 24 ;                   |variables:
        soil_cat_stag = 16 ;                   |        double xl(one) ;

hzh_1211
Posts: 14
Joined: Mon Nov 30, 2015 5:22 pm
Location: NUIST

Re: ROMS-WRF coupling problem

#4 Post by hzh_1211 » Sat Sep 09, 2017 5:59 am

I found my mistake,should be that
LLm= x_rho - 2;
LLm= y_rho - 2;

Post Reply