blow up at first step as long as I turn on the bulk flux

General scientific issues regarding ROMS

Moderators: arango, robertson

Post Reply
Message
Author
shifei
Posts: 30
Joined: Thu Aug 01, 2013 3:11 pm
Location: Ocean University of China

blow up at first step as long as I turn on the bulk flux

#1 Post by shifei » Mon Oct 27, 2014 1:06 am

Hi,
The atmospheric forcing variables are from NCEP2. As long as I turn on the BULK_FLUXES, it blows up at first step. No nans in the forcing file. However, I tryed the analytical values, it works ok.
Attachments
my_subei_all.log
(47.6 KiB) Downloaded 66 times

jcwarner
Posts: 854
Joined: Wed Dec 31, 2003 6:16 pm
Location: USGS, USA

Re: blow up at first step as long as I turn on the bulk flux

#2 Post by jcwarner » Mon Oct 27, 2014 1:24 am

GET_2DFLD - surface u-wind component, t = 365 06:00:00
(Rec=0001462, Index=2, File: subei_Uwind.nc)
(Tmin= 0.0000 Tmax= 3652.7500)
(Min = 1.00000000E+35 Max = -1.00000000E+35)
GET_2DFLD - surface v-wind component, t = 365 06:00:00
(Rec=0001462, Index=2, File: subei_Vwind.nc)
(Tmin= 0.0000 Tmax= 3652.7500)
(Min = 1.00000000E+35 Max = -1.00000000E+35)
GET_2DFLD - surface air pressure, t = 365 06:00:00
(Rec=0001462, Index=2, File: subei_Pair.nc)
(Tmin= 0.0000 Tmax= 3652.7500)
(Min = 1.00000000E+35 Max = -1.00000000E+35)
GET_2DFLD - solar shortwave radiation flux, t = 365 06:00:00
(Rec=0001462, Index=2, File: subei_swrad.nc)
(Tmin= 0.0000 Tmax= 3652.7500)
(Min = 1.00000000E+35 Max = -1.00000000E+35)
GET_2DFLD - downwelling longwave radiation flux, t = 365 06:00:00
(Rec=0001462, Index=2, File: subei_lwrad.nc)
(Tmin= 0.0000 Tmax= 3652.7500)
(Min = 1.00000000E+35 Max = -1.00000000E+35)
GET_2DFLD - surface air temperature, t = 365 06:00:00
(Rec=0001462, Index=2, File: subei_Tair.nc)
(Tmin= 0.0000 Tmax= 3652.7500)
(Min = 1.00000000E+35 Max = -1.00000000E+35)
GET_2DFLD - surface air relative humidity, t = 365 06:00:00
(Rec=0001462, Index=2, File: subei_Qair.nc)
(Tmin= 0.0000 Tmax= 3652.7500)
(Min = 1.00000000E+35 Max = -1.00000000E+35)
GET_2DFLD - rain fall rate, t = 365 06:00:00
(Rec=0001462, Index=2, File: subei_rain.nc)
(Tmin= 0.0000 Tmax= 3652.7500)
(Min = 1.00000000E+35 Max = -1.00000000E+35)


DO you see anything strange here? these min/maxs are not good. perhaps you have fill values in your data?
probably replace them with zeros or some other appropriate value.
-j

shifei
Posts: 30
Joined: Thu Aug 01, 2013 3:11 pm
Location: Ocean University of China

Re: blow up at first step as long as I turn on the bulk flux

#3 Post by shifei » Mon Oct 27, 2014 10:37 am

I have checked the data, it is just this problem. Thank you very much.

nacholibre
Posts: 81
Joined: Thu Dec 07, 2006 3:14 pm
Location: USGS
Contact:

Re: blow up at first step as long as I turn on the bulk flux

#4 Post by nacholibre » Mon Oct 27, 2014 3:51 pm

Did you make sure that your atmospheric forcing file domain has a larger footprint than your ROMS grid? Interpolation onto your domain may have a problem otherwise...
Zafer

shifei
Posts: 30
Joined: Thu Aug 01, 2013 3:11 pm
Location: Ocean University of China

Re: blow up at first step as long as I turn on the bulk flux

#5 Post by shifei » Mon Nov 03, 2014 3:08 am

Hi,
ROMS seems only accept the longitude and latitude of monotonous increasing. If you provide the latitude like [30 29 28 27 26 25] instead of [25 26 27 28 29 30], the weird min/max values above appear.

lanerolle
Posts: 157
Joined: Mon Apr 28, 2003 5:12 pm
Location: NOAA

Re: blow up at first step as long as I turn on the bulk flux

#6 Post by lanerolle » Mon Nov 03, 2014 3:06 pm

The easiest way to do this is to have another coarser grid that overlaps your model grid but is bigger in extent and put the met variables on this grid and get ROMS to internally do the interpolation when the model runs. Here is a sample ncdump of what I am doing (from my met NetCDF file):

Code: Select all

Dimensions:
           xi_surf  = 91
           eta_surf = 111
           frc_time = 5857  (UNLIMITED)
Variables:
    frc_time  
           Size:       5857x1
           Dimensions: frc_time
           Datatype:   single
           Attributes:
                       long_name = 'Forcing time'
                       units     = 'days'
    lon_surf  
           Size:       91x111
           Dimensions: xi_surf,eta_surf
           Datatype:   single
           Attributes:
                       long_name = 'Longitude location of surface forcing data points'
                       units     = 'degrees'
    lat_surf  
           Size:       91x111
           Dimensions: xi_surf,eta_surf
           Datatype:   single
           Attributes:
                       long_name = 'Latitude location of surface forcing data points'
                       units     = 'degrees'
    Uwind     
           Size:       91x111x5857
           Dimensions: xi_surf,eta_surf,frc_time
           Datatype:   single
           Attributes:
                       long_name   = 'Eastern component of the wind speed'
                       units       = 'm/s'
                       coordinates = 'lon_surf lat_surf'
                       time        = 'frc_time'
So my coarse grid dimensions are [xi_surf, eta_surf] and the (lon,lat) on this grid are called (lon_surf, lat_surf). All of my met variables are defined on this grid and when you do so, you need to put the additional NetCDF file attribute "coordinates = 'lon_surf lat_surf'" as shown above to tell ROMS that it needs to read-off the met variables from this coarser grid and thereafter do the interpolation internally.

When you put your met variables on this coarser grid, you have to ensure that the variable values are all meaningful and should exclude NaN, Inf, 1.0e+35, type values.

User avatar
kate
Posts: 3780
Joined: Wed Jul 02, 2003 5:29 pm
Location: CFOS/UAF, USA

Re: blow up at first step as long as I turn on the bulk flux

#7 Post by kate » Mon Nov 03, 2014 5:06 pm

Not only that, but a theme I've been hearing this year is to not use land winds over the ocean. If your atmospheric model is coarse, you can easily end up using winds from the land portion of the atmospheric grid over the coastal ocean. I'm running a program to do an extrapolation of ocean fields into the land part of all my atmospheric fields.

lanerolle
Posts: 157
Joined: Mon Apr 28, 2003 5:12 pm
Location: NOAA

Re: blow up at first step as long as I turn on the bulk flux

#8 Post by lanerolle » Mon Nov 03, 2014 6:14 pm

Yes, Kate is correct and sorry that I did not mention it in my message. I too avoid using winds over land during the interpolation and you may also want to look at air temperature and relative humidity/dew point over land and choose to exclude them if necessary - for some applications, I do this too.

User avatar
wilkin
Posts: 526
Joined: Mon Apr 28, 2003 5:44 pm
Location: Rutgers University
Contact:

Re: blow up at first step as long as I turn on the bulk flux

#9 Post by wilkin » Tue Nov 04, 2014 12:01 pm

You have min/max values of 1e+35
(Min = 1.00000000E+35 Max = -1.00000000E+35)
Obviously you having missing values in the netcdf file that are being interpolated to ROMS. You need to fill them with something sensible or remove them. Wind speeds of 1+35 m/s will certainly blow up on the first time step.
John Wilkin: DMCS Rutgers University
71 Dudley Rd, New Brunswick, NJ 08901-8521, USA. ph: 609-630-0559 jwilkin@rutgers.edu

shifei
Posts: 30
Joined: Thu Aug 01, 2013 3:11 pm
Location: Ocean University of China

Re: blow up at first step as long as I turn on the bulk flux

#10 Post by shifei » Thu Nov 06, 2014 7:49 am

Thank you very much :D

Post Reply