how to set KPP parameter in .in file

Discussion of how to use ROMS on different regional and basin scale applications.

Moderators: arango, robertson

Post Reply

how to set KPP parameter in .in file

#1 Post by gming » Thu Nov 29, 2007 7:02 pm

can anybody give me some hints on how to set the parameters in .in file for LMD (KPP) mixing?

I checked some examples (ie, which uses KPP, but it looks that they all use the same values as GLS, such as
GLS_P == 3.0d0 ! K-epsilon
GLS_M == 1.5d0
GLS_N == -1.0d0
GLS_Kmin == 7.6d-6
GLS_Pmin == 1.0d-12

GLS_CMU0 == 0.5477d0
GLS_C1 == 1.44d0
GLS_C2 == 1.92d0
GLS_C3M == -0.4d0
GLS_C3P == 1.0d0
GLS_SIGK == 1.0d0
GLS_SIGP == 1.30d0

To my understanding, KPP calculates most of the coefficients itself and it has quite different scheme from GLS, so I just wonder does those parameters above important in KPP? or I should set different values for them?

I am asking this because my model blows up after several days-running with KPP, while runs well with GLS.



User avatar
Posts: 3700
Joined: Wed Jul 02, 2003 5:29 pm
Location: IMS/UAF, USA

#2 Post by kate » Thu Nov 29, 2007 7:42 pm contains a superset of values used by all the options. If you are using KPP and not GLS, these GLS parameters will not even be read by ROMS. You need to find another culprit to hunt down - or just run with GLS. What domain? What problem are you trying to solve? Is it important to have KPP? Have you looked at plots of the blow up to see what the trouble looks like?


#3 Post by gming » Thu Nov 29, 2007 10:59 pm

We have set up a bio-physical model for a coastal domain, about 100*100 km. The reason to use kpp is just to test the sensitivity of the model result to different mixing scheme. The model blows up on the east open boundary, an estruine area. I suspect that's because I haven't set right (or reasonable) value for kpp, but I am not sure where, and how to set that as I didn't find anything in the examples.

Post Reply