Ocean Modeling Discussion

ROMS/TOMS

Search for:
It is currently Tue Dec 11, 2018 4:44 am




Post new topic Reply to topic  [ 2 posts ] 

All times are UTC

Author Message
PostPosted: Fri Jul 03, 2015 2:28 am 
Offline

Joined: Thu Jun 11, 2015 5:13 pm
Posts: 5
Location: YoungDong University
Hello

I've got eight XeonPhi system.
I was running a successful ROMS to MIC mode.
I want to run at the same time as the ROMS eight XeonPhi.
I used the intel mpi.
I've created a machinefile mics.
<Mics>

mic0: 24
mic1: 24
# Mic2
# Mic3
# Mic4
# Mic5
# Mic6
# Mic7

Only two XeonPhi've entered for testing.
And
: ~> mpiexe.hydra -machinefile mics -n 48 ./oceanM-mic ROMS / External / ocean_upwelling.in

phi-test-mic0: SCM: 51fe: e5061b40: 1119 us (1119 us): open_hca: ibv_get_device_list () failed
phi-test-mic0: SCM: 51fe: e5061b40: 1155 us (1155 us): open_hca: ibv_get_device_list () failed
phi-test-mic0: CMA: 51fe: e5061b40: 1148 us (1148 us): open_hca: getaddr_netdev ERROR: No such device. Is ib0 configured?
phi-test-mic0: CMA: 51fe: e5061b40: 1488 us (1488 us): open_hca: getaddr_netdev ERROR: No such device. Is ib1 configured?
phi-test-mic0: SCM: 51fe: e5061b40: 1097 us (1097 us): open_hca: ibv_get_device_list () failed
phi-test-mic0: SCM: 51fe: e5061b40: 1118 us (1118 us): open_hca: ibv_get_device_list () failed
phi-test-mic0: SCM: 51fe: e5061b40: 979 us (979 us): open_hca: ibv_get_device_list () failed
phi-test-mic1: SCM: 20ea: 372a5b40: 1118 us (1118 us): open_hca: ibv_get_device_list () failed
phi-test-mic1: SCM: 20ea: 372a5b40: 252 us (252 us): open_hca: ibv_get_device_list () failed
phi-test-mic0: SCM: 51fe: e5061b40: 900 us (900 us): open_hca: ibv_get_device_list () failed
.
.
(Many error messages.)
.
.
many
What's wrong?


Thank you.


Top
 Profile  
Reply with quote  
PostPosted: Fri Jul 03, 2015 9:59 am 
Hi kissrang,
The best place to post Xeon Phi related issues is to post in https://software.intel.com/ forums. I found a post with a similar issue with WRF which has some good points for you to try.

Here is the post: https://software.intel.com/en-us/forums/topic/542161

You must make sure that you have the /opt folder in the host mounted on both the mics, source the host mpivars.sh since you are launching the app from the host, make sure you have the driver installed for the fabric you are trying to use, set I_MPI_MIC to 1...

You can try setting I_MPI_FABRICS to shm:tcp to check if it is driver related.

-gopal


Top
  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group