Compiling with analytical sediment

Discussion of how to use ROMS on different regional and basin scale applications.

Moderators: arango, robertson

Post Reply
Message
Author
tnmiles
Posts: 9
Joined: Wed Oct 15, 2008 3:22 pm
Location: Rutgers

Compiling with analytical sediment

#1 Post by tnmiles » Thu Jun 06, 2013 7:22 pm

I'm trying to turn on the sediment transport features with the newest version of ROMS and am running into problems compiling with ANA_SEDIMENT as my initial sediment conditions. I'm using these options:

#define SSW_BBL
#ifdef SSW_BBL
#define SSW_CALC_ZNOT
#define SSW_CALC_UB
#endif

#define SEDIMENT
#ifdef SEDIMENT
#define ANA_SEDIMENT
#undef SUSPLOAD
#define BEDLOAD_SOULSBY
#endif

and get the following error when I try to compile:


PGF90-S-0034-Syntax error at or near : (analytical.f90: 374)
0 inform, 0 warnings, 1 severes, 0 fatal for ana_sediment_tile

User avatar
wilkin
Posts: 513
Joined: Mon Apr 28, 2003 5:44 pm
Location: Rutgers University
Contact:

Re: Compiling with analytical sediment

#2 Post by wilkin » Fri Jun 07, 2013 12:38 am

So when you look in Build/analytical.f90 at line 374 what invalid FORTRAN syntax do you see?

Work backward from this to determine what you did not correctly configure in your ana_sediment.h that you customized for your application.
John Wilkin: DMCS Rutgers University
71 Dudley Rd, New Brunswick, NJ 08901-8521, USA. ph: 609-630-0559 jwilkin@rutgers.edu

tnmiles
Posts: 9
Joined: Wed Oct 15, 2008 3:22 pm
Location: Rutgers

Re: Compiling with analytical sediment

#3 Post by tnmiles » Fri Jun 07, 2013 3:06 am

I figured it out, I was using the ana_sediment from the User folder so there were ??? instead of values, got it to compile when i used the settings from sed_test.

Thanks!

Post Reply