Ocean Modeling Discussion

ROMS/TOMS

Search for:
It is currently Tue Jul 23, 2019 5:48 pm




Post new topic Reply to topic  [ 8 posts ] 

All times are UTC

Author Message
PostPosted: Thu May 14, 2009 11:49 am 
Offline

Joined: Tue Mar 17, 2009 4:06 pm
Posts: 45
Location: cpeo,ocean university of china
I am doing a tidal forcing only 2D case.I am quite confused about my test cases :
case 1: minimum depth 10m,RDRG2 == 3.0d-03,tide elevation amplitude 30-100cm lower than public quite recognized results.And lower(above30cm) than the tpxo_data I used for forcing.
case 2: minimum depth 10m,RDRG2 == 2.5d-03,tide elevation amplitude even lower than case 1.
case 3: minimum depth 5m(more close to reality),RDRG2 == 2.5d-03,tide elevation amplitude even lower than case 2.And tide amphidromic point(nodal point) is worse and worse.Even no where there should be.
I don't quite understand why.Would some one give some advice?
Thanks in advance.


Top
 Profile  
Reply with quote  
PostPosted: Thu May 14, 2009 2:36 pm 
Offline

Joined: Fri Sep 19, 2008 8:42 pm
Posts: 10
Location: PROOCEANO
Hi bibi951,

I was facing the same problem, i.e. small tide amplitudes compared to observed and even to the forcing imposed. Then I checked the following discussion https://www.myroms.org/forum/viewtopic.php?f=14&t=854 and used the FSOBC_REDUCED cpp option. The tidal amplitudes are now much closer to observed. So, I think the problem is on the tidal velocity ellipses estimation for forcing files. I´m using the recommended matlab scripts (ap2ep.m), but I think there might be some issue on that estimation (probably my fault...). I´ll try to investigate further, but that might take some time. If I have some news on that I´ll let you (all) know...

Regards,

Mauricio
PROOCEANO - Brazil.


Top
 Profile  
Reply with quote  
PostPosted: Sun May 17, 2009 11:18 am 
Offline

Joined: Tue Mar 17, 2009 4:06 pm
Posts: 45
Location: cpeo,ocean university of china
Hi,everyone.
My case underestimate the tide amplitude,so I suppose that my ubar vbar are not consistent with my zeta.So I use reduced physics by defining FSOBC_REDUCED
and ****_M2REDUCED.However it blowup after 8.5days simulation.
I checked the ubar and the zeta.I find that there is only one point on the open boundry with abrupt increase of ubar from 2or3m/s to 21m/s in 3-4 hours,and the corresponding zeta is much bigger than the vicinity points-1.0m VS 0.2m or so.And I checked the depth,there is no intense gradient.
I wonder what triggered this. And how to deal this problem?
Regards.


Top
 Profile  
Reply with quote  
PostPosted: Tue May 19, 2009 2:06 am 
Offline

Joined: Tue Mar 17, 2009 4:06 pm
Posts: 45
Location: cpeo,ocean university of china
I had another try.There is no zeta problem mentioned above(seems reasonable-all around 0.6 when ubar goes to the sky).The blowup begines here(red),and spread up-right.
The depth is :where 10 means land,and I have checked my mask to be consistent.
10 10 874.75 929.36 833.89 713.79 10 489.22 805.24
10 484.63 508.84 10 10 10 10 176.76 549.64
491.38 436.69 10 10 10 39.28 87.99 10 457.58
662.86 623.8 504.89 265.82 10 139.17 197.96 262.67 340.63
1061.1 985.94 880.21 780.64 550.32 404.38 385.71 350.78 10
1498.6 1299.3 1175.2 1143.5 998.62 813.09 722.26 625.05 595.35
2066.8 1823 1738.5 1732.4 1589.3 1406.7 1224.6 1122.9 1083.2
2494.9 2400.9 2510.3 2504.3 2274.3 2102.8 1947.4 1811.8 1688.4
2381.8 2470.2 2680.6 2848.1 2802.1 2708.8 2687.7 2597.6 2440
When I didn't use Reduced Physics,it is OK?
what can cause this problem?
It is 2D. It would not be the T-S problem since I set them uniform along the boundry,right? If yes, why not blowup in the first several steps?
I just wonder how to debug this?
Please give me some guide!


Top
 Profile  
Reply with quote  
PostPosted: Tue May 19, 2009 8:49 am 
Offline

Joined: Tue Mar 17, 2009 4:06 pm
Posts: 45
Location: cpeo,ocean university of china
I just think of what is the balance in the momentum equition in my simple case?
Since my Open Boundry is very close to the equator, will there be a prolem considering f ?
I don't think the horizontal pressure gradient is the problem since the depth gradient and my only one vertical layer? But why not break after several steps?
It really drive me crazy.


Top
 Profile  
Reply with quote  
PostPosted: Thu May 28, 2009 2:58 pm 
Offline

Joined: Fri Sep 19, 2008 8:42 pm
Posts: 10
Location: PROOCEANO
Hi bibi951 and all,

Just for the record, about my previous post. I found the problem I was facing about small tidal amplitude (and of course, was my mistake! :oops: ). So in order to help others that might face the same mistake...

The problem wasn´t on the tidal velocity ellipses estimation for forcing files as I mentioned. The problem was on the combination of open boundary conditions I was using. What happened was I using VOLCONS option along with ADD_FSOBC, ADD_M2OBC, M2FLATHER and FSCHAPMAN and the result was that the tide didn´t propagate well. With FSOBC_REDUCED on, the tide worked well, but after some days run the model was blowing up on the open boundary. After I turned VOLCONS and FSOBC_REDUCED off (and using ADD_FSOBC, ADD_M2OBC, M2FLATHER and FSCHAPMAN) the tide worked well and I managed to run the model for two years without problem.

Is kind of obvious, but I didn´t realize till now: do not use VOLCONS option when forcing with tides.

Lesson learned! :wink:

Regards,

Mauricio
PROOCEANO - Brazil.


Top
 Profile  
Reply with quote  
PostPosted: Fri May 29, 2009 3:42 am 
Offline

Joined: Tue Mar 17, 2009 4:06 pm
Posts: 45
Location: cpeo,ocean university of china
Hi,Mauricio
Do you check the _REDUCED CASE , and see why it blowup at the open boundry.
I am quite confused about how to debug it as I mentioned above.

Regards!


Top
 Profile  
Reply with quote  
PostPosted: Wed Jun 10, 2009 9:51 pm 
Offline

Joined: Fri Sep 19, 2008 8:42 pm
Posts: 10
Location: PROOCEANO
Hi bibi951,

I didn´t go through the equations yet to check why it blew up at the boundary (and to be honest I´m not quite sure if I´ll do it...). What I can tell is that the problem is on the barotropic velocity at the boundary. The combination of reduced physics with M2FLATHER makes it unstable.

My debbuging process relies pretty much on try/error. Based on my past experience (and some research on the wikis and bulletin boards) and of course, some theoretical knowledge (not much I can assure you...) I analyse the problem I´m trying to simulate and make my choices of boundary and initial conditions.

Then I run the model to see if it is stable and if not (probably not!) I make some analysis to try to identify what´s wrong. To do that you have to write the output with high frequency, check the suspicious issues (like boundaries, steep bathymetry regions etc.) and its related variables. Then, choose another boundary conditions to see if the problem is solved (probably not!). And so on, until you get a smooth ride!

Then of course, you must evaluate the results with observed data and if you are not satisfied (probably not!), you´ll have to go back some steps! And here we go again! With luck, you get some interesting results before you get tired and start over on another region to study a complete different aspect of ocean circulation!

Well, but that´s what we do, isn´t it?

Best of luck.

Mauricio
PROOCEANO - Brazil.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group