Search found 14 matches

by cjroach
Tue Sep 07, 2021 2:53 am
Forum: Meetings/Workshops
Topic: ICSHMO 2022, Christchurch NZ 8-12 Feb
Replies: 0
Views: 267

ICSHMO 2022, Christchurch NZ 8-12 Feb

The 13th international Conference on Southern Hemisphere Meteorology and Oceanography is happening in Christchurch NZ February next year. Currently plans includes both online and in-person sessions. Sessions can be found here , there's quite a few sessions that ROMS based numerical modelling would f...
by cjroach
Thu Jun 10, 2021 10:15 pm
Forum: ROMS Bugs
Topic: ROMS4 built with PIO, freeze on creating history file
Replies: 17
Views: 1499

Re: ROMS4 built with PIO, freeze on creating history file

As mention previously, the information in the Wiki tells you how to inquire the build script about the libraries that your are using to compile ROMS without actually compiling: *** That's all! Then, you can check if the PIO library is there. Sorry, but I'm working with a configuration set up by my ...
by cjroach
Wed Jun 09, 2021 12:11 am
Forum: ROMS Bugs
Topic: ROMS4 built with PIO, freeze on creating history file
Replies: 17
Views: 1499

Re: ROMS4 built with PIO, freeze on creating history file

Output of make script, excluding errors (see previous) and warnings.

A quick search suggests that the build script is linking to the PIO_INCDIR but not to the PIO_LIBDIR.
by cjroach
Tue Jun 08, 2021 11:23 pm
Forum: ROMS Bugs
Topic: ROMS4 built with PIO, freeze on creating history file
Replies: 17
Views: 1499

Re: ROMS4 built with PIO, freeze on creating history file

Those fixes (new version downloaded from SVN, adding PIO_LIB and HDF5 to the CPP definitions in roms3d.h) get me beyond the previous error but now I've run into a string of errors to do with undefined references to various PIO functions. ld: /nesi/project/mocean03294/NZB_3/build/libUTIL.a(lbc.o): in...
by cjroach
Tue Jun 08, 2021 9:51 pm
Forum: ROMS Bugs
Topic: ROMS4 built with PIO, freeze on creating history file
Replies: 17
Views: 1499

Re: ROMS4 built with PIO, freeze on creating history file

Thanks everyone. I'll wait until tomorrow, pull down the latest update, add the relevant CPP flags and then try again.
by cjroach
Tue Jun 08, 2021 4:56 am
Forum: ROMS Bugs
Topic: ROMS4 built with PIO, freeze on creating history file
Replies: 17
Views: 1499

Re: ROMS4 built with PIO, freeze on creating history file

Let's go through this again: I have USE_PIO=on enabled in my build script. This results in the issues described in my opening post, including the lack of PIO_LIB in the CPP flags listed in the log file. I have also tried adding # define PIO_LIB to roms3d.h, just in case there's something wrong in th...
by cjroach
Tue Jun 08, 2021 3:12 am
Forum: ROMS Bugs
Topic: ROMS4 built with PIO, freeze on creating history file
Replies: 17
Views: 1499

Re: ROMS4 built with PIO, freeze on creating history file

Thanks for the pointers. The missing PIO_LIB CPP option? I'll need to check the build scripts but I think I'd assume like the USE_NETCDF4 option it could be activated by adding export USE_PIO=on to my build script. Might need to try recompiling with PIO_LIB activated through the export my_CPP_option...
by cjroach
Tue Jun 08, 2021 12:13 am
Forum: ROMS Bugs
Topic: ROMS4 built with PIO, freeze on creating history file
Replies: 17
Views: 1499

ROMS4 built with PIO, freeze on creating history file

G'day, I've just installed ROMS4.0 with the new parallel IO setup on the NZ NESI HPC system. Compiling ROMS didn't produce any errors and I added PIO options to roms.in, mostly following the IO page on the wiki with the exception of switching PIO_METHOD to either 1, 3 or 4 (tried this multiple times...
by cjroach
Thu May 20, 2021 11:24 pm
Forum: ROMS Usage
Topic: Having trouble getting lagrangian float working...
Replies: 8
Views: 1272

Re: Having trouble getting lagrangian float working...

Thanks Mark,
That seems to have got float running.

-Chris
by cjroach
Wed May 19, 2021 2:11 am
Forum: ROMS Usage
Topic: Having trouble getting lagrangian float working...
Replies: 8
Views: 1272

Re: Having trouble getting lagrangian float working...

Hi again Mark,
Tried a few test just with the flt_test case changing DSTART and TIME_REF, neither of which seem to affect float start times.
by cjroach
Tue May 18, 2021 11:50 pm
Forum: ROMS Usage
Topic: Having trouble getting lagrangian float working...
Replies: 8
Views: 1272

Re: Having trouble getting lagrangian float working...

Hi m.hadfield,
Yes, I have tried with grid-coordinates instead of lat-lon.

DSTART? That could be the issue, I'll double-check what we've got and see if adding it to Ft0 fixes things.
by cjroach
Tue May 18, 2021 3:33 am
Forum: ROMS Usage
Topic: Having trouble getting lagrangian float working...
Replies: 8
Views: 1272

Re: Having trouble getting lagrangian float working...

Well, none of those options seem to have helped. Looking through a log file containing all the text output it does look like ROMS is both initializing and running the particle tracking (taking up about 5% of CPU time per below). Nonlinear model elapsed CPU time profile, Grid: 01 Allocation and array...
by cjroach
Wed May 12, 2021 12:09 am
Forum: ROMS Usage
Topic: Having trouble getting lagrangian float working...
Replies: 8
Views: 1272

Re: Having trouble getting lagrangian float working...

Thanks John, I'll try your suggestions. Per MOANA output, as far as I'm aware "full" versions of the latest variant of the backbone configuration aren't public yet. At the moment I think everything is stored on NESI, and thus only really accessible to people involved in the project. MetOce...
by cjroach
Tue May 11, 2021 1:12 am
Forum: ROMS Usage
Topic: Having trouble getting lagrangian float working...
Replies: 8
Views: 1272

Having trouble getting lagrangian float working...

Okay, firs time posting here. I'm a post-doc with MetOcean Solutions in NZ involved in the Kiwis' MOANA project which looks at biological connectivity of a number of key commercial marine species. I'm specifically working on how climate change is going to change ocean circulation which first involve...