Search found 82 matches

by c.drinkorn
Fri Nov 22, 2019 4:14 pm
Forum: ROMS Installation
Topic: Compiling error - undefined reference to ice routines
Replies: 10
Views: 518

Re: Compiling error - undefined reference to ice routines

Okay, looking at the f90 code made it much easier to see what is happening. It also makes it very obvious that the code is not written to work with only ICE_MODEL (and ICE_BULK_FLUXES) switched on, e.g. if it comes to the calculation of the altered heat fluxes due to ice in the bulk_flux routine). T...
by c.drinkorn
Thu Nov 21, 2019 1:50 pm
Forum: ROMS Installation
Topic: Compiling error - undefined reference to ice routines
Replies: 10
Views: 518

Re: Compiling error - undefined reference to ice routines

Okay, since I want the same nudging time scales everywhere I just hard coded the number into ana_nudgecoef. Maybe for a more complex nudging time scales field I'd rather provide a file with the coefficients field. I can see that only switching on ICE_MODEL already takes the ice concentration into ac...
by c.drinkorn
Tue Nov 19, 2019 4:14 pm
Forum: ROMS Installation
Topic: Compiling error - undefined reference to ice routines
Replies: 10
Views: 518

Re: Compiling error - undefined reference to ice routines

Hi Kate,

thank you! Things are much clearer to me know. I am trying to nudge to a sea ice concentration climatology. I hope I got it right and ROMS will use the M2 nudging time scales for sic?
by c.drinkorn
Sat Nov 16, 2019 8:17 pm
Forum: ROMS Installation
Topic: Compiling error - undefined reference to ice routines
Replies: 10
Views: 518

Re: Compiling error - undefined reference to ice routines

Thank you Kate and Hernan for your information on the sea ice model status! I have to clarify (since this was an old post of mine, it probably got lost up there...) that this was about the COAWST branch. But it would be good to hear respective information on this one, too. Is COAWST supposed to have...
by c.drinkorn
Fri Nov 15, 2019 5:08 pm
Forum: ROMS Installation
Topic: Compiling error - undefined reference to ice routines
Replies: 10
Views: 518

Re: Compiling error - undefined reference to ice routines

Hi all, it seems like I finally solved this one: In the makefile the link to the SeaIce folder in Nonlinear was (unintentionally?) missing. When I added this one the compiling error vanished. There was a warning that all old commands for the respective targets are being overridden by the new command...
by c.drinkorn
Thu Nov 14, 2019 10:31 am
Forum: ROMS Problems
Topic: Nudging time scales for RadNud boundaries
Replies: 4
Views: 384

Re: Nudging time scales for RadNud boundaries

I'm sorry, I meant nl_ocean not mod_ocean.
by c.drinkorn
Thu Nov 14, 2019 10:14 am
Forum: ROMS Problems
Topic: Nudging time scales for RadNud boundaries
Replies: 4
Views: 384

Re: Nudging time scales for RadNud boundaries

Hi John, thank you very much for the clarification! Yes, grep is my best friend. :) So I was somewhat familiar with the routines you pointed at. What's still unclear to me is from where t3dbc_im.F receives its Tobc_out which I suppose is already rescaled at that time. I guess, the thread goes back t...
by c.drinkorn
Tue Nov 12, 2019 3:29 pm
Forum: ROMS Problems
Topic: Nudging time scales for RadNud boundaries
Replies: 4
Views: 384

Re: Nudging time scales for RadNud boundaries

HI all, to get back at this and be fair to the ROMS code I want to share that I investigated the *nudg and *obc_out / _in values provided in the output and they are very much consistent with the expected internal rescaling from days to seconds and the obc factor, respectively. :oops: However, I stil...
by c.drinkorn
Wed Oct 30, 2019 5:39 pm
Forum: ROMS Problems
Topic: Nudging time scales for RadNud boundaries
Replies: 4
Views: 384

Nudging time scales for RadNud boundaries

DEar ROMS community, I am pondering over this for quite some time now. Maybe the answer is fairly easy but I couldn't quite figure it on my own: How does ROMS calculate the RadNud boundary nudging time scales? Does it check the time unit of the boundary file in order to determine whether the timesca...
by c.drinkorn
Wed Oct 30, 2019 5:10 pm
Forum: ROMS Source
Topic: Huon_eastward and Hvom_northward
Replies: 9
Views: 333

Re: Huon_eastward and Hvom_northward

Thank you, Kate and John! Yes, at some point I also want to calculate the transport across a transect and I already wrote a script for that. I will compare the procedure carried out in Oceanspy with mine! For now I am using the volume transport to depict a mean vertically integrated flow vector fiel...
by c.drinkorn
Wed Oct 23, 2019 8:21 am
Forum: ROMS Source
Topic: Huon_eastward and Hvom_northward
Replies: 9
Views: 333

Re: Huon_eastward and Hvom_northward

Hi John, these are really helpful explanations! Thank you! Just one more confusion: When I calculate the vertically integrated volume transport on the basis of the barotropic flow components, I can make use of the already interpolated and shifted eastward and northward components. However, then usin...
by c.drinkorn
Tue Oct 22, 2019 11:53 am
Forum: ROMS Source
Topic: Huon_eastward and Hvom_northward
Replies: 9
Views: 333

Re: Huon_eastward and Hvom_northward

Hi John, thank you for the very comprehensive explanation! To be honest, many of those average flow variables confused me. I was looking for a variable to create a vertically integrated flow field, preferably in m3/s or Sv, respectively. I post-processed Huon and Hvom using NCL but I don't trust the...
by c.drinkorn
Tue Oct 22, 2019 9:57 am
Forum: ROMS Source
Topic: Huon_eastward and Hvom_northward
Replies: 9
Views: 333

Re: Huon_eastward and Hvom_northward

Hi Kate, thank you for your helpful advice! I want Huon and Hvom at rho-point locations (that is in the 3D sense) and then rotate them towards East or North, respectively. I am still a bit confused as to why on_u is used for the calculation of Huon and not on_p. Wouldn't the distance of the psi poin...
by c.drinkorn
Mon Oct 21, 2019 9:27 am
Forum: ROMS Source
Topic: Huon_eastward and Hvom_northward
Replies: 9
Views: 333

Huon_eastward and Hvom_northward

Hi ROMS cummunity! I am currently trying to make ROMS output the volume transport components as eastward and northward, too, as is being done for the 2D and 3D velocity fields. I was wondering, since the volume transports are Average out variables, why the rotation of u and v is only being conducted...
by c.drinkorn
Mon Jul 15, 2019 9:26 am
Forum: ROMS Discussion
Topic: Which tool is the stablest tools to create ROMS grid?
Replies: 20
Views: 2715

Re: Which tool is the stablest tools to create ROMS grid?

Hi Charles, I attached the grid file and the topography (remapped to the grid file's grid). I included your fix into getDefaultBathymetry but unfortunately this didn't solve the problem so I still had to add the lines for axlim(1) and axlim(2). I appreciate if you try and find a solution for the pol...
by c.drinkorn
Thu Jul 11, 2019 3:59 pm
Forum: ROMS Discussion
Topic: Which tool is the stablest tools to create ROMS grid?
Replies: 20
Views: 2715

Re: Which tool is the stablest tools to create ROMS grid?

Okay, I managed to load my grid file into gridBuilder by adding these two lines to the getDefaultBathymetry function: if axlim(1)<-180;axlim(1)=-180;end if axlim(2)>180;axlim(2)=180;end By remapping my new topography to the old grid file grid and writing a simple script to load lon_rho, lat_rho and ...
by c.drinkorn
Thu Jul 11, 2019 9:35 am
Forum: ROMS Discussion
Topic: Which tool is the stablest tools to create ROMS grid?
Replies: 20
Views: 2715

Re: Which tool is the stablest tools to create ROMS grid?

Hi Charles,

I sent you an email with the files. In the meanwhile, I will try myself to find a solution, too.

Cheers,
Cate
by c.drinkorn
Tue Jul 09, 2019 2:53 pm
Forum: ROMS Bugs
Topic: Error regarding variable dP in prsgrd44.h or prsgrd42.h
Replies: 1
Views: 146

Error regarding variable dP in prsgrd44.h or prsgrd42.h

Probably due to case-insensitivity, there is a compiling problem with the variable dP in the pressure gradient routines for quartic pressure Jacobians. The variable conflicts with the parameter DP for double precision from the mod_kinds module. Renaming dP to say dPr solved the problem. I know that ...
by c.drinkorn
Tue Jul 09, 2019 10:18 am
Forum: ROMS Discussion
Topic: Which tool is the stablest tools to create ROMS grid?
Replies: 20
Views: 2715

Re: Which tool is the stablest tools to create ROMS grid?

Hi all, I am trying to "replace" the topography in an existing ROMS grid file. But when I load the grid file into GridBuilder I get the error: Error using griddedInterpolant Grid is improperly defined. Error in setROMSgrid (line 59) BathyInterpolant=griddedInterpolant(bathymetry.xbathy,bathymetry.yb...
by c.drinkorn
Wed Jun 19, 2019 1:07 pm
Forum: ROMS Sediment
Topic: SED_MORPH causes blow up after restart
Replies: 0
Views: 238

SED_MORPH causes blow up after restart

HI all, I have been looking into this issue for quite some time now and wrote about pre-steps of it in other threads. At this point I am not getting any further and desperately hope for help by the community. Here is a short outline: I am running a high-resolution (delta x ~ 20km) Arctic application...
by c.drinkorn
Fri Jun 07, 2019 11:50 am
Forum: ROMS Problems
Topic: ROMS restart time steps
Replies: 4
Views: 416

Re: ROMS restart time steps

I got another step further: Only undefining SED_MORPH makes the restart blow up disappear. But since I want a time-evolving bathymetry I will investigate this further and report. SED_MORPH is meant to work with restart, right?
by c.drinkorn
Thu Jun 06, 2019 2:31 pm
Forum: ROMS Problems
Topic: ROMS restart time steps
Replies: 4
Views: 416

Re: ROMS restart time steps

Ok, I got one step further but still didn't succeed. I figured the problem with the additional restart time step was nonsense. The additional time step was simply the one written after blow up. :roll: However, the blowing up still remains and without the sediment option restart works fine. I now try...
by c.drinkorn
Wed May 29, 2019 8:34 am
Forum: ROMS Problems
Topic: ROMS restart time steps
Replies: 4
Views: 416

Re: ROMS restart time steps

Hi Kate, all of my forcing and boundary files range from Jan-01 00:00:00 this to Jan-01 00:00:00 of the next year. So this should be fine. I realized that all sediment related variables do have values in the additional rst fields. Now that I switched Lcycle back to false I get 367 rst fields of whic...
by c.drinkorn
Wed May 29, 2019 8:14 am
Forum: ROMS Problems
Topic: Noisy SST
Replies: 8
Views: 445

Re: Noisy SST

As for MIX_S_TS, it's a really bad idea over a sloping bottom and can lead to unphysical cross-isopycnal mixing. I hear you! But there was no way to solve the issue of punctual alternating high/low temperatures at the slope when mixing along z-planes which would even cause the model to blow up. The...
by c.drinkorn
Tue May 28, 2019 1:39 pm
Forum: ROMS Problems
Topic: Noisy SST
Replies: 8
Views: 445

Re: Noisy SST

Then the only idea I have is to enable TS_MPDATA which will "force" the fields to be in 3d consistency...
by c.drinkorn
Tue May 28, 2019 1:33 pm
Forum: ROMS Sediment
Topic: Problem regarding restart when activate SED_MOR
Replies: 1
Views: 1005

Re: Problem regarding restart when activate SED_MOR

Hi, I found this old issue while I am having had the same. I realized it is connected to the usage of PERFECT RESTART. In wrt_rst.F, when choosing PERFECT_RESTART, t2dgrd is becoming an extra value, i.e. DimIDs(31). Later in def_var.F this causes an inconsistency while nvd3 has the value 3 and Vdim(...
by c.drinkorn
Tue May 28, 2019 12:19 pm
Forum: ROMS Problems
Topic: Noisy SST
Replies: 8
Views: 445

Re: Noisy SST

Hi Xavier,

I switched from MIX_GEO_TS to MIX_S_TS in order to solve a similar problem at the bottom. Maybe it also helps you. :)

//Cate
by c.drinkorn
Tue May 28, 2019 8:39 am
Forum: ROMS Problems
Topic: How to enhance vertical mixing in roms MY2.5
Replies: 3
Views: 318

Re: How to enhance vertical mixing in roms MY2.5

Hi Azam, just an idea: Did you try switching between Laplacian and biharmonic horizontal diffusion? I.e., define either TS_DIF2 or TS_DIF4. I don't know whether the issue is too less horizontal or vertical mixing but I guess if your subsurface temperature AND salinity is too low you need more vertic...
by c.drinkorn
Mon May 27, 2019 11:17 pm
Forum: ROMS Problems
Topic: ROMS restart time steps
Replies: 4
Views: 416

ROMS restart time steps

Hi all, I have a simple question: Why does ROMS store the last time step of the restart file one hour after the model time domain instead of the very last time step so I can use it as a restart initial? My model time step is 600s and I am simulating 52560 time steps (one year). NRST is set to 144 in...
by c.drinkorn
Thu May 09, 2019 8:42 am
Forum: ROMS Sediment
Topic: couldn't create executable oceanM
Replies: 2
Views: 251

Re: couldn't create executable oceanM

Hi Van!

I think, you need to specify the path to your MPI library. I marked the line with a long arrow:

Code: Select all

gfortran )
if [ "${which_MPI}" = "mpich2" ]; then
export PATH=/usr/bin:$PATH
elif [ "${which_MPI}" = "openmpi" ]; then
------> export PATH=/opt/openmpi:$PATH
fi
by c.drinkorn
Thu Apr 11, 2019 3:04 pm
Forum: ROMS Installation
Topic: Compiling error - undefined reference to ice routines
Replies: 10
Views: 518

Compiling error - undefined reference to ice routines

Hi all, I recently switched to the COAWST because I want to run both ice and sediments in an Arctic domain but couldn't solve some inconsistencies in the Kate branch code... Howver, now I am unable to solve this compiling error which seems top be about some ice routines: /scratch/b/b380636/Arctic20k...
by c.drinkorn
Wed Apr 10, 2019 3:16 pm
Forum: ROMS Ice
Topic: Issue connected to Tnudg_SSS
Replies: 3
Views: 727

Re: Issue connected to Tnudg_SSS

Unfortunately, I am reproducing the error with one of your ocean.in files. I took my time to look into the referred code lines but there is nothing suspicious or inconsistent. I guess, I'll switch to the COAWST code, then, unless anyone has an idea what produces this problem.
by c.drinkorn
Wed Apr 10, 2019 9:03 am
Forum: ROMS Ice
Topic: Issue connected to Tnudg_SSS
Replies: 3
Views: 727

Re: Issue connected to Tnudg_SSS

If you are using my code, you really, really need to start from one of my ocean.in files. In particular, you need not only NFFILES for the number of forcing files, but also NBCFILES and NCLMFILES for the number of boundary and climatology files as well. Maybe even NSSFFILES for the rivers if the co...
by c.drinkorn
Tue Apr 09, 2019 3:27 pm
Forum: ROMS Ice
Topic: Issue connected to Tnudg_SSS
Replies: 3
Views: 727

Issue connected to Tnudg_SSS

I am trying to set up Kate's branch for an Arctic application including ice and sediments. When I first used the code as I received it from github, there was a compilation error about the dimension of Rval in inp_par.F Obviously, there is a major difference between the SVN version and Kate's branch ...
by c.drinkorn
Thu Mar 28, 2019 9:41 am
Forum: ROMS Problems
Topic: Blowing up problem when using sediment
Replies: 3
Views: 654

Re: Blowing up problem when using sediment

Maybe look at the rho, temp and sal values right before blow up.
by c.drinkorn
Wed Feb 13, 2019 7:39 pm
Forum: ROMS Sediment
Topic: Negative suspended load concentrations near river runoff
Replies: 17
Views: 1218

Re: Negative suspended load concentrations near river runoff

Yessss, that was it! I didn't look in the Qout section. :D Thank you!
by c.drinkorn
Wed Feb 13, 2019 10:45 am
Forum: ROMS Sediment
Topic: Negative suspended load concentrations near river runoff
Replies: 17
Views: 1218

Re: Negative suspended load concentrations near river runoff

In my restart files I get mudmass written out so in principle this works. Just not in the history file... :idea:
by c.drinkorn
Tue Feb 12, 2019 7:57 pm
Forum: ROMS Sediment
Topic: Negative suspended load concentrations near river runoff
Replies: 17
Views: 1218

Re: Negative suspended load concentrations near river runoff

It does define mud as sediment class but not mention bed mass as Hout output: Sediment Parameters, Grid: 01 ============================= Size Sd50 Csed Srho Wsed Erate poros Class (mm) (kg/m3) (kg/m3) (mm/s) (kg/m2/s) (nondim) 1 0.0000E+00 0.0000E+00 1.8000E+03 1.0000E-01 5.0000E-04 9.0000E-01 tau_...
by c.drinkorn
Tue Feb 12, 2019 7:34 pm
Forum: ROMS Sediment
Topic: Negative suspended load concentrations near river runoff
Replies: 17
Views: 1218

Re: Negative suspended load concentrations near river runoff

MUd, so NCS equals 1. I thought I found the reason but still no writing of bed mass: In the Write-out section of sediment_inp.h it says ... DO itrc=1,NST i=idfrac(itrc) IF (Hout(i,ng)) WRITE (out,160) Hout(i,ng), & & 'Hout(idfrac)', & & 'Write out bed fraction, sediment ', itrc, & & TRIM(Vname(1,i))...
by c.drinkorn
Tue Feb 12, 2019 6:53 pm
Forum: ROMS Sediment
Topic: Negative suspended load concentrations near river runoff
Replies: 17
Views: 1218

Re: Negative suspended load concentrations near river runoff

Mysterious. I think, I have everything set as it should: ... Hout(idmud) == T ! mud_01, ... suspended concentration Hout(iMfrac) == T ! mudfrac_01, ... bed layer fraction Hout(iMmass) == T ! mudmass_01, ... bed layer mass Hout(iMUbld) == F ! bedload_Umud_01, ... bed load at U-points Hout(iMVbld) == ...
by c.drinkorn
Tue Feb 12, 2019 4:24 pm
Forum: ROMS Sediment
Topic: Negative suspended load concentrations near river runoff
Replies: 17
Views: 1218

Re: Negative suspended load concentrations near river runoff

Something else: Is there anything I need to switch on in order to write out bed mass? Setting the true flag in sediment.in didn't do the trick. :(
by c.drinkorn
Tue Feb 12, 2019 1:53 pm
Forum: ROMS Sediment
Topic: Negative suspended load concentrations near river runoff
Replies: 17
Views: 1218

Re: Negative suspended load concentrations near river runoff

Oh and by the way, I also needed to undefine the vertical tracer advection scheme, of course. Just in case someone is reading this later...
by c.drinkorn
Tue Feb 12, 2019 12:56 pm
Forum: ROMS Sediment
Topic: Negative suspended load concentrations near river runoff
Replies: 17
Views: 1218

Re: Negative suspended load concentrations near river runoff

MPDATA did really solve the problem which does of course make sense because it just restricts the local simulation results. Even though I am always a bit concerned with too much correction terms in the calculation, I think switching to MPDATA was a really good idea. Thank you for this great advice! ...
by c.drinkorn
Mon Feb 11, 2019 4:20 pm
Forum: ROMS Sediment
Topic: Negative suspended load concentrations near river runoff
Replies: 17
Views: 1218

Re: Negative suspended load concentrations near river runoff

Thanks for your promt answer! Speaking of sharp horizontal gradients: I do indeed discover erroneous negative rho values (in fact of the same order as the susp. load concentration) next to the river discharge, so maybe this isn't exactly a sediment issue. T and S look fine, though. The errors occur ...
by c.drinkorn
Mon Feb 11, 2019 2:47 pm
Forum: ROMS Sediment
Topic: Negative suspended load concentrations near river runoff
Replies: 17
Views: 1218

Negative suspended load concentrations near river runoff

Hi, I get very low negative suspended load concentration values (down to several hundreds of kg/m^3) near river runoff. I have no sediment input via rivers. But the initial concentration in the water column is zero so I wonder what exactly a negative concentration should mean. Is there a way to prev...
by c.drinkorn
Fri Feb 08, 2019 10:01 am
Forum: ROMS Problems
Topic: forrtl: severe (151): allocatable array is already allocated
Replies: 17
Views: 3436

Re: forrtl: severe (151): allocatable array is already alloc

Thank you for your explanation, Kate. The error actually vanished with the recent updates so this might have just been a bug... I still don't use parallel I/O because I keep receiving an error about the scratch arrays in the global periodic patch. However, I don't mind. So far using a serial I/O is ...
by c.drinkorn
Thu Jan 31, 2019 12:13 pm
Forum: ROMS Problems
Topic: forrtl: severe (151): allocatable array is already allocated
Replies: 17
Views: 3436

Re: forrtl: severe (151): allocatable array is already alloc

The user has an Arctic domain. I added a GLOBAL_PERIODIC flag to ROMS to handle just this case, interpolating across the dateline. I've attached the patch file. Hi Kate, I'm sorry I have to get back at this again but I just wanted to switch to Parallel IO and got an error while compiling about too ...
by c.drinkorn
Tue Dec 04, 2018 3:02 pm
Forum: ROMS Sediment
Topic: Initial sediment layers
Replies: 3
Views: 549

Re: Initial sediment layers

It seems to be possible by using a bottom boundary layer model... :idea: I will try something like that.
I'd be happy about any further hints. :)
by c.drinkorn
Tue Dec 04, 2018 2:53 pm
Forum: ROMS Sediment
Topic: Initial sediment layers
Replies: 3
Views: 549

Re: Initial sediment layers

The sediment part in roms can be run with just roms. The swan coupling provides wave information that can be used by the ocean model to: - compute enhanced surface mixing due to tke wave breaking - computed wave driven flow using vortex force approach - compute enhanced bottom stresses due to combi...
by c.drinkorn
Tue Dec 04, 2018 9:55 am
Forum: ROMS Sediment
Topic: Initial sediment layers
Replies: 3
Views: 549

Initial sediment layers

Hi all,

I wonder if and how it would be possible to start a sedimentation simulation with initial sediment layers coming with e.g. thickness and densities, by running just the sediment module in ROMS. Or will I have to run a coupled SWAN simulation in order to do that?
by c.drinkorn
Fri Nov 23, 2018 11:16 am
Forum: ROMS Discussion
Topic: Problem with the time of the ECMWF files
Replies: 2
Views: 598

Re: Problem with the time of the ECMWF files

Hi Scarlett, I had sort of the same problem (my Pair time record had switched 12h and 18h steps - it was what the conversion from grib to netcdf resulted in while my grib file had both analytical and forecast). Since I didn't retrieve the data myself I wrote a workaround to fix the field myself (not...
by c.drinkorn
Wed Nov 14, 2018 4:08 pm
Forum: ROMS Bugs
Topic: tiny little bug in get_state.F for time evolving bathymetry
Replies: 2
Views: 568

tiny little bug in get_state.F for time evolving bathymetry

Hi all,

this isn't a big deal but when running a simulation using time evolving bathymetry, I received an error about a variable "ibath" from get_state. I am convinced it should be "idbath" in that line. Fixing this solved the error for me and from the code's logic this also makes sense. :wink:
by c.drinkorn
Tue Nov 13, 2018 2:55 pm
Forum: ROMS Sediment
Topic: tracer surface flux
Replies: 2
Views: 598

Re: tracer surface flux

try using this in the project.h file # define ANA_SMFLUX # define ANA_BPFLUX # define ANA_BSFLUX # define ANA_BTFLUX # define ANA_SPFLUX # define ANA_SRFLUX # define ANA_SSFLUX # define ANA_STFLUX Thanks! Switching on ANA_SPFLUX was the solution. I have an open vertical boundary so I didn't even co...
by c.drinkorn
Tue Nov 13, 2018 1:12 pm
Forum: ROMS Sediment
Topic: tracer surface flux
Replies: 2
Views: 598

tracer surface flux

I am trying to set up a very simple first test case for the implementation of the sediment tool into my ROMS model. I want a 1m layer of sand with the typical sand properties (high porosity, no cohesion etc.) evenly distributed throughout the domain with closed borders and and no suspension in the w...
by c.drinkorn
Thu Sep 13, 2018 8:19 pm
Forum: ROMS Problems
Topic: forrtl: severe (151): allocatable array is already allocated
Replies: 17
Views: 3436

Re: forrtl: severe (151): allocatable array is already alloc

I realized lately that global_periodic gives a seam at lon 180/-180 if the coordinates are not in the order of -180 to 180 instead of 0 to -0 (which would be the outcome of the d_ecmwf2roms.m). Therefore, I added two lines to the script: In the section where lat and lon are read, right after the mod...
by c.drinkorn
Tue Sep 04, 2018 8:53 am
Forum: ROMS Discussion
Topic: Cannot find "coordinates" attribute for variable: Uwind
Replies: 15
Views: 1781

Re: Cannot find "coordinates" attribute for variable: Uwind

Yes, my inputs files (the files that I downloaded from ECMWF) are monthly, and it was easier for me to modify the script to read them and create them monthly. I think that the better solution is make an annual file and run the code for the entire year once, like you suggest. If you could give me th...
by c.drinkorn
Fri Aug 31, 2018 9:31 am
Forum: ROMS Discussion
Topic: Cannot find "coordinates" attribute for variable: Uwind
Replies: 15
Views: 1781

Re: Cannot find "coordinates" attribute for variable: Uwind

HI Scarlett, I worked with the ecmwf2roms script a lot recently. How do you loop through the monthly input files? Maybe you accidentally call the same file all the time (i.e. January)? Just a thought... ADD: I looked into the ecmwf2roms file you shared in the other post and can see that you run the ...
by c.drinkorn
Tue Aug 28, 2018 4:43 pm
Forum: ROMS Problems
Topic: forrtl: severe (151): allocatable array is already allocated
Replies: 17
Views: 3436

Re: forrtl: severe (151): allocatable array is already alloc

If it is your first application in ROMS, I suggest that you gain experience with a smaller regional grid, so you can transfer all that knowledge when building and setting up your global application. Dear Hernan, your are right, I am a bloody beginner. :oops: But thanks to the comprehensive document...
by c.drinkorn
Tue Aug 28, 2018 4:37 pm
Forum: ROMS Problems
Topic: forrtl: severe (151): allocatable array is already allocated
Replies: 17
Views: 3436

Re: forrtl: severe (151): allocatable array is already alloc

Dear Kate, million thanks for the patch! I needed to adjust my Matlab processing a bit so that my lon/lat variables are 1d. In the Matlab package one needs to change the metadata (in roms_metadata.m) to just one variable dimension entry and in the main program comment out the repmat procedure. Other...
by c.drinkorn
Sun Aug 26, 2018 10:09 am
Forum: ROMS Problems
Topic: forrtl: severe (151): allocatable array is already allocated
Replies: 17
Views: 3436

Re: forrtl: severe (151): allocatable array is already alloc

Hey all, after your hints about double-entries in the .in file I finally looked really really close once again and, alas, I found an entire block of entries at the very end of my file (after the Glossary and coupling section). My guess how it ended up there: an accidental mousewheel click while scro...
by c.drinkorn
Wed Aug 22, 2018 3:38 pm
Forum: ROMS Problems
Topic: forrtl: severe (151): allocatable array is already allocated
Replies: 17
Views: 3436

Re: forrtl: severe (151): allocatable array is already alloc

Oh yes, tabs! I encountered them already in the .in file. :D I use Vi on a UNIX. And .e.g tabs before the forcing file links are a bad idea! :twisted: However, so far I couldn't find them to be the reason of double-allocation. At the moment I am still busy setting up the forcing fields to the desire...
by c.drinkorn
Wed Aug 22, 2018 9:33 am
Forum: ROMS Problems
Topic: forrtl: severe (151): allocatable array is already allocated
Replies: 17
Views: 3436

Re: forrtl: severe (151): allocatable array is already alloc

Considering the recent repository update underlines even more that the IF-condition wrap is a workaround but shouldn't be necessary. In fact, I did not encounter the problem when using another ocean.in. I tried hard to figure which setting causes the obsolete allocation but was not successful. Which...
by c.drinkorn
Sat Aug 18, 2018 7:41 am
Forum: ROMS Problems
Topic: forrtl: severe (151): allocatable array is already allocated
Replies: 17
Views: 3436

Re: forrtl: severe (151): allocatable array is already alloc

Thanks for your reply, Kate. No, there is no double entry for NtileJ. What I did now is to wrap the allocation of IO_BOUNDS inside an IF-condition, too. I guess, this is a nasty workaround and there sure is an issue in my model setup somewhere but it solved the problem for now. Let's see how the sim...
by c.drinkorn
Fri Aug 17, 2018 3:03 pm
Forum: ROMS Problems
Topic: forrtl: severe (151): allocatable array is already allocated
Replies: 17
Views: 3436

Re: forrtl: severe (151): allocatable array is already alloc

After setting up my model once again, I re-encounter this problem. :roll:
No suggestions on how to solve this?
by c.drinkorn
Wed Jun 20, 2018 3:51 pm
Forum: ROMS Problems
Topic: forrtl: severe (151): allocatable array is already allocated
Replies: 17
Views: 3436

forrtl: severe (151): allocatable array is already allocated

Hello everyone, while trying to run ROMS in parallel mode with analytical initial conditions I receive the following error output from debugging mode (excerpt from the whole error file): forrtl: severe (151): allocatable array is already allocated Image PC Routine Line Source oceanG 000000000220D767...
by c.drinkorn
Thu Jun 07, 2018 3:54 pm
Forum: ROMS Installation
Topic: compile roms
Replies: 1
Views: 722

Re: compile roms

rm -f -r core *.ipo /home/yaduvendra/projects/upwelling/Build /home/yaduvendra/make_macros.mk ./build.bash: line 409: syntax error: unexpected end of file plz help This is some time ago but I just had the same error and fixed it. Reason and solution were rather trivial: There was a non-closed if cl...
by c.drinkorn
Tue May 29, 2018 12:35 pm
Forum: ROMS Usage
Topic: How Small/Large region can ROMS compute?
Replies: 4
Views: 2328

Re: How Small/Large region can ROMS compute?

kate wrote:Paul Budgell is doing a global ROMS. On the small end, I think it has been run to simulate a laboratory rotating tank to the same scale. Four meters across? Something like that.
I know, this is old but is the global set up still available somewhere (GitHub etc.)? Thanks!
by c.drinkorn
Thu May 03, 2018 7:24 am
Forum: ROMS Installation
Topic: roms installation
Replies: 1
Views: 691

Re: roms installation

Hi Shauryasingh!

Do you use NetCDf4? (Usually, it is Kate's part to ask that question...)
If not, you need to set the flags to the different libraries manually (e.g. in the compiler file).
If yes, there might be something wrong with the path to your netcdf library.
by c.drinkorn
Thu Apr 26, 2018 9:21 pm
Forum: ROMS Problems
Topic: unable to open existing NetCDF file GET GRID
Replies: 10
Views: 1196

Re: unable to open existing NetCDF file GET GRID

It works! :D After re-compiling and re-running and re-compiling and re-running using Netcdf4 or not using it... I finally figured what the problem was: The path to the grid nc (and apparently all the other input nc files) was wrong. It had to be the absolute path, no home directory shortcuts (or at ...
by c.drinkorn
Thu Apr 26, 2018 6:02 pm
Forum: ROMS Problems
Topic: unable to open existing NetCDF file GET GRID
Replies: 10
Views: 1196

Re: unable to open existing NetCDF file GET GRID

Ok, I found the section in mod_netcdf.F and it looks like this now: IF (FoundError(status, nf90_noerr, __LINE__, & & __FILE__ // & & ", netcdf_open")) THEN WRITE (stdout,10) TRIM(ncname), TRIM(SourceFile) PRINT *, trim(nf90_strerror(status)) exit_flag=3 ioerror=status END IF There was no "IF (Master...
by c.drinkorn
Thu Apr 26, 2018 5:32 pm
Forum: ROMS Problems
Topic: unable to open existing NetCDF file GET GRID
Replies: 10
Views: 1196

Re: unable to open existing NetCDF file GET GRID

Thank you, Kate! But where will I have to include it?
by c.drinkorn
Thu Apr 26, 2018 5:06 pm
Forum: ROMS Problems
Topic: unable to open existing NetCDF file GET GRID
Replies: 10
Views: 1196

Re: unable to open existing NetCDF file GET GRID

Yes, it is there and I can open it with ncview. All variables are in it and it seems alright.
by c.drinkorn
Thu Apr 26, 2018 4:57 pm
Forum: ROMS Problems
Topic: unable to open existing NetCDF file GET GRID
Replies: 10
Views: 1196

unable to open existing NetCDF file GET GRID

Hi everyone! I am sure this is trivial but I am lacking experience: When trying to run the DAMEE_4 test case I receive the following error in the output file INITIAL: Configuring and initializing forward nonlinear model ... ******* Found Error: 02 Line: 6565 Source: ROMS/Modules/mod_netcdf.F, netcdf...
by c.drinkorn
Thu Apr 26, 2018 7:34 am
Forum: ROMS Installation
Topic: Compiling using MPI anf ifort -> mpiifort
Replies: 7
Views: 1213

Re: Compiling using MPI anf ifort -> mpiifort

Yes, I know. But I did comment out USE_DEBUG=on...
However, I found that in the makefile it was not. When I did it I got an oceanM. Happy end. :D
Thank you for your help, Kate!
by c.drinkorn
Wed Apr 25, 2018 9:18 pm
Forum: ROMS Installation
Topic: Compiling using MPI anf ifort -> mpiifort
Replies: 7
Views: 1213

Re: Compiling using MPI anf ifort -> mpiifort

They are only warnings. Did it build an executable? Can you try running it? Also, you want to make sure netcdf-fortran was compiled with the same compiler you are using to compile ROMS. Always. I missed this one... Ok, well it built an oceanG. But I was expecting an oceanM. :| Regarding the netcdf ...
by c.drinkorn
Wed Apr 25, 2018 9:17 pm
Forum: ROMS Installation
Topic: Compiling using MPI anf ifort -> mpiifort
Replies: 7
Views: 1213

Re: Compiling using MPI anf ifort -> mpiifort

I just solved it myself. I saw that you have a much newer openmpi so I looked again and found openmpi-1.10.7_hpcx-intel14. I thought it would be a wrong one since it comes with the hpcx suffix but the compiling worked without error. So thank you again! :D HOWEVER, I only have an oceanG and no oceanM...
by c.drinkorn
Wed Apr 25, 2018 8:55 pm
Forum: ROMS Installation
Topic: Compiling using MPI anf ifort -> mpiifort
Replies: 7
Views: 1213

Re: Compiling using MPI anf ifort -> mpiifort

Hi Kate! Your hint was very valuable, I managed to find the module which provides the openmpi mpif90 environment for intel! Thank you! :D (For users having the same issue: typing something like "module whatis" gives additonal descriptions of the modules and makes it easier to identify the right one....
by c.drinkorn
Wed Apr 25, 2018 3:47 pm
Forum: ROMS Installation
Topic: Compiling using MPI anf ifort -> mpiifort
Replies: 7
Views: 1213

Compiling using MPI anf ifort -> mpiifort

Hi everyone, after having tried to find the source of error myself during the whole day, I resign and ask for help here: I want to compile a test case for parallel processing and use openmpi and ifort. I already switched on USE_MPI, of course, and also pointed to mpiifort instead of mpif90 in the Co...
by c.drinkorn
Wed Apr 11, 2018 5:56 am
Forum: ROMS Installation
Topic: netcdf and hdf5 in different folders
Replies: 3
Views: 802

Re: netcdf and hdf5 in different folders

Hi, if you do not want to use NetCDF4, it may be necessary to change the library path settings in the compiler file. In the respective file (according to your system and fortran compiler) in the 'Library locations' section you may paste the output of "path/to/your/nf-config -flibs" into the "ifdef U...
by c.drinkorn
Mon Mar 19, 2018 8:50 am
Forum: ROMS Discussion
Topic: ROMS for North Atlantic, Nordic Seas and Arctic
Replies: 2
Views: 847

Re: ROMS for North Atlantic, Nordic Seas and Arctic

Thank you very much for your reply, Kate! And sorry for the late answer; I just found the time to take a closer look at your suggested domain very recently. I also found a GitHub (yours?) with ARC-NATL header files so I'll take a look into them in order to examine the resolution and extent. From wha...
by c.drinkorn
Mon Mar 12, 2018 4:26 pm
Forum: ROMS Discussion
Topic: ROMS for North Atlantic, Nordic Seas and Arctic
Replies: 2
Views: 847

ROMS for North Atlantic, Nordic Seas and Arctic

Hi everyone!

I am new to ROMS and this forum.
While I am digging into how to set up a high-resolution model for the above mentioned domain, I thought it was worthwhile to ask around who might have done a similar set up already. I would be very grateful for exchange or hints! :idea:

Cate