Search found 11 matches

by cousins
Wed Apr 23, 2014 4:51 pm
Forum: ROMS Discussion
Topic: forrtl: severe (174): SIGSEGV, segmentation fault occurred
Replies: 11
Views: 5706

Re: forrtl: severe (174): SIGSEGV, segmentation fault occurr

That is the version we had problems with before (see earlier in the thread). The answer still is to upgrade your compiler.

Good luck,

Steve
by cousins
Wed Apr 23, 2014 4:14 pm
Forum: ROMS Discussion
Topic: forrtl: severe (174): SIGSEGV, segmentation fault occurred
Replies: 11
Views: 5706

Re: forrtl: severe (174): SIGSEGV, segmentation fault occurr

What compiler and version are you using? Upgrading to a newer version of the compiler allowed it to work for us previously. It would be good to know what compiler version you are using to know which versions to avoid.
by cousins
Tue Apr 03, 2012 9:44 pm
Forum: ROMS Discussion
Topic: forrtl: severe (174): SIGSEGV, segmentation fault occurred
Replies: 11
Views: 5706

Re: forrtl: severe (174): SIGSEGV, segmentation fault occurr

Just to close this up, Intel Composer XE 2011 SP1 9.293 is working as expected.
by cousins
Tue Apr 03, 2012 2:15 am
Forum: ROMS Discussion
Topic: forrtl: severe (174): SIGSEGV, segmentation fault occurred
Replies: 11
Views: 5706

Re: forrtl: severe (174): SIGSEGV, segmentation fault occurr

Bizarre. We've had no problem with earlier versions of ROMS (at least a year old) and this compiler,

Thanks for the confirmation.

Steve
by cousins
Mon Apr 02, 2012 10:09 pm
Forum: ROMS Discussion
Topic: forrtl: severe (174): SIGSEGV, segmentation fault occurred
Replies: 11
Views: 5706

Re: forrtl: severe (174): SIGSEGV, segmentation fault occurr

Did you ever figure out what this was? I'm getting the same thing now from a recent (608) download using SVN. Using USE_DEBUG allows it to work. Running it without USE_DEBUG but adding -g -traceback (Intel compiler 11.1) in FFLAGS yielded: NL ROMS/TOMS: started time-stepping: (Grid: 01 TimeSteps: 00...
by cousins
Fri Aug 18, 2006 4:04 pm
Forum: ROMS Discussion
Topic: How can we make the ROMS forum more active?
Replies: 2
Views: 1873

One thing that would help would be to have all items posted on the forum be sent to a mailing list (that of course would be optional to sign up for). Yeah, I second that. Shouldn't be too hard to set up. And I third it. The less it gets used, the less it gets used. I posted a problem in the Bugs di...
by cousins
Tue Aug 15, 2006 4:17 pm
Forum: ROMS Bugs
Topic: ROMS 2.2 problem when USWEST is defined
Replies: 1
Views: 1891

ROMS 2.2 problem when USWEST is defined

After downloading the ROMS code with the corrections I made two changes: 1. cppdefs.h: undefined UPWELLING and defined USWEST 2. makefile: changed compiler to ifort ran make: ... yada, yada, yada... /usr/bin/cpp -P -traditional -I/opt/intelsoft/netcdf/include -DLINUX -DX86_64 -DIFORT -IInclude -INon...
by cousins
Tue Apr 25, 2006 8:10 pm
Forum: ROMS Installation
Topic: OSX with xlf tweaks
Replies: 0
Views: 1436

OSX with xlf tweaks

I've just gone through the process of setting up ROMS 2.2 on a Mac OSX cluster running the IBM xlf compiler and I have a couple of tweaks to hopefully make it easier for others in the future. 1. the xlf compiler uses flush_ instead of flush. Utility/mp_routines.F checks #ifdef AIX for this but it wo...
by cousins
Thu Jun 16, 2005 4:59 pm
Forum: ROMS Problems
Topic: running ROMS on an OSX cluster
Replies: 5
Views: 4244

Re: running ROMS on an OSX cluster

We have been successful in running One other problem you will find is segmentation faults for large models using LMD modules. The LMD modules allocate local 3-D arrays on the stack. The stack size support in Mac OS X is limited to 64MB using the shell's limit command. To workaround this limitation,...
by cousins
Mon May 02, 2005 10:14 pm
Forum: ROMS Discussion
Topic: Interconnect speed for MPI: Gigabit, Myrinet and Infiniband
Replies: 5
Views: 4333

Re: Gigabit vs. Infiniband on the BENCHMARK1 test

However, I thought it would be of interest to point out that the BENCHMARK1 ROMS test case has been run on dual-Opteron 250 clusters with both INFINIBAND and GIGABIT. For an 8 processor run, the system with INFINIBAND was 2.73 times faster than the system with GIGABIT . Was the Gigabit run setup wi...
by cousins
Wed Apr 20, 2005 4:32 pm
Forum: ROMS Discussion
Topic: ROMS with Mac cluster?
Replies: 0
Views: 1364

ROMS with Mac cluster?

Has anyone had success with ROMS on a Mac G5 cluster running either OSX or Linux? We (will) have access to a cluster that is set up to run either operating system and use the IBM Fortran compilers. We don't actually have access to the cluster yet so we can't give it a try. Just curious if anyone has...