Search found 30 matches

by Eugen
Sat Dec 01, 2018 6:42 pm
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

Re: ROMS + SWAN with nesting : error on the child grid

John, Unfortunately, I didn't succeed to eliminate this error while playing with the ROMS time step, nor with the SWAN time step or with the coupling time step. Could it be due to a mask mismatch? I made some significant changes in the mask inside of the domain (not in the contact point layer). But ...
by Eugen
Fri Nov 30, 2018 5:08 pm
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

Re: ROMS + SWAN with nesting : error on the child grid

John,

The SWAN itself works fine now. But, coupled with ROMS, the nested grid gives a weird numerical error along the upper boundary.

It is not deadly anymore, but it is definitely a patch to be eliminated.

Could you guess please, why does it appear?
by Eugen
Fri Nov 30, 2018 10:14 am
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

Re: ROMS + SWAN with nesting : error on the child grid

Thanks a lot, John !

I'll try your suggestions and soon tell the results of the coupled run.
by Eugen
Thu Nov 29, 2018 6:36 pm
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

Re: ROMS + SWAN with nesting : error on the child grid

John, I've decided to make an experiment. I've turned both grids of the Sandy test-case on 180 degrees. Then, I've created .grd and .bot files and have run SWAN (without coupling with ROMS). And then I've compared it with the run on the normal (non-reversed) grid. I've switched off the winds on the ...
by Eugen
Thu Nov 29, 2018 2:24 pm
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

Re: ROMS + SWAN with nesting : error on the child grid

Thanks, John,

I've sent you a message.

Did I mention that my ROMS grids have an angle of 120 degrees?
Can it be a reason, why the configuration works such bad?

SWAN does not read the southern nested boundary at all, and the western boundary it reads with a numerical error...
by Eugen
Wed Nov 28, 2018 10:20 am
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

Re: ROMS + SWAN with nesting : error on the child grid

I compared indexes of child grid edge points compared to the corresponding parent grid cells in the scrip interpolation weight logs. For Sandy hurricane it is: ROMS starting i & j index of parent w.r.t child grid 23 27 ending i & j index of parent w.r.t child grid-- 60 54 And ncdump says, that the c...
by Eugen
Tue Nov 27, 2018 10:05 pm
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

Re: ROMS + SWAN with nesting : error on the child grid

Dear John, 1) SWAN only (results after 5 days): https://psv4.userapi.com/c848428/u51965391/docs/d10/2cb18d9148ad/Only_SWAN.png?extra=FNDXxVQY47FTy_rVekXjUy7jvAMXbssQ9Cm9V00vhn2TQrl-S1sWARXrsNLEWH4Eyfcfu4tv2BdopV1uhMc3Bw_GQsNY9hDOHklOb74PC19WH_6FzadoxkSDpcRvxK4rd-TQly05XObiW4vd5VOqbw 3) If I run the ...
by Eugen
Tue Nov 27, 2018 2:25 pm
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

Re: ROMS + SWAN with nesting : error on the child grid

Hi John, 1) I run SWAN grids without ROMS. No numerical errors and "zero" boundaries are found; 2) Currents are continuous, yes; 3) I've run the coupled system for one day and then have rerun with HOTFILEs. The error is still on both ROMS grids, while both SWAN grids look OK. I suspect an interpolat...
by Eugen
Fri Nov 23, 2018 12:01 am
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

Re: ROMS + SWAN with nesting : error on the child grid

Thanks, John !

I'll try your suggestions and tell the result
by Eugen
Thu Nov 22, 2018 11:04 pm
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

Re: ROMS + SWAN with nesting : error on the child grid

Thanks John,

Here they are:
by Eugen
Thu Nov 22, 2018 10:48 pm
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

Re: ROMS + SWAN with nesting : error on the child grid

Hi, John. This is a snapshot after 11 hours. But the model can go 30 days without explosion, just the results on the child grid have a little connection to the parent. About winds: I use the same regular ECMWF grid with winds for both of my grids. I tried to run with having winds on both grids, and ...
by Eugen
Thu Nov 22, 2018 8:33 pm
Forum: ROMS Results
Topic: ROMS + SWAN with nesting : error on the child grid
Replies: 21
Views: 2165

ROMS + SWAN with nesting : error on the child grid

Dear ROMS users, I run ROMS + SWAN in coupling using MCT library on two grids, one inside of another, in two way nesting. I'm sure about the wave results on the coarse grid. However, the fine resolution grid does not behave on the way I expect it. Here is a picture of the significant wave height on ...
by Eugen
Thu Nov 15, 2018 2:09 pm
Forum: ROMS Information
Topic: TPAR wave directions: correct or not on the ROMS grid angle
Replies: 2
Views: 602

TPAR wave directions: correct or not on the ROMS grid angle

Dear ROMS users, I have a short question. I couple online ROMS and SWAN on the same grid. Should I correct wave directions in my TPAR boundary files on the ROMS grid angle? To make TPAR files, I used a standard MATLAB scrip, which seemed to interpolate wave directions from the global wave product on...
by Eugen
Thu Nov 08, 2018 1:50 pm
Forum: ROMS Problems
Topic: Problem with SWAN
Replies: 6
Views: 2851

Re: Problem with SWAN

Sorry for the necroposting.
I had exactly the same problem.

The reason was the name of my test case. I named it 'NS' (i.e. North Sea), and it overlapped with a variable inside of the SWAN code with the same name.

I renamed my test case and solved the problem.
by Eugen
Thu Mar 08, 2018 1:07 pm
Forum: ROMS Problems
Topic: Contact point problem with salinity in Two Way Nesting run
Replies: 6
Views: 1740

Re: Contact point problem with salinity in Two Way Nesting r

Thanks, arango ! I tested all proposed solutions, and found out, that the source of the problem was the time step , which was five times smaller for the child grid, than for the parent, due to a grid cell size ratio of 1:5. With the advection schemes TS_C4VADVECTION and TS_U3HADVECTION I always enco...
by Eugen
Wed Feb 28, 2018 1:20 pm
Forum: ROMS Problems
Topic: Contact point problem with salinity in Two Way Nesting run
Replies: 6
Views: 1740

Re: Contact point problem with salinity in Two Way Nesting r

Dear Farshid , Thank you for these suggestions ! 1) I undefined UV_SADVECTION, but the result is almost the same. 2) Surprisingly One-Way nesting works fine (I knew it before), but for our study we need the two-way, to prove its superiority compare to the one-way. 3) I scaled the bottom drag for eac...
by Eugen
Tue Feb 27, 2018 2:52 pm
Forum: ROMS Problems
Topic: Contact point problem with salinity in Two Way Nesting run
Replies: 6
Views: 1740

Contact point problem with salinity in Two Way Nesting run

Dear ROMS users, I have a bizarre problem at the contact point layer in the configuration of a coarse grid and a fine grid, nested inside of the domain with TWO-WAY interaction. I've spotted bizarre residual currents across the grid frame in my highly tidal region (North Sea). I had a close look at ...
by Eugen
Thu Nov 23, 2017 12:28 pm
Forum: ROMS Problems
Topic: Boundary condition type definition at river point sources
Replies: 2
Views: 1076

Boundary condition type definition at river point sources

Dear all, I have a problem with tidal forcing on my domain. The tidal amplitudes are too big in semi-closed bays. How to define a boundary condition type at river point sources (like we have to do for open boundaries), to make the tides propagate? The image below is a bias in [m]: M2 tidal amplitude...
by Eugen
Wed Jun 28, 2017 3:15 pm
Forum: ROMS Problems
Topic: Tidal modes twice bigger in the results, than in the forcing
Replies: 0
Views: 914

Tidal modes twice bigger in the results, than in the forcing

Dear ROMS users, For validation of tides at the domain of the North Sea, I decomposed SSH and U, V- velocity components from the results by using the pytides python tool. Then I compared tidal amplitudes from the results at the points in the center of the domain with the amplitudes from the in-situ ...
by Eugen
Mon Apr 17, 2017 9:34 am
Forum: ROMS Problems
Topic: The model does not read the Forcing file for the Child grid
Replies: 6
Views: 2291

Re: The model does not read the Forcing file for the Child g

Thank you, wilkin Yes, I confirm , that the Forcing file for the parent grid is being read twice: for the parent and for the child grids. But how can I make ROMS reading the Forcing file for the child grid ? This experience suggests that for added clarity we should have stdout explicitly report whic...
by Eugen
Fri Apr 14, 2017 10:17 am
Forum: ROMS Problems
Topic: The model does not read the Forcing file for the Child grid
Replies: 6
Views: 2291

Re: The model does not read the Forcing file for the Child g

Thanks, John , I can assume this, on the basis of netcdf pictures. For example, short-wave radiation, the variable I have to define. On the left hand-side - how it does look in the Forcing file. On the right hand-side - how it does look at the history outputs. https://pp.userapi.com/c837232/v8372323...
by Eugen
Thu Apr 13, 2017 4:17 pm
Forum: ROMS Problems
Topic: The model does not read the Forcing file for the Child grid
Replies: 6
Views: 2291

The model does not read the Forcing file for the Child grid

Hello, everyone! For my nesting simulations, I made a forcing files for both, the parent and the child grids. However, I noticed, that ROMS, instead of reading and processing the child forcing file, interpolates data from the parent forcing file into the child grid. What could be the reason? Here is...
by Eugen
Mon Mar 20, 2017 12:39 pm
Forum: ROMS Bugs
Topic: WET-DRY points initialization, how they go from DRY to WET?
Replies: 7
Views: 3255

Re: WET-DRY points initialization, how they go from DRY to W

Thank you, Kate ! Btw, we found two possible ways to overcome this problem. First way : the subroutine LIMIT_STFLX_COOLING , which prevents temperature of going too low. It works fine, but it is a rude way. Second way : the added a condition into the subroutine step3D_t to keep temperature the same,...
by Eugen
Thu Mar 16, 2017 3:13 pm
Forum: ROMS Bugs
Topic: WET-DRY points initialization, how they go from DRY to WET?
Replies: 7
Views: 3255

Re: WET-DRY points initialization, how they go from DRY to W

jcwarner wrote:can you put that rmask_wet in pre_step3d.F that i showed above?
-j
I'm sorry, but isn't it already there?
by Eugen
Thu Mar 16, 2017 1:54 pm
Forum: ROMS Bugs
Topic: WET-DRY points initialization, how they go from DRY to WET?
Replies: 7
Views: 3255

Re: WET-DRY points initialization, how they go from DRY to W

Yes, I use BULK_FLUXES subroutine. And in its code I saw the multiplication on rmask_wet for longwave , sensible , latent and heat fluxes , and the wind stress . Here is a complete list of subroutines, which I use: #define ROMS_MODEL #undef NESTING #define MASKING #define UV_ADV #define UV_SADVECTIO...
by Eugen
Wed Mar 15, 2017 5:04 pm
Forum: ROMS Bugs
Topic: WET-DRY points initialization, how they go from DRY to WET?
Replies: 7
Views: 3255

WET-DRY points initialization, how they go from DRY to WET?

Hello, everyone, As a continuation of this topic (https://www.myroms.org/forum/viewtopic.php?f=19&t=4423), we decided to output all model variables at the 'problematic' point of model’s explosion (during long-time simulations), in order to investigate why. It seems, that temperature goes randomly (?...
by Eugen
Thu Feb 02, 2017 2:31 pm
Forum: ROMS Bugs
Topic: Climatological run error: temperature vanishing
Replies: 3
Views: 1946

Re: Climatological run error: temperature vanishing

kate , thank you for the answer! The error remains again, also during interannual (10 years) real-data run. We think, that anomalous low temperatures could be a reason of this numerical error. I have many of them occasionally occurring time-by-time along the grid mask. But most of the time, the mod...
by Eugen
Tue Jan 24, 2017 2:54 pm
Forum: ROMS Bugs
Topic: Climatological run error: temperature vanishing
Replies: 3
Views: 1946

Climatological run error: temperature vanishing

Hi, I have a strange problem with the climatological multi-year simulation in ROMS. I force the model by a climatological atmospheric forcing, climatological boundary conditions and climatological nudging at the open boundaries. And also with climatological river point sources and tides. So all the ...