Search found 19 matches

by Paul_Budgell
Sat Dec 17, 2016 9:38 pm
Forum: Job Opportunities
Topic: Ecosystem modelling position at IMR, Bergen, Norway
Replies: 0
Views: 1453

Ecosystem modelling position at IMR, Bergen, Norway

A permanent position for an ecosystem modeller has become available at the Institute of Marine Research, Bergen, Norway. See attached.

Regards
Paul Budgell
by Paul_Budgell
Tue Oct 11, 2016 12:15 pm
Forum: ROMS Discussion
Topic: Spurious supercooling in ROMS-CICE simulation
Replies: 33
Views: 6884

Re: Spurious supercooling in ROMS-CICE simulation

With regard to MPDATA you were discussing a couple of days ago, unless the code has changed it won't work properly for subzero temperatures. It works at keeping things "positive". I have needed to, say, add 5 degrees to temperature, do the advection with MPDATA, then subtract 5 degrees. I don't know...
by Paul_Budgell
Wed Apr 02, 2014 6:15 pm
Forum: ROMS Discussion
Topic: 3-level nesting
Replies: 3
Views: 1053

3-level nesting

Has anyone been able to run a 3-level nest with ROMS 3.7? I can get a 2-level nest to run fine, but I'm not able to get contact.m to generate contact points file for a 3-level nest, in which Grid 2 is nested into Grid 1 at 3:1 grid refinement and Grid 3 nests into Grid 2 at 3:1 refinement. I couldn'...
by Paul_Budgell
Sun Mar 09, 2014 2:02 pm
Forum: ROMS Ice
Topic: SST big problem use ROMS sea ice define BULK_FLUX
Replies: 6
Views: 4945

Re: SST big problem use ROMS sea ice define BULK_FLUX

I think I see your problem now. Just put your Pair the way you originally had it and #undef CORE_FORCING. You will also need to make sure you have the right setting for relative humidity in your varinfo.dat. You clearly are using relative, not specific humidity, so the cppdef above will cause ROMS t...
by Paul_Budgell
Sun Mar 09, 2014 4:05 am
Forum: ROMS Ice
Topic: SST big problem use ROMS sea ice define BULK_FLUX
Replies: 6
Views: 4945

Re: SST big proble use ROMS sea ice define BULK_FLUX

No, that should be OK - the important thing is the 0.01 factor. You need to see what the forcing variables look like as they are being read in (their ranges are written out at input times). That will tell you if your variables are in the right range, i.e., you can catch problems like air temps being...
by Paul_Budgell
Sun Mar 09, 2014 1:05 am
Forum: ROMS Ice
Topic: SST big problem use ROMS sea ice define BULK_FLUX
Replies: 6
Views: 4945

Re: SST big proble use ROMS sea ice define BULK_FLUX

Looks like some issue with units. Have you converted sea level pressure from Pascals to Hectopascals (mb) in varinfo.dat?
by Paul_Budgell
Tue Oct 25, 2011 1:52 am
Forum: ROMS Discussion
Topic: NONLIN_EOS in upwelling example creates velocities
Replies: 6
Views: 2212

Re: NONLIN_EOS in upwelling example creates velocities

As I understand it, when constant T and S are used with a linear equation of state, the velocities are indeed zero. The non-zero velocities crop up when a nonlinear equation of state is used. This makes sense since there is a compressibility condition in the full, nonlinear equation of state which w...
by Paul_Budgell
Fri Sep 11, 2009 6:05 pm
Forum: ROMS Ice
Topic: Sea Ice code
Replies: 4
Views: 3396

Re: Sea Ice code

I basically have to recreate them. I hope to do this real soon now. I will post them to Kate where they can live happily on her branch.

Paul
by Paul_Budgell
Wed Aug 12, 2009 2:28 am
Forum: ROMS Ice
Topic: Sea Ice code
Replies: 4
Views: 3396

Re: Sea Ice code

Yes, there are 2 test cases: ICE_BASIN and ICE_OCEAN_1D. I will set up the input files and test the setup - I wrote these cases some time ago, so it would be a good idea to update them for the current model version.
by Paul_Budgell
Sat Mar 21, 2009 1:11 am
Forum: ROMS Bugs
Topic: Possible bug regarding humidity and ice
Replies: 7
Views: 4442

Re: Possible bug regarding humidity and ice

Actually, now I use a SPECIFIC_HUMIDITY directive like Kate does and units are kg/kg. You also need to apply the modified humidity calculation in computing net solar radiation at the surface in ana_srflx.h, as well, if using ANA_SRFLX. The way ROMS does it in the standard release fails over the very...
by Paul_Budgell
Fri Feb 06, 2009 3:37 am
Forum: ROMS Discussion
Topic: Probable bug in I/O when MPI and NS_PERIODIC are used
Replies: 4
Views: 1844

Re: Probable bug in I/O when MPI and NS_PERIODIC are used

Did you #undef ANA_GRID and read in a grid file? The default RIVERPLUME1 configuration works fine because it doesn't input the grid data.
by Paul_Budgell
Fri Feb 06, 2009 1:52 am
Forum: ROMS Discussion
Topic: Probable bug in I/O when MPI and NS_PERIODIC are used
Replies: 4
Views: 1844

Re: Probable bug in I/O when MPI and NS_PERIODIC are used

I just ran the same set up on version 298 and it worked fine. So, it looks as though the bug(s) were introduced in the last major upgrade with changes in parallel I/O.
by Paul_Budgell
Thu Feb 05, 2009 10:35 pm
Forum: ROMS Discussion
Topic: Probable bug in I/O when MPI and NS_PERIODIC are used
Replies: 4
Views: 1844

Probable bug in I/O when MPI and NS_PERIODIC are used

I have found that if I use MPI in combination with NS_PERIODIC, version #306 crashes. I have been able to replicate the problem with one of the analytical test cases, RIVERPLUME1. If I run the RIVERPLUME1 case as it comes with the version 306 distribution, it runs - no problem. But if I read the gri...
by Paul_Budgell
Fri Jan 19, 2007 11:00 am
Forum: ROMS Problems
Topic: ROMS 2.0 with MPI
Replies: 6
Views: 2790

I/O on large array?

Have you tried:

#define INLINE_2DIO

Perhaps there are some issues with reading in large 3D arrays all at once. Reading them in level by level might help.
by Paul_Budgell
Wed Oct 04, 2006 1:29 pm
Forum: ROMS Problems
Topic: MPI 1 by 1 tile configuration --segmentation error
Replies: 11
Views: 4537

Actually, the -inherit_limits is an option for mpirun/mpimon . The point is that you should be sure that the limits you have set in your user shell are actually transmitted to the MPI process. If not, then if you are using ifort, for example, you will likely get a segmentation fault because the defa...
by Paul_Budgell
Wed Oct 04, 2006 9:30 am
Forum: ROMS Problems
Topic: MPI 1 by 1 tile configuration --segmentation error
Replies: 11
Views: 4537

I was getting similar problems on an HP Itanium cluster. What happened there was that the limits in the user shell were not transferred by default to the MPI job. The problem was fixed in that case by adding the -inherit_limits option on the mpiexec command line. Then the unlimited stacksize setting...
by Paul_Budgell
Tue Aug 30, 2005 3:11 pm
Forum: ROMS Discussion
Topic: ROMS on Itanium with MPI and ifort
Replies: 3
Views: 2479

Thanks Hernan. I have now tried using the corrected (Aug. 11) version of ROMS 2.2 with the UPWELLING case and get the same problem. If I use Lm=41, Mm=80, N=16 (in mod_param.F), with NtileI=2, NtileJ=4 (in External/ocean_upw.in), everything works fine. But if I use Lm=252, Mm=296, N=30 (same as lane...
by Paul_Budgell
Fri Aug 26, 2005 9:21 am
Forum: ROMS Discussion
Topic: ROMS on Itanium with MPI and ifort
Replies: 3
Views: 2479

ROMS on Itanium with MPI and ifort

I have been having horrific problems trying to run ROMS 2.1 with MPI on an HP Itanium cluster and ifort 8.1. No matter what I try, I cannot run on more than one 4-processor node. Does anyone else in the ROMS community have experience with ROMS and MPI+Itanium+ifort? The same model configuration work...
by Paul_Budgell
Wed Feb 26, 2003 4:16 pm
Forum: ROMS Problems
Topic: ROMS on the IBM Regatta
Replies: 1
Views: 1748

ROMS on the IBM Regatta

Hi folks, As I had mentioned in an e-mail last January, our supercomputing here at IMR switched from the SGI Origin 2000 to an IBM Regatta (p690) at Parallab at the University of Bergen. We had tremendous problems running ROMS in parallel on the new system. By playing with some of the compiler switc...