Search found 61 matches

by xiaozhu557
Wed Jul 03, 2019 3:28 am
Forum: ROMS Discussion
Topic: Marchesiello's RSUP3 in ROMS?
Replies: 9
Views: 2122

Re: Marchesiello's RSUP3 in ROMS?

Yes, I have tried the split advection scheme on TS only at first, but got the same blow-up problem.

Do you have any other suggestion to figure out the spurious diapycnal mixing problem with ROMS?
by xiaozhu557
Tue Jul 02, 2019 7:43 am
Forum: ROMS Discussion
Topic: Marchesiello's RSUP3 in ROMS?
Replies: 9
Views: 2122

Re: Marchesiello's RSUP3 in ROMS?

When the time step is 120s, it just run three steps, while the time step is 10s, it run five steps. It always looks like occur around the open boundary with the maximum velocity over 20m/s, sometime the maximum velocity is over 160 m/s. The places with the maximum anormaly always occur near the land...
by xiaozhu557
Tue Jul 02, 2019 12:39 am
Forum: ROMS Discussion
Topic: Marchesiello's RSUP3 in ROMS?
Replies: 9
Views: 2122

Re: Marchesiello's RSUP3 in ROMS?

kate wrote:The easiest thing to try is a shorter timestep. Have you tried that?
Yes, I have tried. The original

Code: Select all

DT=180.0 
NDTFAST=30
It can work. But for the new scheme, I have tried it with

Code: Select all

dt=30.0
It still can not work. It just can run 3 steps.
by xiaozhu557
Mon Jul 01, 2019 2:21 pm
Forum: ROMS Discussion
Topic: Marchesiello's RSUP3 in ROMS?
Replies: 9
Views: 2122

Re: Marchesiello's RSUP3 in ROMS?

Hello all, I would like to follow this very old topic. Since I have faced the spurious diapycnal diffusion problem in the South China Sea. I have run my model with define #define TS_U3HADVECTION #define TS_C4VADVECTION It can run but with the spurious diapycnal diffusion problem that the temperature...
by xiaozhu557
Wed Mar 28, 2018 8:02 am
Forum: ROMS Adjoint
Topic: about the implicit upstream radiation condition
Replies: 0
Views: 804

about the implicit upstream radiation condition

Hello all, I have derived the implicit upstream radiation condition from Marchesiello et al.(2001). I found it should have an implicit assumption dx=dy (or om=on in ROMS). If not, the variables r_x (Cx in ROMS) and r_y (Cy in ROMS) should be dy*dy*dudt*dudx*alpha dx*dx*dudt*dudy*beta r_x= - --------...
by xiaozhu557
Tue Mar 27, 2018 1:39 pm
Forum: ROMS Adjoint
Topic: question about the caculating of om_p, om_u, on_p, on_u
Replies: 5
Views: 1572

Re: question about the caculating of om_p, om_u, on_p, on_u

I have got it. Thanks all your replying. :)
by xiaozhu557
Mon Mar 26, 2018 7:56 am
Forum: ROMS Adjoint
Topic: question about the caculating of om_p, om_u, on_p, on_u
Replies: 5
Views: 1572

question about the caculating of om_p, om_u, on_p, on_u

Hello everyone, I am not understand the caculating of om_p, om_u, on_p, on_u, om_v, on_v. In the file mod_grid.F , they are discribed as ! om_p PSI-grid spacing (meters) in the XI-direction. ! ! om_r RHO-grid spacing (meters) in the XI-direction. ! ! om_u U-grid spacing (meters) in the XI-direction....
by xiaozhu557
Fri Sep 29, 2017 7:57 am
Forum: ROMS Problems
Topic: mp_collect bug when compiling with define PARALLEL_IO
Replies: 8
Views: 4032

Re: mp_collect bug when compiling with define PARALLEL_IO

I assume that you already know that all input files need to be NetCDF4 (HDF5) type files. Also, all output files are the NetCDF4 type. I am planning to make an update the code tomorrow to give the user more options fine-tune the MPI communications an accelerate the I/O. Hello, Arango, would you lik...
by xiaozhu557
Tue Sep 26, 2017 1:37 am
Forum: ROMS Problems
Topic: mp_collect bug when compiling with define PARALLEL_IO
Replies: 8
Views: 4032

Re: mp_collect bug when compiling with define PARALLEL_IO

Many thanks Kate and Arango.

It is a good news to me. I am using super-computer to run ROMS.

Hopefully I can get your new version ASAP.
by xiaozhu557
Sun Sep 24, 2017 11:59 am
Forum: ROMS Problems
Topic: mp_collect bug when compiling with define PARALLEL_IO
Replies: 8
Views: 4032

Re: mp_collect bug when compiling with define PARALLEL_IO

Thank you for your reminding on the compression of the output, Kate.

I would like to know whether you have the mp_collect_f routine to the interface with the 2-D array ? Since I am not good at the parallel programming. If you have, could you share it with me?

Thanks.
by xiaozhu557
Sat Sep 23, 2017 7:16 am
Forum: ROMS Problems
Topic: mp_collect bug when compiling with define PARALLEL_IO
Replies: 8
Views: 4032

Re: mp_collect bug when compiling with define PARALLEL_IO

Thanks for your reply, Kate. It is also real(r8), intent(inout) :: A(Npts) in my copy. I am sorry for the error in my last post. I have fixed it in my last post. But I would like to let you know that the bug which I mentioned in my last post is caused by the disagreement between the shapes of the ac...
by xiaozhu557
Fri Sep 22, 2017 4:35 am
Forum: ROMS Problems
Topic: mp_collect bug when compiling with define PARALLEL_IO
Replies: 8
Views: 4032

mp_collect bug when compiling with define PARALLEL_IO

Dear all, I want to try the parallel input/output in order to increase the speed of I/O. But I have found a bug with the function mp_collect when I compiled the ROMS code 857 with the option #define PARALLEL_IO . I have double checked that the parameter A of function mp_collect_f(ng,model,Npts,Aspv,...
by xiaozhu557
Thu Sep 21, 2017 3:17 am
Forum: ROMS Bugs
Topic: mp_collect bug when compiling with define PARALLEL_IO
Replies: 0
Views: 1087

mp_collect bug when compiling with define PARALLEL_IO

Dear all, I want to try the parallel input/output in order to increase the speed of I/O. But I have found a bug with the function mp_collect when I compiled the ROMS code 857 with the option #define PARALLEL_IO . I have double checked that the parameter A of function mp_collect_f(ng,model,Npts,Aspv,...
by xiaozhu557
Wed Sep 07, 2016 3:30 am
Forum: ROMS Discussion
Topic: assimilate TSLA into the restart fields of my ROMS model
Replies: 6
Views: 2835

Re: assimilate TSLA into the restart fields of my ROMS model

The point of having a PERFECT RESTART option in ROMS is to be able to be able to restart a run as if it were never interrupted. To do so it needs all levels that are carried for the 3td-order predictor-corrector time stepping. Since you propose to change the ocean state with an offline analysis, pe...
by xiaozhu557
Wed Sep 07, 2016 3:22 am
Forum: ROMS Discussion
Topic: assimilate TSLA into the restart fields of my ROMS model
Replies: 6
Views: 2835

Re: assimilate TSLA into the restart fields of my ROMS model

Wilkin, thanks for your kindly replying very much. Since I found the re-calculated results of restarting with the HISFILE or non-perfect restart RSTFILE were different from the original results without restart. For example, (1)I run the model from Jan 1st, 2000 to Dec. 31, 2000 directly without PERF...
by xiaozhu557
Mon Sep 05, 2016 1:14 pm
Forum: ROMS Discussion
Topic: assimilate TSLA into the restart fields of my ROMS model
Replies: 6
Views: 2835

assimilate TSLA into the restart fields of my ROMS model

I'm trying to use EnKF to assimilate TSLA(along-track Sea Level Anomaly) data into the restart fields of my ROMS model. I have defined the PERFECT_RESTART option while compling ROMS. And my assimilation is offline. My CPP options associated with momentum equations is UV_U3HADVECTION, UV_C4VADVECTION...
by xiaozhu557
Wed Mar 25, 2015 8:22 am
Forum: ROMS Discussion
Topic: the forcing fields from input and output are not the same
Replies: 7
Views: 1321

Re: the forcing fields from input and output are not the sa

Thanks for your kindly responding. I am sorry for my later.

I forget that I have #defined QCORRECTION. I think that should be the reason for my problem.

But I would like to know how should I set the model to let it regrid input? I have not defined nesting.

Thanks.
by xiaozhu557
Thu Mar 19, 2015 2:17 am
Forum: ROMS Discussion
Topic: the forcing fields from input and output are not the same
Replies: 7
Views: 1321

Re: the forcing fields from input and output are not the sa

kate wrote:ROMS is interpolating in time and space to obtain its field. Is your input field at exactly the starting time for your run?
Hi, Kate, could you continue to follow my question? Thanks a lot.
by xiaozhu557
Tue Mar 10, 2015 12:46 am
Forum: ROMS Discussion
Topic: the forcing fields from input and output are not the same
Replies: 7
Views: 1321

Re: the forcing fields from input and output are not the sa

kate wrote:ROMS is interpolating in time and space to obtain its field. Is your input field at exactly the starting time for your run?
Yes, it is. They are both for ocean_time=0.
by xiaozhu557
Thu Mar 05, 2015 2:18 am
Forum: ROMS Discussion
Topic: the forcing fields from input and output are not the same
Replies: 7
Views: 1321

the forcing fields from input and output are not the same

Hello, I have tried to compare the forcing field from input with output for the variable shflux (surface net heat flux). The followed three figures are the fields of input, output, and difference between of them on the first time step (ocean_time=0). I can not understand why they are not the same? I...
by xiaozhu557
Thu Feb 12, 2015 1:23 am
Forum: ROMS Discussion
Topic: how to keep constant temp when running tide only modal?
Replies: 5
Views: 1642

Re: how to keep constant temp when running tide only modal?

For a really simple tides-only problem you can turn off SOLVE3D. Then you won't have any temperature to be evolving. The one thing you would have to change in ocean.in is to set DT to your fast DT and NDTFAST to 1. I just want to run 3D model, not 2D, though I know 2D is enough for tide only case. ...
by xiaozhu557
Thu Feb 12, 2015 1:21 am
Forum: ROMS Discussion
Topic: how to keep constant temp when running tide only modal?
Replies: 5
Views: 1642

Re: how to keep constant temp when running tide only modal?

You don't need to define TS_FIXED for tide-only modeling. Just constant tempe/salt as you specified. It looks to me that your problem may be something to do with open boundaries. What's your cppdefs and ocean.in? Also, why did you edit ana_tobc.h? I don't think I did that for tide-only modeling. Ch...
by xiaozhu557
Tue Feb 10, 2015 7:44 am
Forum: ROMS Discussion
Topic: how to keep constant temp when running tide only modal?
Replies: 5
Views: 1642

Re: how to keep constant temp when running tide only modal?

Though I have not defined TS_FIXED, I have set the initial conditions, OBC to T0(ng), and set the surface and bottom fluxes to 0, by ana_initial, ana_tobc.h, ana_stflux.h and ana_btflux.h.

So I really can not understand why the temperature can be changed still during the LOOP?
by xiaozhu557
Tue Feb 10, 2015 3:34 am
Forum: ROMS Discussion
Topic: how to keep constant temp when running tide only modal?
Replies: 5
Views: 1642

how to keep constant temp when running tide only modal?

I am running the tides only model and keeping constant temp. But I have got the surface temperature as follow. I also found the temperature of all boundaries in the bottom layers are not constant. What's the reason for this?

Please find the attachment for my model's configure.
by xiaozhu557
Fri Jan 30, 2015 3:16 pm
Forum: ROMS Discussion
Topic: which index of zeta should I use to add POT_TIDES
Replies: 6
Views: 1620

Re: which index of zeta should I use to add POT_TIDES

Thank you so much Wilkin.
by xiaozhu557
Fri Jan 30, 2015 2:31 pm
Forum: ROMS Discussion
Topic: which index of zeta should I use to add POT_TIDES
Replies: 6
Views: 1620

Re: which index of zeta should I use to add POT_TIDES

Thanks,Wilkin. I understand it clearly. Could you continue to answer my frst question in my last post? (1) For the original version, add Ptide to the P. I found that if I define POT_TIDES, I have to define DJ_GRADPS. Because you have not add it in other files, prsgrd31.h, prsgrd40/2/4.h. I want to k...
by xiaozhu557
Fri Jan 30, 2015 2:15 am
Forum: ROMS Discussion
Topic: which index of zeta should I use to add POT_TIDES
Replies: 6
Views: 1620

Re: which index of zeta should I use to add POT_TIDES

Hello, Kate, thanks for your nice suggestions. (1) For the original version, add Ptide to the P. I found that if I define POT_TIDES, I have to define DJ_GRADPS. Because you have not add it in other files, prsgrd31.h, prsgrd40/2/4.h. I want to know why you did not add it in those files? If I want, co...
by xiaozhu557
Thu Jan 29, 2015 2:30 pm
Forum: ROMS Discussion
Topic: which index of zeta should I use to add POT_TIDES
Replies: 6
Views: 1620

which index of zeta should I use to add POT_TIDES

I am trying to add the POT_TIDES into set_tides.f90. In my opinion, after the codes, as follow, of calculating the Potential Tides, DO j=JstrR,JendR DO i=IstrR,IendR # ifdef TIDES_ASTRO ! Convert Vu_sat from cycles to radians Ptide(i,j)=Ptide(i,j)+ & & ramp*POT_Tamp(i,j,itide)* & & COS(-POT_Tphase(i...
by xiaozhu557
Wed Oct 29, 2014 8:29 am
Forum: ROMS Discussion
Topic: how to active ADJUST_BOUNDARY
Replies: 2
Views: 706

Re: how to active ADJUST_BOUNDARY

Where is it? I do not find it in the file cppdefs.h or globaldefs.h.

But I think it should be there
by xiaozhu557
Wed Oct 29, 2014 1:36 am
Forum: ROMS Discussion
Topic: how to active ADJUST_BOUNDARY
Replies: 2
Views: 706

how to active ADJUST_BOUNDARY

I do not know how to activate the option ADJUST_BOUNDARY in the version svn 724.
I have searched it in the file cppdefs.h and globaldefs.h, but got nothing.

Anyone can tell me where is it? What does it do? And When should I activate it?

Many thanks.
by xiaozhu557
Mon Oct 27, 2014 4:03 am
Forum: ROMS Bugs
Topic: a small bug in inp_par.F
Replies: 2
Views: 1821

a small bug in inp_par.F

Hello all, I found a small bug in line 855 of the file inp_par.F. The original version is 854 #ifdef SOLVE3D 855 IF (LnudgeM3CLM(ng).or. & 856 & LnudgeM3CLM(ng).or. & 857 & ANY(LnudgeTCLM(:,ng))) THEN 858 Lnudging(ng)=.TRUE. 859 END IF 860 #else 861 IF (LnudgeM2CLM(ng)) THEN 862 Lnudging(ng)=.TRUE. ...
by xiaozhu557
Mon Mar 03, 2014 7:47 pm
Forum: ROMS Discussion
Topic: big jump occured when restart
Replies: 7
Views: 2049

Re: big jump occured when restart

I would check to make sure that PERFECT_RESTART really is giving a perfect restart for the options you have chosen. I see you are getting a warning about the little-used SMAGORINSKY options. Perhaps PERFECT_RESTART doesn't work with them. In other words: * Check to see if PERFECT_RESTART behaves as...
by xiaozhu557
Sat Mar 01, 2014 2:44 am
Forum: ROMS Discussion
Topic: big jump occured when restart
Replies: 7
Views: 2049

Re: big jump occured when restart

Hi Kate or anybody,

Can you give me any clue for this problem? I really need your help.

Thanks.
by xiaozhu557
Thu Feb 20, 2014 2:19 am
Forum: ROMS Discussion
Topic: big jump occured when restart
Replies: 7
Views: 2049

Re: big jump occured when restart

Did you check to make sure that PERFECT_RESTART was defined in your model output? It was not correct in your post above. Misspellings will cause ROMS to ignore your #define directives. Yes, I have checked that it was defined. I just typed incorrectly in my last post. Sorry about that. Here is some ...
by xiaozhu557
Wed Feb 19, 2014 8:42 pm
Forum: ROMS Discussion
Topic: big jump occured when restart
Replies: 7
Views: 2049

big jump occured when restart

I have a trouble with RESTART even I defined PERFECT_RESTART . For the first run, it ended in 930240 step, the screen output like this 930238 3229 23:50:00 2.343559E-03 2.323374E+04 2.323374E+04 4.688070E+17 (0389,498,18) 6.291085E-03 3.352070E-03 1.438732E-01 2.145083E+00 930239 3229 23:55:00 2.343...
by xiaozhu557
Tue Feb 11, 2014 2:56 am
Forum: ROMS Bugs
Topic: possible bug with TCLIMATOLOGY
Replies: 4
Views: 2647

Re: possible bug with TCLIMATOLOGY

Thanks for your nice reply. Dear Arango, Can you show me the places in code where the TCLIMATOLOGY is used for isopycnal mixing corrections, nudging, and adjoint sensitivity? I have searched it in all the ROMS codes, just found it used for boundary conditions as pointed out in my last post, but not ...
by xiaozhu557
Fri Feb 07, 2014 4:23 pm
Forum: ROMS Bugs
Topic: possible bug in ana_m3obc.h
Replies: 0
Views: 956

possible bug in ana_m3obc.h

I have tried to compile the code Version 3.7 svn 658 for tide only case with #defined ANA_M3OBC , but I have got an error as the variable ieast iwest isouth inorth have not been defined. So I think that we should add a line in ana_m3obc.h , as follow: ! !*********************************************...
by xiaozhu557
Fri Feb 07, 2014 4:10 pm
Forum: ROMS Bugs
Topic: possible bug with TCLIMATOLOGY
Replies: 4
Views: 2647

possible bug with TCLIMATOLOGY

I found the defined settings for TCLIMATOLOGY in files tl_step3d_t.F , step3d_t.F , rp_step3d_t.F , nesting.F and so on, as follow # if defined TCLM_NUDGING && defined TCLIMATOLOGY it means that the following code can be run only when both of them are defined, but in other files, such as get_data.F ...
by xiaozhu557
Tue Jan 07, 2014 5:46 pm
Forum: ROMS Bugs
Topic: how to call the function get_3dfld
Replies: 4
Views: 2435

Re: how to call the function get_3dfld

But why it can work when I run the model with only one processor? This is exactly confused me. Thanks.
by xiaozhu557
Tue Jan 07, 2014 5:19 pm
Forum: ROMS Bugs
Topic: how to call the function get_3dfld
Replies: 4
Views: 2435

Re: how to call the function get_3dfld

Thanks for your replying, arango. Also, you need to be sure that you added the proper metadata in varinfo.dat for the new variable and code the appropriate logic for idWbv in mod_ncparam.F. Yes, I have added it, I am sure. Or I can not compile it successful. Now my question is why the modifications ...
by xiaozhu557
Tue Jan 07, 2014 1:18 am
Forum: ROMS Bugs
Topic: how to call the function get_3dfld
Replies: 4
Views: 2435

how to call the function get_3dfld

Hello all, I want to add a 3D mixing coefficient and input it to the model as a forcing parameter. I have defined it in mod_forces.F as follow, # ifdef ECOSIM allocate ( FORCES(ng) % SpecIr(LBi:UBi,LBj:UBj,NBands) ) allocate ( FORCES(ng) % avcos(LBi:UBi,LBj:UBj,NBands) ) # endif !===================...
by xiaozhu557
Thu Nov 21, 2013 3:09 pm
Forum: ROMS Discussion
Topic: how to set tide_Pamp and tide_Pphase
Replies: 2
Views: 909

Re: how to set tide_Pamp and tide_Pphase

Hi Kate and all, Could you explain why do we need to input tide_Pphase and tide_Pamp for ROMS, even if we have added the define POT_tide? What is the role for those codes in POT_tide define? As far as I know, I do not need to prepare any input file for the tidal body forces in FVCOM model. Thanks.
by xiaozhu557
Mon Nov 11, 2013 8:17 pm
Forum: ROMS Discussion
Topic: a small bug in ana_m3obc.h
Replies: 0
Views: 734

a small bug in ana_m3obc.h

I have tried to compile the code Version 3.7 svn 658 for tide only case with #defined ANA_M3OBC , but I have got an error as the variable ieast iwest isouth inorth have not been defined. So I think that we should add a line in ana_m3obc.h , as follow: ! !*********************************************...
by xiaozhu557
Mon Nov 11, 2013 8:09 pm
Forum: ROMS Discussion
Topic: how to set tide_Pamp and tide_Pphase
Replies: 2
Views: 909

how to set tide_Pamp and tide_Pphase

I want to add the body force to calculate the potential tide. But I don't know how to set the input file for the variables tide_Pamp and tide_Pphase, especially for the tide_Pphase. Any one can give me any suggestion?

Thank you so much.
by xiaozhu557
Fri Nov 08, 2013 12:51 am
Forum: ROMS Discussion
Topic: can not understand the code in ana_nudgcoef.h
Replies: 3
Views: 1297

Re: can not understand the code in ana_nudgcoef.h

Hi Kate, thanks for your response. Two comments based on your reply, as follow (1) I know that # ifdef TCLM_NUDGING is in your ana_nudgcoef.h, and the codes posted in my last post just can work when I defined TCLM_NUDGING in *.h file. Of course, I have defined it. I just did not post it with them to...
by xiaozhu557
Thu Nov 07, 2013 3:53 am
Forum: ROMS Discussion
Topic: can not understand the code in ana_nudgcoef.h
Replies: 3
Views: 1297

can not understand the code in ana_nudgcoef.h

I have read the code in /ROMS/Functionals/ana_nudgcoef.h, I found its codes in line 460-469 as follow, 460 IF (DOMAIN(ng)%SouthWest_Corner(tile)) THEN 461 Tobc_out(itrc,ng,iwest)=CLIMA(ng)%Tnudgcof([b]0,1[/b],itrc) 462 Tobc_in (itrc,ng,iwest)=obcfac(ng)* & 463 & Tobc_out(itrc,ng,iwest) 464 END IF 46...
by xiaozhu557
Wed Nov 06, 2013 5:35 pm
Forum: ROMS Discussion
Topic: how to get the code of Tidal Potential for Version 3.7?
Replies: 0
Views: 844

how to get the code of Tidal Potential for Version 3.7?

Hi all,
How can I get the code of Tidal Potential for the newest Version 3.7? I want to run a tidal case with Tidal Potential.

Anyone can help me? Thanks.
by xiaozhu557
Thu Feb 28, 2013 2:56 am
Forum: ROMS Installation
Topic: variable change from kout to kstp(ng) when compling
Replies: 1
Views: 1436

variable change from kout to kstp(ng) when compling

Hello Everyone, I found some variables name changed while compling from *.F to *.f90. Such as in the file wrt_his.F Line 509 status=nf_fwrite3d(ng, iNLM, HIS(ng)%ncid, HIS(ng)%Vid(idUvel), & & HIS(ng)%Rindex, gtype, & & LBi, UBi, LBj, UBj, 1, N(ng), scale, & # ifdef MASKING & GRID(ng) % umask_io, & ...
by xiaozhu557
Thu Nov 29, 2012 1:56 am
Forum: ROMS Discussion
Topic: unable to define variable Tobc_in
Replies: 4
Views: 1426

Re: unable to define variable Tobc_in

Hi Kate, I had restarted the model with a restart file np8_rst.nc many times, it worked well. But I have to restart the model with a history file (np8_his_0013.nc) right now, because I have no the restart record in the restart file for that time point which I want. Now I have settings as follow: GRD...
by xiaozhu557
Thu Nov 29, 2012 1:15 am
Forum: ROMS Discussion
Topic: unable to define variable Tobc_in
Replies: 4
Views: 1426

Re: unable to define variable Tobc_in

It looks like you are running from a restart? Is this your first restart? Somehow it is trying to define a variable in your restart file, which should only happen when this file has been newly created. What value do you have for NRREC? Thanks for your reply,Kate. Yes, I am running from a restart wi...
by xiaozhu557
Wed Nov 28, 2012 6:43 am
Forum: ROMS Discussion
Topic: unable to define variable Tobc_in
Replies: 4
Views: 1426

unable to define variable Tobc_in

Hi everyone, I had got an error message when creating a new file (*_avg.nc or *_rst.nc) while model running. The error message as follow: STEP Day HH:MM:SS KINETIC_ENRG POTEN_ENRG TOTAL_ENRG NET_VOLUME C => (i,j,k) Cu Cv Cw Max Speed 1369440 4755 00:00:00 3.431246E-03 2.322748E+04 2.322748E+04 4.688...
by xiaozhu557
Sat Oct 27, 2012 12:31 pm
Forum: ROMS Problems
Topic: ROMS not running for 1 rank per node for 64 ranks for 17532
Replies: 1
Views: 1051

Re: ROMS not running for 1 rank per node for 64 ranks for 17

Hi prakrati, did fix the problem as you said? I have got the same problem, could you tell me how to fix it?

Or anyone have any suggestion? :cry:

Thanks.
by xiaozhu557
Sun Sep 16, 2012 1:40 pm
Forum: ROMS Bugs
Topic: negative temperature
Replies: 14
Views: 4420

Re: negative temperature

I have used the surface forcing data from NCEP Climate Forecast System Reanalysis (CFSR). The data base has provided some variables such as: 'UFLX_surface' ... %var1——momentum flux,U-Component [N/m^2] 'VFLX_surface' ... %var2——momentum flux,V-Component [N/m^2] 'DSWRF_surface' ... %var3——downward sho...
by xiaozhu557
Sun Sep 16, 2012 1:23 pm
Forum: ROMS Bugs
Topic: negative temperature
Replies: 14
Views: 4420

Re: negative temperature

Hello Arango,
I have got the same problem when I simulated Bohai Sea. But I also found the other problem is that sea water was over heated along the coast of Bohai Sea in summer, such as
by xiaozhu557
Sun Aug 26, 2012 2:14 pm
Forum: ROMS Discussion
Topic: ERROR: Illegal model configuration
Replies: 1
Views: 1777

ERROR: Illegal model configuration

Hello everyone, I have got an error as follow: ( I don't know the reason, I am confused. Anyone can tell me how to fix it?) 869 Activated C-preprocessing Options: 870 871 NP8 North Pacific Model 872 ANA_BSFLUX Analytical kinematic bottom salinity flux. 873 ANA_BTFLUX Analytical kinematic bottom temp...
by xiaozhu557
Fri May 18, 2012 12:49 am
Forum: ROMS Discussion
Topic: How can make sure proper river point position in ROMS
Replies: 15
Views: 7573

Re: How can make sure proper river point position in ROMS

Hi rduran, Thanks for your reply. I have tried your suggestion, that line lat=sign(LAT_rho(:)).*geomean(abs(LAT_rho(:))); can work, but the other line xfac=cos(lat*pi/180); set(gca,'DataAspectRatio',[1 xfac 1]); can not work, and I have got the error message with Error using horzcat CAT argument dim...
by xiaozhu557
Tue May 15, 2012 1:44 am
Forum: ROMS Discussion
Topic: How can make sure proper river point position in ROMS
Replies: 15
Views: 7573

Re: How can make sure proper river point position in ROMS

ok i know :P :P . it's the geometric mean . Under my MATLAB version, the function is geomean ! Hi Tony and all, When I run the script map_rivers.m and changed the code 'gmean' to 'geomean', I have got an error that Error using geomean(line 17) X may not contain negative values. ones the array LAT_r...
by xiaozhu557
Tue Dec 22, 2009 2:42 pm
Forum: ROMS Tools and Techniques
Topic: EASYGRID error
Replies: 1
Views: 1131

EASYGRID error

when i create the grid file by EASYGRID, it report a error! In the easygrid.m files, I set % Geographical and Grid parameters -------- lat = 0.86; % Latitude (degrees) of the bottom-left corner of the grid. lon = 99; % Longitude (degrees) of the bottom-left corner of the grid. X = 3120000; % Width o...
by xiaozhu557
Tue Dec 22, 2009 8:15 am
Forum: ROMS Usage
Topic: How to add coastal structures into model
Replies: 2
Views: 1699

Re: How to add coastal structures into model

when i creat the grid file by EASYGRID, it report a error! In the easygrid.m files, I set % Geographical and Grid parameters -------- lat = 0.86; % Latitude (degrees) of the bottom-left corner of the grid. lon = 99; % Longitude (degrees) of the bottom-left corner of the grid. X = 3120000; % Width of...
by xiaozhu557
Sun Dec 20, 2009 9:26 am
Forum: ROMS Problems
Topic: About easygrid's SMOOTH_GRID
Replies: 0
Views: 982

About easygrid's SMOOTH_GRID

Now I am running ROMS for simulating the SOUTH CHINA SEA, and after I changed for my depth from our group to create a grid: lat = 0.86; % Latitude (degrees) of the bottom-left corner of the grid. lon = 99; % Longitude (degrees) of the bottom-left corner of the grid. X = 3120000; % Width of domain (m...
by xiaozhu557
Fri Dec 18, 2009 7:51 am
Forum: ROMS Usage
Topic: a problem on easygrid
Replies: 0
Views: 1169

a problem on easygrid

when i creat the grid file by EASYGRID, it report a error! In the easygrid.m files, I set % Geographical and Grid parameters -------- lat = 0.86; % Latitude (degrees) of the bottom-left corner of the grid. lon = 99; % Longitude (degrees) of the bottom-left corner of the grid. X = 3120000; % Width of...