Search found 12 matches

by gerardo
Sat Mar 08, 2008 4:21 pm
Forum: ROMS Problems
Topic: compile ROMS3.0 using ifort
Replies: 5
Views: 2564

azhang wrote: I switched to ifort 8.0. ROMS3.0 was successfully compiled. I guess there might be bugs in ifort 9.0 Fortran compiler. If your license allows, instead of going to older versions, try to get the latest 10.0 or 10.1 compilers. They do a good job and allow the entire source to be compiled...
by gerardo
Fri Mar 07, 2008 2:09 am
Forum: ROMS Problems
Topic: compile ROMS3.0 using ifort
Replies: 5
Views: 2564

azhang wrote: I got the following error message, IPO link: can not find "(" ifort: error: problem during multi-file optimization compilation (code 1) kate wrote: Is that an error message from the compiler? It is, and it comes from the link step. It is most likely due to the use of the "-ipo" compile...
by gerardo
Thu Feb 07, 2008 2:36 pm
Forum: ROMS Discussion
Topic: ROMS Debug Approach
Replies: 6
Views: 2667

[...] Oh, for the good old days when the Cray compiler would let you dump core during the actual operation that caused the NaN/Inf so you could see what was going on. You can blame such default behavior (continuing to run way after infinities and NaNs have been produced by operations) on the IEEE s...
by gerardo
Fri Nov 30, 2007 1:58 pm
Forum: ROMS Installation
Topic: mpi error on SGI with the latest ROMS
Replies: 5
Views: 3680

isopycnal wrote: thank you very much if you can do the similar test. I will be glad to run your test case, but I will need to have copies of your .nc input files. Next week I will be traveling to Europe (to visit an institution where ROMS is also used), but the following week I should be able to bui...
by gerardo
Fri Nov 30, 2007 1:15 am
Forum: ROMS Installation
Topic: mpi error on SGI with the latest ROMS
Replies: 5
Views: 3680

when I tried to use fewer cpus(originally 16 cpus, now 8 cpus), it works using oceanM. Is this the reason for the error? I really don't know too much on the linux system. I don't understand why the error would occur with *fewer* processors, since in that case one would expect the application to req...
by gerardo
Thu Nov 29, 2007 6:59 pm
Forum: ROMS Installation
Topic: mpi error on SGI with the latest ROMS
Replies: 5
Views: 3680

isopycnal wrote: > [...] > MPI: On host a3700, Program /lun/home/liuzl/latest_roms/oceanM, Rank 11, Process 22290 received signal SIGSEGV(11) > [...] SIGSEGV(11) occurs for one of two reasons: a bad memory access (such as using out-of-range indices or a bad pointer), or trying to grow the stack beyo...
by gerardo
Thu Aug 09, 2007 1:20 pm
Forum: ROMS Problems
Topic: A problem about building OpenMP ROMS
Replies: 8
Views: 3354

Hernan,

Perhaps a check could be inserted somewhere in the make scripts
that terminates a build if USE_MPI and USE_OpenMP are both set?

Saludos,
--
Gerardo Cisneros
by gerardo
Wed Aug 01, 2007 12:29 pm
Forum: ROMS Problems
Topic: Compiling error in SGI workstation
Replies: 7
Views: 3190

linzhenhua wrote: > I have access to the same SGI as you.I just try ROMS on it. > At first I'm lazy to compile the netcdf library myself and > download the binary version from unidata,I meet with similiar > fortcom problems as you,but with a different fortran 90 file. > Then I compile the netcdf lib...
by gerardo
Tue Jul 31, 2007 12:55 pm
Forum: ROMS Problems
Topic: Compiling error in SGI workstation
Replies: 7
Views: 3190

Zhouwei, Judging from your post, it looks like you're using an Altix 330 server. I will assume you are using Intel Fortran 9.x compilers. I use a modified Linux-ifort.mk file. The differences are the following (Linux-ifort8.mk is the original Linux-ifort.mk file; Linux-ifort9.mk is mine): nuke[104] ...
by gerardo
Thu Feb 08, 2007 9:58 pm
Forum: ROMS Benchmarks
Topic: ROMS 3.0 on the Altix 4700, benchmarks
Replies: 1
Views: 2857

ROMS 3.0 on the Altix 4700, benchmarks

I ran the BENCHMARK1 and BENCHMARK2 test cases on 32 cores of an Altix 4700 with dual-core Itanium2 ("Montecito") processors (1.6GHz, 9MBL3 cache per core), and the BENCHMARK3 test case on 64, 128 and 192 cores of the same system. The benchmarks ran pretty much out of the box , with minor changes to...
by gerardo
Wed Feb 07, 2007 2:17 pm
Forum: ROMS Installation
Topic: segmentation fault
Replies: 11
Views: 4777

Thanks for your replay,Kate. It seems you are right that the problem lies in the optimizer switch -O3. I had the same error using -O2, but succeeded in compiling without using any of -O2 or -O3. However I ran into the same situation as in the first post. I wonder if the 'limit' you referred to is t...
by gerardo
Fri Oct 13, 2006 7:27 pm
Forum: ROMS Trivia
Topic: ROMS Acronym in different Languages
Replies: 4
Views: 5647

Re: ROMS Acronym in different Languages

The meaning of ROMS in Spanish is given as

Sistema Regional de Modelado Oceánico

The question is, what is it that's regional, the system or the modeling? If the latter, then a more appropriate translation would be:

Sistema de Modelado Oceánico Regional